ASP4-PSGI

Metadata

Analyzed metadata and errors of ASP4-PSGI.

{
   "abstracts_in_pod" : {
      "ASP4::PSGI" : "Run your ASP4 web application under PSGI/Plack."
   },
   "author" : "JOHND",
   "buildfile_executable" : 0,
   "dir_lib" : "lib",
   "dir_t" : "t",
   "dirs_array" : [
      "lib",
      "lib/ASP4",
      "t",
      "t/010-basic",
      "inc",
      "inc/Module",
      "inc/Module/Install"
   ],
   "dist" : "ASP4-PSGI",
   "dynamic_config" : 0,
   "error" : {},
   "extension" : "tar.gz",
   "extractable" : 1,
   "extracts_nicely" : 1,
   "file__build" : 0,
   "file_blib" : 0,
   "file_build" : 0,
   "file_changelog" : "Changes",
   "file_makefile" : 0,
   "file_makefile_pl" : "Makefile.PL",
   "file_manifest" : "MANIFEST",
   "file_meta_yml" : "META.yml",
   "file_pm_to_blib" : 0,
   "files_array" : [
      "Changes",
      "Makefile.PL",
      "META.yml",
      "MANIFEST",
      "lib/ASP4/PSGI.pm"
   ],
   "files_hash" : {
      "Changes" : {
         "mtime" : 1328076569,
         "size" : 341
      },
      "MANIFEST" : {
         "mtime" : 1285110747,
         "size" : 356
      },
      "META.yml" : {
         "mtime" : 1328076607,
         "size" : 566
      },
      "Makefile.PL" : {
         "mtime" : 1328076634,
         "size" : 316,
         "used" : [
            "5.008005",
            "inc::Module::Install",
            "strict",
            "warnings"
         ]
      },
      "inc/Module/Install.pm" : {
         "mtime" : 1235851697,
         "no_index" : 1,
         "size" : 8837
      },
      "inc/Module/Install/Base.pm" : {
         "mtime" : 1235851697,
         "no_index" : 1,
         "size" : 1064
      },
      "inc/Module/Install/Can.pm" : {
         "mtime" : 1235851697,
         "no_index" : 1,
         "size" : 1810
      },
      "inc/Module/Install/Fetch.pm" : {
         "mtime" : 1235851697,
         "no_index" : 1,
         "size" : 2454
      },
      "inc/Module/Install/Makefile.pm" : {
         "mtime" : 1235851697,
         "no_index" : 1,
         "size" : 6498
      },
      "inc/Module/Install/Metadata.pm" : {
         "mtime" : 1235851697,
         "no_index" : 1,
         "size" : 12853
      },
      "inc/Module/Install/Scripts.pm" : {
         "mtime" : 1237597735,
         "no_index" : 1,
         "size" : 513
      },
      "inc/Module/Install/Win32.pm" : {
         "mtime" : 1235851697,
         "no_index" : 1,
         "size" : 1794
      },
      "inc/Module/Install/WriteAll.pm" : {
         "mtime" : 1235851697,
         "no_index" : 1,
         "size" : 721
      },
      "lib/ASP4/PSGI.pm" : {
         "license" : "Perl_5",
         "module" : "ASP4::PSGI",
         "mtime" : 1328076489,
         "required" : [
            "ASP4::API"
         ],
         "size" : 3196,
         "used" : [
            "ASP4::SimpleCGI",
            "Plack::Request",
            "strict",
            "warnings"
         ]
      },
      "t/010-basic/010-compile.t" : {
         "mtime" : 1285108386,
         "no_index" : 1,
         "size" : 107,
         "used" : [
            "Test::More",
            "strict",
            "warnings"
         ]
      }
   },
   "got_prereq_from" : "META.yml",
   "included_modules" : [
      "Module::Install::Base",
      "Module::Install::WriteAll",
      "Module::Install",
      "Module::Install::Win32",
      "Module::Install::Makefile",
      "Module::Install::Scripts",
      "Module::Install::Fetch",
      "Module::Install::Can",
      "Module::Install::Metadata"
   ],
   "kwalitee" : {
      "buildtool_not_executable" : 1,
      "consistent_version" : 1,
      "distname_matches_name_in_meta" : 1,
      "extractable" : 1,
      "extracts_nicely" : 1,
      "has_abstract_in_pod" : 1,
      "has_buildtool" : 1,
      "has_changelog" : 1,
      "has_human_readable_license" : 1,
      "has_known_license_in_source_file" : 1,
      "has_license_in_source_file" : 1,
      "has_manifest" : 1,
      "has_meta_yml" : 1,
      "has_proper_version" : 1,
      "has_readme" : 0,
      "has_separate_license_file" : 0,
      "has_tests" : 1,
      "has_tests_in_t_dir" : 1,
      "has_version" : 1,
      "kwalitee" : "95.45",
      "manifest_matches_dist" : 1,
      "meta_json_conforms_to_known_spec" : 1,
      "meta_json_is_parsable" : 1,
      "meta_yml_conforms_to_known_spec" : 1,
      "meta_yml_declares_perl_version" : 0,
      "meta_yml_has_license" : 1,
      "meta_yml_has_provides" : 0,
      "meta_yml_has_repository_resource" : 0,
      "meta_yml_is_parsable" : 1,
      "no_abstract_stub_in_pod" : 1,
      "no_broken_auto_install" : 1,
      "no_broken_module_install" : 1,
      "no_dot_dirs" : 1,
      "no_dot_underscore_files" : 1,
      "no_generated_files" : 1,
      "no_invalid_versions" : 1,
      "no_local_dirs" : 1,
      "no_mymeta_files" : 1,
      "no_pax_headers" : 1,
      "no_pod_errors" : 1,
      "no_stdin_for_prompting" : 1,
      "no_symlinks" : 1,
      "package_version_matches_dist_version" : 1,
      "portable_filenames" : 1,
      "proper_libs" : 1,
      "use_strict" : 1,
      "use_warnings" : 1,
      "valid_signature" : 1
   },
   "latest_mtime" : 1328076634,
   "license" : "artistic defined in META.yml",
   "license_file" : "lib/ASP4/PSGI.pm",
   "license_from_yaml" : "artistic",
   "license_in_pod" : 1,
   "license_type" : "Perl_5",
   "licenses" : {
      "Perl_5" : [
         "lib/ASP4/PSGI.pm"
      ]
   },
   "manifest_matches_dist" : 1,
   "meta_yml" : {
      "abstract" : "Run your ASP4 web application under PSGI/Plack.",
      "author" : [
         "John Drago <jdrago_999@yahoo.com>"
      ],
      "distribution_type" : "module",
      "generated_by" : "Hand",
      "license" : "artistic",
      "meta-spec" : {
         "url" : "http://module-build.sourceforge.net/META-spec-v1.4.html",
         "version" : "1.4"
      },
      "name" : "ASP4-PSGI",
      "no_index" : {
         "directory" : [
            "t",
            "inc"
         ]
      },
      "requires" : {
         "ASP4" : "1.077",
         "PSGI" : "1.03",
         "Plack" : "0.9949"
      },
      "test_requires" : {
         "Test::More" : "0"
      },
      "version" : "0.004"
   },
   "meta_yml_is_parsable" : 1,
   "meta_yml_spec_version" : "1.4",
   "module_install" : {
      "version" : "0.79"
   },
   "modules" : [
      {
         "file" : "lib/ASP4/PSGI.pm",
         "in_basedir" : 0,
         "in_lib" : 1,
         "module" : "ASP4::PSGI"
      }
   ],
   "no_index" : "^inc/;^t/",
   "no_pax_headers" : 1,
   "package" : "ASP4-PSGI-0.004.tar.gz",
   "prereq" : [
      {
         "is_prereq" : 1,
         "requires" : "ASP4",
         "type" : "runtime_requires",
         "version" : "1.077"
      },
      {
         "is_prereq" : 1,
         "requires" : "Plack",
         "type" : "runtime_requires",
         "version" : "0.9949"
      },
      {
         "is_prereq" : 1,
         "requires" : "PSGI",
         "type" : "runtime_requires",
         "version" : "1.03"
      }
   ],
   "released_epoch" : 1328076780,
   "size_packed" : 14649,
   "size_unpacked" : 41426,
   "uses" : {
      "required_in_code" : {
         "ASP4::API" : 1
      },
      "used_in_code" : {
         "ASP4::SimpleCGI" : 1,
         "Plack::Request" : 1,
         "strict" : 1,
         "warnings" : 1
      },
      "used_in_config" : {
         "5.008005" : 1,
         "inc::Module::Install" : 1,
         "strict" : 1,
         "warnings" : 1
      },
      "used_in_tests" : {
         "Test::More" : 1,
         "strict" : 1,
         "warnings" : 1
      }
   },
   "valid_signature" : -1,
   "version" : "0.004",
   "versions" : {
      "lib/ASP4/PSGI.pm" : {
         "ASP4::PSGI" : "0.004"
      }
   },
   "vname" : "ASP4-PSGI-0.004"
}