The site is under maintenance.

Most probably the CPANTS databases are being regenerated from scratch behind the scenes due to the major change in Kwalitee metrics or the update of relevant modules/perl. Usually this maintenance takes about a day or two, and some of the information may be old or missing tentatively. Sorry for the inconvenience.

Apache-AuthzLDAP

Metadata

Analyzed metadata and errors of Apache-AuthzLDAP.

{
   "abstracts" : {
      "Apache::AuthzLDAP" : "mod_perl LDAP Authorization Module"
   },
   "author" : "CGILMORE",
   "buildfile_executable" : 0,
   "dirs_array" : [],
   "dist" : "Apache-AuthzLDAP",
   "dynamic_config" : 0,
   "easily_repackageable_by_debian" : "has_tests_in_t_dir",
   "easily_repackageable_by_fedora" : "fits_fedora_license",
   "error" : {
      "use_warnings" : "Apache::AuthzLDAP"
   },
   "extension" : "tar.gz",
   "extractable" : 1,
   "extracts_nicely" : 1,
   "file__build" : 0,
   "file_blib" : 0,
   "file_build" : 0,
   "file_changelog" : "ChangeLog",
   "file_makefile" : 0,
   "file_makefile_pl" : "Makefile.PL",
   "file_manifest" : "MANIFEST",
   "file_meta_yml" : "META.yml",
   "file_pm_to_blib" : 0,
   "file_readme" : "README",
   "files_array" : [
      "README",
      "SUPPORT",
      "AuthzLDAP.pm",
      "INSTALL",
      "Makefile.PL",
      "META.yml",
      "ChangeLog",
      "MANIFEST"
   ],
   "files_hash" : {
      "AuthzLDAP.pm" : {
         "module" : "Apache::AuthzLDAP",
         "mtime" : 1115656566,
         "size" : 30147,
         "used" : [
            "Apache::Constants",
            "Apache::Log",
            "Net::LDAP",
            "Text::ParseWords",
            "constant",
            "mod_perl",
            "strict"
         ]
      },
      "ChangeLog" : {
         "mtime" : 1115656566,
         "size" : 2331
      },
      "INSTALL" : {
         "mtime" : 969994311,
         "size" : 555
      },
      "MANIFEST" : {
         "mtime" : 1101937592,
         "size" : 383
      },
      "META.yml" : {
         "mtime" : 1115662061,
         "size" : 464
      },
      "Makefile.PL" : {
         "mtime" : 1044313461,
         "size" : 494,
         "used" : [
            "Config",
            "ExtUtils::MakeMaker",
            "strict"
         ]
      },
      "README" : {
         "mtime" : 969994311,
         "size" : 309
      },
      "SUPPORT" : {
         "mtime" : 969994311,
         "size" : 216
      }
   },
   "got_prereq_from" : "META.yml",
   "kwalitee" : {
      "buildtool_not_executable" : 1,
      "consistent_version" : 1,
      "easily_repackageable_by_debian" : 0,
      "easily_repackageable_by_fedora" : 0,
      "extractable" : 1,
      "extracts_nicely" : 1,
      "fits_fedora_license" : 0,
      "has_abstract_in_pod" : 1,
      "has_buildtool" : 1,
      "has_changelog" : 1,
      "has_human_readable_license" : 1,
      "has_known_license_in_source_file" : 0,
      "has_license_in_source_file" : 1,
      "has_manifest" : 1,
      "has_meta_yml" : 1,
      "has_proper_version" : 1,
      "has_readme" : 1,
      "has_separate_license_file" : 0,
      "has_tests" : 0,
      "has_tests_in_t_dir" : 0,
      "has_version" : 1,
      "kwalitee" : "85.37",
      "manifest_matches_dist" : 1,
      "metayml_conforms_to_known_spec" : 1,
      "metayml_declares_perl_version" : 0,
      "metayml_has_license" : 0,
      "metayml_has_provides" : 0,
      "metayml_is_parsable" : 1,
      "no_abstract_stub_in_pod" : 1,
      "no_broken_auto_install" : 1,
      "no_broken_module_install" : 1,
      "no_dot_dirs" : 1,
      "no_dot_underscore_files" : 1,
      "no_generated_files" : 1,
      "no_invalid_versions" : 1,
      "no_local_dirs" : 1,
      "no_mymeta_files" : 1,
      "no_pax_headers" : 1,
      "no_pod_errors" : 1,
      "no_stdin_for_prompting" : 1,
      "no_symlinks" : 1,
      "package_version_matches_dist_version" : 1,
      "portable_filenames" : 1,
      "proper_libs" : 1,
      "use_strict" : 1,
      "use_warnings" : 0,
      "valid_signature" : 1
   },
   "latest_mtime" : 1115662061,
   "license" : "defined in POD (AuthzLDAP.pm)",
   "license_in_pod" : 1,
   "manifest_matches_dist" : 1,
   "meta_yml" : {
      "distribution_type" : "module",
      "generated_by" : "ExtUtils::MakeMaker version 6.17",
      "installdirs" : "site",
      "meta-spec" : {},
      "name" : "Apache-AuthzLDAP",
      "requires" : {
         "Apache" : "1.26",
         "Apache::Log" : "1.01",
         "Net::LDAP" : "0.25",
         "Text::ParseWords" : "3.2"
      },
      "version" : "1.11",
      "version_from" : "AuthzLDAP.pm"
   },
   "metayml_is_parsable" : 1,
   "modules" : [
      {
         "file" : "AuthzLDAP.pm",
         "in_basedir" : 1,
         "in_lib" : 0,
         "module" : "Apache::AuthzLDAP"
      }
   ],
   "no_pax_headers" : 1,
   "package" : "Apache-AuthzLDAP-1.11.tar.gz",
   "prereq" : [
      {
         "is_prereq" : 1,
         "requires" : "Apache",
         "type" : "runtime_requires",
         "version" : "1.26"
      },
      {
         "is_prereq" : 1,
         "requires" : "Net::LDAP",
         "type" : "runtime_requires",
         "version" : "0.25"
      },
      {
         "is_prereq" : 1,
         "requires" : "Text::ParseWords",
         "type" : "runtime_requires",
         "version" : "3.2"
      },
      {
         "is_prereq" : 1,
         "requires" : "Apache::Log",
         "type" : "runtime_requires",
         "version" : "1.01"
      }
   ],
   "released_epoch" : 1115662667,
   "size_packed" : 11509,
   "size_unpacked" : 34899,
   "unknown_license_texts" : {
      "AuthzLDAP.pm" : "=head1 COPYRIGHT\n\nCopyright (C) 2004, International Business Machines Corporation\nand others. All Rights Reserved.\n\nThis module is free software; you can redistribute it and/or\nmodify it under the terms of the IBM Public License.\n\n"
   },
   "uses" : {
      "used_in_code" : {
         "Apache::Constants" : 1,
         "Apache::Log" : 1,
         "Net::LDAP" : 1,
         "Text::ParseWords" : 1,
         "constant" : 1,
         "mod_perl" : 1,
         "strict" : 1
      },
      "used_in_config" : {
         "Config" : 1,
         "ExtUtils::MakeMaker" : 1,
         "strict" : 1
      }
   },
   "valid_signature" : -1,
   "version" : "1.11",
   "versions" : {
      "AuthzLDAP.pm" : {
         "Apache::AuthzLDAP" : "1.11"
      }
   },
   "vname" : "Apache-AuthzLDAP-1.11"
}