Kwalitee Issues


Add tests!


Take a look at the META.yml Spec at (for version 1.4) or (for version 2), and change your META.yml accordingly.

Error: Expected a map structure from string or file. (requires) [Validation: 1.0]


Split the distribution, or fix the version numbers to make them consistent (use the highest version number to avoid version downgrade).

Error: 0.08,0.09,0.14


Add a META.json to the distribution. Your buildtool should be able to autogenerate it.


Add tests or move to the t/ directory!


If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.


Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.


Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: Apache::DB, Apache::DProf, Apache::SmallProf


This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.


Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.


Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).


Name Abstract Version View
Apache::DB Run the interactive Perl debugger under mod_perl 0.14 metacpan
Apache::DProf Hook Devel::DProf into mod_perl 0.08 metacpan
Apache::SmallProf Hook Devel::SmallProf into mod_perl 0.09 metacpan

Other Files

Changes metacpan
MANIFEST metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan