Apache-LoggedAuthDBI

Metadata

Analyzed metadata and errors of Apache-LoggedAuthDBI.

{
   "abstracts" : {
      "Apache::AuthDBI" : "Authentication and Authorization via Perl's DBI",
      "Apache::DBI" : "Initiate a persistent database connection"
   },
   "author" : "SIMKIN",
   "buildfile_executable" : 0,
   "dirs_array" : [],
   "dist" : "Apache-LoggedAuthDBI",
   "dynamic_config" : 0,
   "easily_repackageable_by_debian" : "has_tests_in_t_dir",
   "easily_repackageable_by_fedora" : "fits_fedora_license",
   "error" : {
      "consistent_version" : "0.11,0.98",
      "no_pod_errors" : "Apache-LoggedAuthDBI-0.11/AuthDBI.pm -- Around line 1088:  '=item' outside of any '=over'Around line 1221:  You forgot a '=back' before '=head1'Around line 1320:  '=item' outside of any '=over'Around line 1333:  You forgot a '=back' before '=head1'Apache-LoggedAuthDBI-0.11/DBI.pm -- POD ERRORSHey! The above document had some coding errors, which are explained below:Around line 417:  '=item' outside of any '=over'Around line 433:  You forgot a '=back' before '=head1'",
      "proper_libs" : "AuthDBI.pm, DBI.pm, LoggedAuthDBI.pm",
      "use_warnings" : "Apache::DBI, Apache::AuthDBI, Apache::LoggedAuthDBI"
   },
   "extension" : "tar.gz",
   "extractable" : 1,
   "extracts_nicely" : 1,
   "file__build" : 0,
   "file_blib" : 0,
   "file_build" : 0,
   "file_changelog" : "Changes",
   "file_makefile" : 0,
   "file_makefile_pl" : "Makefile.PL",
   "file_manifest" : "MANIFEST",
   "file_meta_yml" : "META.yml",
   "file_pm_to_blib" : 0,
   "file_readme" : "README",
   "file_test_pl" : "test.pl",
   "files_array" : [
      "pass_sharing.html",
      "README",
      "test.pl",
      "AuthDBI.pm",
      "Changes",
      "Makefile.PL",
      "META.yml",
      "blocked.html",
      "brute_force.html",
      "DBI.pm",
      "MANIFEST",
      "LoggedAuthDBI.pm"
   ],
   "files_hash" : {
      "AuthDBI.pm" : {
         "license" : "Perl_5",
         "module" : "Apache::AuthDBI",
         "mtime" : 1122851622,
         "required" : [
            "Apache2::Const",
            "Apache2::ServerUtil",
            "Apache::Constants",
            "IPC::SysV"
         ],
         "size" : 54756,
         "used" : [
            "DBI",
            "Digest::MD5",
            "Digest::SHA1",
            "strict"
         ]
      },
      "Changes" : {
         "mtime" : 1122852923,
         "size" : 225
      },
      "DBI.pm" : {
         "license" : "Perl_5",
         "module" : "Apache::DBI",
         "mtime" : 1122851619,
         "noed" : [
            "strict"
         ],
         "required" : [
            "Apache2::ServerUtil"
         ],
         "required_in_eval" : [
            "Apache",
            "Apache2::Module",
            "mod_perl2"
         ],
         "size" : 16217,
         "used" : [
            "Carp",
            "DBI",
            "strict"
         ]
      },
      "LoggedAuthDBI.pm" : {
         "license" : "Perl_5",
         "module" : "Apache::LoggedAuthDBI",
         "mtime" : 1122854000,
         "required" : [
            "Apache2::Const",
            "Apache::Constants"
         ],
         "size" : 11078,
         "used" : [
            "Apache::AuthDBI",
            "DBI",
            "Exporter",
            "strict",
            "vars"
         ]
      },
      "MANIFEST" : {
         "mtime" : 1122853142,
         "size" : 216
      },
      "META.yml" : {
         "mtime" : 1122854060,
         "size" : 390
      },
      "Makefile.PL" : {
         "mtime" : 1122850537,
         "size" : 321,
         "used" : [
            "ExtUtils::MakeMaker"
         ]
      },
      "README" : {
         "mtime" : 1122852919,
         "size" : 725
      },
      "blocked.html" : {
         "mtime" : 1122851612,
         "size" : 248
      },
      "brute_force.html" : {
         "mtime" : 1122851615,
         "size" : 237
      },
      "pass_sharing.html" : {
         "mtime" : 1122851613,
         "size" : 210
      },
      "test.pl" : {
         "mtime" : 1122848520,
         "size" : 666
      }
   },
   "got_prereq_from" : "META.yml",
   "kwalitee" : {
      "buildtool_not_executable" : 1,
      "consistent_version" : 0,
      "easily_repackageable_by_debian" : 0,
      "easily_repackageable_by_fedora" : 0,
      "extractable" : 1,
      "extracts_nicely" : 1,
      "fits_fedora_license" : 0,
      "has_abstract_in_pod" : 1,
      "has_buildtool" : 1,
      "has_changelog" : 1,
      "has_human_readable_license" : 1,
      "has_known_license_in_source_file" : 1,
      "has_license_in_source_file" : 1,
      "has_manifest" : 1,
      "has_meta_yml" : 1,
      "has_proper_version" : 1,
      "has_readme" : 1,
      "has_separate_license_file" : 0,
      "has_tests" : 1,
      "has_tests_in_t_dir" : 0,
      "has_version" : 1,
      "kwalitee" : "82.93",
      "manifest_matches_dist" : 1,
      "metayml_conforms_to_known_spec" : 1,
      "metayml_declares_perl_version" : 0,
      "metayml_has_license" : 0,
      "metayml_has_provides" : 0,
      "metayml_is_parsable" : 1,
      "no_abstract_stub_in_pod" : 1,
      "no_broken_auto_install" : 1,
      "no_broken_module_install" : 1,
      "no_dot_dirs" : 1,
      "no_dot_underscore_files" : 1,
      "no_generated_files" : 1,
      "no_invalid_versions" : 1,
      "no_local_dirs" : 1,
      "no_mymeta_files" : 1,
      "no_pax_headers" : 1,
      "no_pod_errors" : 0,
      "no_stdin_for_prompting" : 1,
      "no_symlinks" : 1,
      "package_version_matches_dist_version" : 1,
      "portable_filenames" : 1,
      "proper_libs" : 0,
      "use_strict" : 1,
      "use_warnings" : 0,
      "valid_signature" : 1
   },
   "latest_mtime" : 1122854060,
   "license" : "defined in POD (AuthDBI.pm)",
   "license_file" : "AuthDBI.pm,DBI.pm,LoggedAuthDBI.pm",
   "license_in_pod" : 1,
   "license_type" : "Perl_5",
   "licenses" : {
      "Perl_5" : [
         "AuthDBI.pm",
         "DBI.pm",
         "LoggedAuthDBI.pm"
      ]
   },
   "manifest_matches_dist" : 1,
   "meta_yml" : {
      "distribution_type" : "module",
      "generated_by" : "ExtUtils::MakeMaker version 6.17",
      "installdirs" : "site",
      "meta-spec" : {},
      "name" : "Apache-LoggedAuthDBI",
      "requires" : {
         "Apache::AuthDBI" : "0.93",
         "DBI" : "1"
      },
      "version" : "0.11",
      "version_from" : "LoggedAuthDBI.pm"
   },
   "metayml_is_parsable" : 1,
   "modules" : [
      {
         "file" : "AuthDBI.pm",
         "in_basedir" : 1,
         "in_lib" : 0,
         "module" : "Apache::AuthDBI"
      },
      {
         "file" : "DBI.pm",
         "in_basedir" : 1,
         "in_lib" : 0,
         "module" : "Apache::DBI"
      },
      {
         "file" : "LoggedAuthDBI.pm",
         "in_basedir" : 1,
         "in_lib" : 0,
         "module" : "Apache::LoggedAuthDBI"
      }
   ],
   "no_pax_headers" : 1,
   "package" : "Apache-LoggedAuthDBI-0.11.tar.gz",
   "prereq" : [
      {
         "is_prereq" : 1,
         "requires" : "Apache::AuthDBI",
         "type" : "runtime_requires",
         "version" : "0.93"
      },
      {
         "is_prereq" : 1,
         "requires" : "DBI",
         "type" : "runtime_requires",
         "version" : "1"
      }
   ],
   "released_epoch" : 1122854813,
   "size_packed" : 23126,
   "size_unpacked" : 85289,
   "uses" : {
      "noed_in_code" : {
         "strict" : 1
      },
      "required_in_code" : {
         "Apache2::Const" : 2,
         "Apache2::ServerUtil" : 4,
         "Apache::Constants" : 2,
         "IPC::SysV" : 1
      },
      "required_in_eval_in_code" : {
         "Apache" : 1,
         "Apache2::Module" : 1,
         "mod_perl2" : 1
      },
      "used_in_code" : {
         "Carp" : 1,
         "DBI" : 3,
         "Digest::MD5" : 1,
         "Digest::SHA1" : 1,
         "Exporter" : 1,
         "strict" : 4,
         "vars" : 1
      },
      "used_in_config" : {
         "ExtUtils::MakeMaker" : 1
      }
   },
   "valid_signature" : -1,
   "version" : "0.11",
   "versions" : {
      "AuthDBI.pm" : {
         "Apache::AuthDBI" : "0.98"
      },
      "DBI.pm" : {
         "Apache::DBI" : "0.98",
         "Apache::DBI::db" : "0.98"
      },
      "LoggedAuthDBI.pm" : {
         "Apache::LoggedAuthDBI" : "0.11"
      }
   },
   "vname" : "Apache-LoggedAuthDBI-0.11"
}