Apache-Scriptor

Metadata

Analyzed metadata and errors of Apache-Scriptor.

{
   "abstracts_in_pod" : {
      "Apache::Scriptor" : "Support for Apache handlers conveyor.\r"
   },
   "author" : "KOTEROV",
   "buildfile_executable" : 0,
   "dirs_array" : [],
   "dist" : "Apache-Scriptor",
   "error" : {
      "no_pod_errors" : "Apache-Scriptor-1.21/Scriptor.pm --  Around line 336:  Non-ASCII character seen before =encoding in 'òåêóùàÿ'. Assuming  ISO8859-1",
      "use_strict" : "Apache::Scriptor",
      "use_warnings" : "Apache::Scriptor"
   },
   "extension" : "tar.gz",
   "extractable" : 1,
   "extracts_nicely" : 1,
   "file__build" : 0,
   "file_blib" : 0,
   "file_build" : 0,
   "file_changelog" : "Changes",
   "file_makefile" : 0,
   "file_makefile_pl" : "Makefile.PL",
   "file_manifest" : "MANIFEST",
   "file_pm_to_blib" : 0,
   "file_readme" : "README",
   "file_test_pl" : "test.pl",
   "files_array" : [
      "Changes",
      "MANIFEST",
      "Makefile.PL",
      "README",
      "Scriptor.pm",
      "test.pl",
      "test.pl"
   ],
   "files_hash" : {
      "Changes" : {
         "mtime" : 1072974759,
         "size" : 339
      },
      "MANIFEST" : {
         "mtime" : 1115294580,
         "size" : 62
      },
      "Makefile.PL" : {
         "mtime" : 1101999106,
         "size" : 544,
         "used" : [
            "ExtUtils::MakeMaker"
         ]
      },
      "README" : {
         "mtime" : 1101999283,
         "size" : 1018
      },
      "Scriptor.pm" : {
         "module" : "Apache::Scriptor",
         "mtime" : 1115295190,
         "size" : 15049,
         "used" : [
            "CGI::WebOut",
            "Cwd"
         ]
      },
      "test.pl" : {
         "mtime" : 1005020712,
         "size" : 513
      }
   },
   "got_prereq_from" : "Makefile.PL",
   "kwalitee" : {
      "buildtool_not_executable" : 1,
      "consistent_version" : 1,
      "distname_matches_name_in_meta" : 1,
      "extractable" : 1,
      "extracts_nicely" : 1,
      "has_abstract_in_pod" : 1,
      "has_buildtool" : 1,
      "has_changelog" : 1,
      "has_human_readable_license" : 0,
      "has_known_license_in_source_file" : 0,
      "has_license_in_source_file" : 0,
      "has_manifest" : 1,
      "has_meta_yml" : 0,
      "has_proper_version" : 1,
      "has_readme" : 1,
      "has_separate_license_file" : 0,
      "has_tests" : 1,
      "has_tests_in_t_dir" : 0,
      "has_version" : 1,
      "kwalitee" : "79.55",
      "manifest_matches_dist" : 1,
      "meta_json_conforms_to_known_spec" : 1,
      "meta_json_is_parsable" : 1,
      "meta_yml_conforms_to_known_spec" : 1,
      "meta_yml_declares_perl_version" : 1,
      "meta_yml_has_license" : 0,
      "meta_yml_has_provides" : 1,
      "meta_yml_has_repository_resource" : 1,
      "meta_yml_is_parsable" : 1,
      "no_abstract_stub_in_pod" : 1,
      "no_broken_auto_install" : 1,
      "no_broken_module_install" : 1,
      "no_dot_dirs" : 1,
      "no_dot_underscore_files" : 1,
      "no_generated_files" : 1,
      "no_invalid_versions" : 1,
      "no_local_dirs" : 1,
      "no_mymeta_files" : 1,
      "no_pax_headers" : 1,
      "no_pod_errors" : 0,
      "no_stdin_for_prompting" : 1,
      "no_symlinks" : 1,
      "package_version_matches_dist_version" : 1,
      "portable_filenames" : 1,
      "proper_libs" : 1,
      "use_strict" : 0,
      "use_warnings" : 0,
      "valid_signature" : 1
   },
   "latest_mtime" : 1115295190,
   "license" : "",
   "manifest_matches_dist" : 1,
   "modules" : [
      {
         "file" : "Scriptor.pm",
         "in_basedir" : 1,
         "in_lib" : 0,
         "module" : "Apache::Scriptor"
      }
   ],
   "no_pax_headers" : 1,
   "package" : "Apache-Scriptor-1.21.tar.gz",
   "prereq" : [],
   "released_epoch" : 1115295628,
   "size_packed" : 7720,
   "size_unpacked" : 18038,
   "uses" : {
      "used_in_code" : {
         "CGI::WebOut" : 2,
         "Cwd" : 1
      },
      "used_in_config" : {
         "ExtUtils::MakeMaker" : 1
      }
   },
   "valid_signature" : -1,
   "version" : "1.21",
   "versions" : {
      "Scriptor.pm" : {
         "Apache::Scriptor" : "1.21",
         "Apache::Scriptor::Handlers" : "1.21"
      }
   },
   "vname" : "Apache-Scriptor-1.21"
}