Kwalitee Issues

has_abstract_in_pod

Provide a short description in the NAME section of the pod (after the module name followed by a hyphen) at least for the main module of this distribution.

has_license_in_source_file

Add =head1 LICENSE and the text of the license to the main module in your code.

has_tests

Add tests!

meta_yml_conforms_to_known_spec

Take a look at the META.yml Spec at http://module-build.sourceforge.net/META-spec-v1.4.html (for version 1.4) or http://search.cpan.org/perldoc?CPAN::Meta::Spec (for version 2), and change your META.yml accordingly.

Error: '<undef>' for 'Cache::FileCache' is not a valid version. (requires -> Cache::FileCache) [Validation: 1.0];'<undef>' for 'Data::Dumper' is not a valid version. (requires -> Data::Dumper) [Validation: 1.0];'<undef>' for 'Image::Magick' is not a valid version. (requires -> Image::Magick) [Validation: 1.0];'<undef>' for 'LWP::Simple' is not a valid version. (requires -> LWP::Simple) [Validation: 1.0];'<undef>' for 'Net::UPnP' is not a valid version. (requires -> Net::UPnP) [Validation: 1.0];'<undef>' for 'SOAP::Lite' is not a valid version. (requires -> SOAP::Lite) [Validation: 1.0];'<undef>' for 'URI::Escape' is not a valid version. (requires -> URI::Escape) [Validation: 1.0];'<undef>' for 'XML::Simple' is not a valid version. (requires -> XML::Simple) [Validation: 1.0]

no_pod_errors

Remove the POD errors. You can check for POD errors automatically by including Test::Pod to your test suite.

Error: Apache-UpnpImgBrowser-0.01/UpnpImgBrowser.pm -- Around line 44: =over without closing =back Apache-UpnpImgBrowser-0.01/UpnpImgBrowser.pm -- Around line 44: =over without closing =back

has_known_license_in_source_file

Add =head1 LICENSE and/or the proper text of the well-known license to the main module in your code.

has_meta_json

Add a META.json to the distribution. Your buildtool should be able to autogenerate it.

has_tests_in_t_dir

Add tests or move tests.pl to the t/ directory!

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

meta_yml_has_license

Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.

use_warnings

Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: Apache::UpnpImgBrowser

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

meta_yml_has_repository_resource

Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).

Modules

Name Abstract Version View
Apache::UpnpImgBrowser 0.01 metacpan

Other Files

MANIFEST metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan