Kwalitee Issues


Run a proper command ("make manifest" or "./Build manifest", maybe with a force option), or use a distribution builder to generate the MANIFEST. Or update MANIFEST manually.


  • MANIFEST (71) does not match dist (103):
  • Missing in MANIFEST: Build, Build.bat, Makefile, cnr.bat, images/widget-gtk-button.png, images/widget-gtk-calendar.png, images/widget-gtk-checkbutton.png, images/widget-gtk-combo.png, images/widget-gtk-dialog.png, images/widget-gtk-entry.png, images/widget-gtk-hscale.png, images/widget-gtk-label.png, images/widget-gtk-list.png, images/widget-gtk-menubar.png, images/widget-gtk-progressbar.png, images/widget-gtk-radiobutton.png, images/widget-gtk-vscrollbar.png, pod2htmd.tmp, pod2htmi.tmp, setup/images/stuff, setup/images/widget-gtk-button.png, setup/images/widget-gtk-calendar.png, setup/images/widget-gtk-checkbutton.png, setup/images/widget-gtk-combo.png, setup/images/widget-gtk-dialog.png, setup/images/widget-gtk-entry.png, setup/images/widget-gtk-hscale.png, setup/images/widget-gtk-label.png, setup/images/widget-gtk-list.png, setup/images/widget-gtk-menubar.png, setup/images/widget-gtk-progressbar.png, setup/images/widget-gtk-radiobutton.png, setup/images/widget-gtk-vscrollbar.png, setup/stencils/asciio
  • Duplicates in MANIFEST: README, setup/stencils/guiio


Remove the offending files/directories!

Error: Build, Makefile


Remove the POD errors. You can check for POD errors automatically by including Test::Pod to your test suite.

Error: App-Guiio-0.991/lib/App/ -- Around line 75: Non-ASCII character seen before =encoding in 'Gábor'. Assuming ISO8859-1 App-Guiio-0.991/setup/hooks/ -- Around line 13: =pod directives shouldn't be over one line long! Ignoring all 21 lines of content App-Guiio-0.991/setup/import_export/ -- Around line 62: =pod directives shouldn't be over one line long! Ignoring all 6 lines of content


Fix the version(s).


Add a META.json to the distribution. Your buildtool should be able to autogenerate it.


If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.


This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.


Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).


Name Abstract Version View
App::Guiio Plain ASCII diagram 0.99 metacpan
App::Guiio::stripes::editable_arrow2 metacpan
App::Guiio::stripes::editable_box2 metacpan
App::Guiio::stripes::if_box metacpan
App::Guiio::stripes::process_box metacpan
App::Guiio::stripes::section_wirl_arrow metacpan
App::Guiio::stripes::single_stripe metacpan
App::Guiio::stripes::stripes metacpan
App::Guiio::stripes::wirl_arrow metacpan

Other Files

Build.PL metacpan
Changes metacpan
MANIFEST metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan