Kwalitee Issues

prereq_matches_use

List all used modules in META.yml requires

Error:

  • Encode

use_warnings

Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: Archive::Zip, Archive::Zip::Archive, Archive::Zip::BufferedFileHandle, Archive::Zip::DirectoryMember, Archive::Zip::FileMember, Archive::Zip::Member, Archive::Zip::MemberRead, Archive::Zip::MockFileHandle, Archive::Zip::NewFileMember, Archive::Zip::StringMember, Archive::Zip::Tree, Archive::Zip::ZipFileMember

has_separate_license_file

This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

Modules

Name Abstract Version View
Archive::Zip Provide an interface to ZIP archive files. 1.59 metacpan
Archive::Zip::Archive 1.59 metacpan
Archive::Zip::BufferedFileHandle 1.59 metacpan
Archive::Zip::DirectoryMember 1.59 metacpan
Archive::Zip::FileMember 1.59 metacpan
Archive::Zip::Member 1.59 metacpan
Archive::Zip::MemberRead A wrapper that lets you read Zip archive members as if they were files. 1.59 metacpan
Archive::Zip::MockFileHandle 1.59 metacpan
Archive::Zip::NewFileMember 1.59 metacpan
Archive::Zip::StringMember 1.59 metacpan
Archive::Zip::Tree (DEPRECATED) methods for adding/extracting trees using Archive::Zip 1.59 metacpan
Archive::Zip::ZipFileMember 1.59 metacpan

Other Files

Changes metacpan
MANIFEST metacpan
META.json metacpan
META.yml metacpan
Makefile.PL metacpan
README.md metacpan