AssistantFrames

Metadata

Analyzed metadata and errors of AssistantFrames.

{
   "abstracts_in_pod" : {
      "AFDialogs" : "GUI-Class to create the dialogs for AssistantFrame",
      "Mac::AssistantFrames" : "GUI-Class to build an assistant-like line of frames\nresembles the standard OS assistants/wizards."
   },
   "author" : "GBAUER",
   "buildfile_executable" : 0,
   "dirs_array" : [],
   "dist" : "AssistantFrames",
   "error" : {
      "no_invalid_versions" : {
         "AFDialogs.pm" : {
            "Mac::AFDialogs" : "0.1a"
         }
      },
      "proper_libs" : "AssistantFrames.pm, AFDialogs.pm",
      "use_warnings" : "Mac::AssistantFrames, Mac::AFDialogs"
   },
   "extension" : "tar.gz",
   "extractable" : 1,
   "extracts_nicely" : 1,
   "file__build" : 0,
   "file_blib" : 0,
   "file_build" : 0,
   "file_changelog" : "Changes",
   "file_makefile" : 0,
   "file_makefile_pl" : "Makefile.PL",
   "file_manifest" : "MANIFEST",
   "file_pm_to_blib" : 0,
   "file_readme" : "README",
   "files_array" : [
      "README",
      "AssistantFrames.pm",
      "Changes",
      "Makefile.PL",
      "AFDialogs.pm",
      "MANIFEST"
   ],
   "files_hash" : {
      "AFDialogs.pm" : {
         "license" : "Perl_5",
         "module" : "Mac::AFDialogs",
         "mtime" : 901092733,
         "required" : [
            "5.004"
         ],
         "size" : 10113,
         "used" : [
            "Mac::Controls",
            "Mac::Dialogs",
            "Mac::Events",
            "Mac::Windows",
            "strict"
         ]
      },
      "AssistantFrames.pm" : {
         "license" : "Perl_5",
         "module" : "Mac::AssistantFrames",
         "mtime" : 901092718,
         "required" : [
            "5.004"
         ],
         "size" : 13778,
         "used" : [
            "Mac::AFDialogs",
            "strict"
         ]
      },
      "Changes" : {
         "mtime" : 901011351,
         "size" : 109
      },
      "MANIFEST" : {
         "mtime" : 901011366,
         "size" : 68
      },
      "Makefile.PL" : {
         "mtime" : 901011348,
         "size" : 446,
         "used" : [
            "ExtUtils::MakeMaker"
         ]
      },
      "README" : {
         "mtime" : 901012440,
         "size" : 7921
      }
   },
   "got_prereq_from" : "Makefile.PL",
   "kwalitee" : {
      "buildtool_not_executable" : 1,
      "consistent_version" : 1,
      "distname_matches_name_in_meta" : 1,
      "extractable" : 1,
      "extracts_nicely" : 1,
      "has_abstract_in_pod" : 1,
      "has_buildtool" : 1,
      "has_changelog" : 1,
      "has_human_readable_license" : 1,
      "has_known_license_in_source_file" : 1,
      "has_license_in_source_file" : 1,
      "has_manifest" : 1,
      "has_meta_yml" : 0,
      "has_proper_version" : 1,
      "has_readme" : 1,
      "has_separate_license_file" : 0,
      "has_tests" : 0,
      "has_tests_in_t_dir" : 0,
      "has_version" : 1,
      "kwalitee" : "81.82",
      "manifest_matches_dist" : 1,
      "meta_json_conforms_to_known_spec" : 1,
      "meta_json_is_parsable" : 1,
      "meta_yml_conforms_to_known_spec" : 1,
      "meta_yml_declares_perl_version" : 0,
      "meta_yml_has_license" : 0,
      "meta_yml_has_provides" : 0,
      "meta_yml_has_repository_resource" : 0,
      "meta_yml_is_parsable" : 1,
      "no_abstract_stub_in_pod" : 1,
      "no_broken_auto_install" : 1,
      "no_broken_module_install" : 1,
      "no_dot_dirs" : 1,
      "no_dot_underscore_files" : 1,
      "no_generated_files" : 1,
      "no_invalid_versions" : 0,
      "no_local_dirs" : 1,
      "no_mymeta_files" : 1,
      "no_pax_headers" : 1,
      "no_pod_errors" : 1,
      "no_stdin_for_prompting" : 1,
      "no_symlinks" : 1,
      "package_version_matches_dist_version" : 1,
      "portable_filenames" : 1,
      "proper_libs" : 0,
      "use_strict" : 1,
      "use_warnings" : 0,
      "valid_signature" : 1
   },
   "latest_mtime" : 901092733,
   "license" : "defined in POD (AFDialogs.pm)",
   "license_file" : "AFDialogs.pm,AssistantFrames.pm",
   "license_in_pod" : 1,
   "license_type" : "Perl_5",
   "licenses" : {
      "Perl_5" : [
         "AFDialogs.pm",
         "AssistantFrames.pm"
      ]
   },
   "manifest_matches_dist" : 1,
   "meta_yml" : {},
   "modules" : [
      {
         "file" : "AssistantFrames.pm",
         "in_basedir" : 1,
         "in_lib" : 0,
         "module" : "Mac::AssistantFrames"
      },
      {
         "file" : "AFDialogs.pm",
         "in_basedir" : 1,
         "in_lib" : 0,
         "module" : "Mac::AFDialogs"
      }
   ],
   "no_pax_headers" : 1,
   "package" : "AssistantFrames-0.1.tar.gz",
   "prereq" : [],
   "released_epoch" : 901783680,
   "size_packed" : 6748,
   "size_unpacked" : 32435,
   "uses" : {
      "required_in_code" : {
         "5.004" : 2
      },
      "used_in_code" : {
         "Mac::Controls" : 1,
         "Mac::Dialogs" : 1,
         "Mac::Events" : 1,
         "Mac::Windows" : 1,
         "strict" : 2
      },
      "used_in_config" : {
         "ExtUtils::MakeMaker" : 1
      }
   },
   "valid_signature" : -1,
   "version" : "0.1",
   "versions" : {
      "AFDialogs.pm" : {
         "Mac::AFDialogs" : "undef"
      },
      "AssistantFrames.pm" : {
         "Mac::AssistantFrames" : "0.1"
      }
   },
   "vname" : "AssistantFrames-0.1"
}