Kwalitee Issues

has_meta_yml

Add a META.yml to the distribution. Your buildtool should be able to autogenerate it.

manifest_matches_dist

Run a proper command ("make manifest" or "./Build manifest", maybe with a force option), or use a distribution builder to generate the MANIFEST. Or update MANIFEST manually.

Error:

  • MANIFEST (7) does not match dist (58):
  • Missing in MANIFEST: .bzr/README, .bzr/branch-format, .bzr/branch/branch-name, .bzr/branch/format, .bzr/branch/revision-history, .bzr/checkout/basis-inventory-cache, .bzr/checkout/conflicts, .bzr/checkout/format, .bzr/checkout/inventory, .bzr/checkout/last-revision, .bzr/checkout/pending-merges, .bzr/checkout/stat-cache, .bzr/repository/format, .bzr/repository/inventory.kndx, .bzr/repository/inventory.knit, .bzr/repository/knits/16/changes-20070516172058-q2wm0b0x6onbev2u-1.kndx, .bzr/repository/knits/16/changes-20070516172058-q2wm0b0x6onbev2u-1.knit, .bzr/repository/knits/61/log-20070516172151-la93ifxh65govfi2-1.kndx, .bzr/repository/knits/61/log-20070516172151-la93ifxh65govfi2-1.knit, .bzr/repository/knits/6d/bzrignore-20070516172210-at7cyyh1jpgks1og-1.kndx, .bzr/repository/knits/6d/bzrignore-20070516172210-at7cyyh1jpgks1og-1.knit, .bzr/repository/knits/72/store-20070516172058-q2wm0b0x6onbev2u-9.kndx, .bzr/repository/knits/72/store-20070516172058-q2wm0b0x6onbev2u-9.knit, .bzr/repository/knits/78/lib-20070516172058-q2wm0b0x6onbev2u-5.kndx, .bzr/repository/knits/78/lib-20070516172058-q2wm0b0x6onbev2u-5.knit, .bzr/repository/knits/87/makefile.pl-20070516172058-q2wm0b0x6onbev2u-3.kndx, .bzr/repository/knits/87/makefile.pl-20070516172058-q2wm0b0x6onbev2u-3.knit, .bzr/repository/knits/95/manifest-20070516172058-q2wm0b0x6onbev2u-2.kndx, .bzr/repository/knits/95/manifest-20070516172058-q2wm0b0x6onbev2u-2.knit, .bzr/repository/knits/9d/queue.pm-20070516172058-q2wm0b0x6onbev2u-10.kndx, .bzr/repository/knits/9d/queue.pm-20070516172058-q2wm0b0x6onbev2u-10.knit, .bzr/repository/knits/9e/asteriskstorequeue.t-20070516172058-q2wm0b0x6onbev2u-8.kndx, .bzr/repository/knits/9e/asteriskstorequeue.t-20070516172058-q2wm0b0x6onbev2u-8.knit, .bzr/repository/knits/a3/todo-20070516182456-1w8g41kh12wxw6ru-1.kndx, .bzr/repository/knits/a3/todo-20070516182456-1w8g41kh12wxw6ru-1.knit, .bzr/repository/knits/a9/asterisk-20070516172058-q2wm0b0x6onbev2u-7.kndx, .bzr/repository/knits/a9/asterisk-20070516172058-q2wm0b0x6onbev2u-7.knit, .bzr/repository/knits/ae/readme-20070516172058-q2wm0b0x6onbev2u-4.kndx, .bzr/repository/knits/ae/readme-20070516172058-q2wm0b0x6onbev2u-4.knit, .bzr/repository/knits/b6/t-20070516172058-q2wm0b0x6onbev2u-6.kndx, .bzr/repository/knits/b6/t-20070516172058-q2wm0b0x6onbev2u-6.knit, .bzr/repository/knits/c0/exists-20070516172151-la93ifxh65govfi2-2.kndx, .bzr/repository/knits/c0/exists-20070516172151-la93ifxh65govfi2-2.knit, .bzr/repository/revisions.kndx, .bzr/repository/revisions.knit, .bzr/repository/signatures.kndx, .bzr/repository/signatures.knit, .bzrignore, TODO, log/member.log, log/queue.log

package_version_matches_dist_version

Fix the version(s).

prereq_matches_use

List all used modules in META.yml requires

Error:

  • Log::Log4perl

has_meta_json

Add a META.json to the distribution. Your buildtool should be able to autogenerate it.

meta_yml_has_license

Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.

no_dot_dirs

Fix MANIFEST (or MANIFEST.SKIP) to exclude dot directories from a distribution. Use an appropriate tool and avoid archiving your working directory by hand. If you switch your version control system, remove old VCS directories after you migrate.

Error: .bzr

has_separate_license_file

This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.

Modules

Name Abstract Version View
Asterisk::Store::Queue Class for Asterisk queue objects 0.01 metacpan

Other Files

Changes metacpan
MANIFEST metacpan
Makefile.PL metacpan
README metacpan