Astro-Aladin

Metadata

Analyzed metadata and errors of Astro-Aladin.

{
   "abstracts_in_pod" : {
      "Astro::Aladin" : "Perl class giving access to images and catalogues",
      "Astro::Aladin::LowLevel" : "Perl class designed to drive CDS Aladin Application"
   },
   "author" : "AALLAN",
   "base_dirs" : [
      "LowLevel/"
   ],
   "buildfile_executable" : 0,
   "dir_t" : "t",
   "dirs_array" : [
      "LowLevel",
      "t",
      "t"
   ],
   "dist" : "Astro-Aladin",
   "dynamic_config" : 0,
   "error" : {
      "consistent_version" : "1.2,1.3",
      "meta_yml_conforms_to_known_spec" : "Expected a map structure from string or file. (requires) [Validation: 1.0]",
      "use_warnings" : "Astro::Aladin::LowLevel, Astro::Aladin"
   },
   "extension" : "tar.gz",
   "extractable" : 1,
   "extracts_nicely" : 1,
   "file__build" : 0,
   "file_blib" : 0,
   "file_build" : 0,
   "file_changelog" : "ChangeLog",
   "file_makefile" : 0,
   "file_makefile_pl" : "WWW::CPANTS::Analyze::Context=HASH(0x67521b0)->d->{file_makefile_pl},LowLevel/Makefile.PL",
   "file_manifest" : "MANIFEST",
   "file_meta_yml" : "META.yml",
   "file_pm_to_blib" : 0,
   "file_readme" : "README",
   "files_array" : [
      "Aladin.pm",
      "ChangeLog",
      "GPL",
      "LowLevel/LowLevel.pm",
      "LowLevel/Makefile.PL",
      "MANIFEST",
      "META.yml",
      "Makefile.PL",
      "README",
      "t/aladin.t",
      "t/lowlevel.t"
   ],
   "files_hash" : {
      "Aladin.pm" : {
         "license" : "GPL_1,GPL_2,GPL_3",
         "module" : "Astro::Aladin",
         "mtime" : 1046287297,
         "size" : 9153,
         "used" : [
            "5.7.3",
            "Astro::Aladin::LowLevel",
            "Carp",
            "Errno",
            "File::Spec",
            "POSIX",
            "strict",
            "threads",
            "threads::shared",
            "vars"
         ]
      },
      "ChangeLog" : {
         "mtime" : 1068644247,
         "size" : 483
      },
      "GPL" : {
         "mtime" : 1045853820,
         "size" : 15146
      },
      "LowLevel/LowLevel.pm" : {
         "license" : "GPL_1,GPL_2,GPL_3",
         "module" : "Astro::Aladin::LowLevel",
         "mtime" : 1046126756,
         "size" : 7772,
         "used" : [
            "Carp",
            "File::Spec",
            "strict",
            "vars"
         ]
      },
      "LowLevel/Makefile.PL" : {
         "mtime" : 1045853820,
         "size" : 469,
         "used" : [
            "ExtUtils::MakeMaker"
         ]
      },
      "MANIFEST" : {
         "mtime" : 1068644531,
         "size" : 196
      },
      "META.yml" : {
         "mtime" : 1068644530,
         "size" : 240
      },
      "Makefile.PL" : {
         "mtime" : 1068644521,
         "size" : 1744,
         "used" : [
            "Config",
            "ExtUtils::MakeMaker",
            "threads",
            "threads::shared"
         ]
      },
      "README" : {
         "mtime" : 1046126756,
         "size" : 5058
      },
      "t/aladin.t" : {
         "mtime" : 1068644079,
         "size" : 1305,
         "used" : [
            "Astro::Aladin",
            "Config",
            "Data::Dumper",
            "Test",
            "strict"
         ]
      },
      "t/lowlevel.t" : {
         "mtime" : 1068644117,
         "size" : 823,
         "used" : [
            "Astro::Aladin::LowLevel",
            "Data::Dumper",
            "Test",
            "strict"
         ]
      }
   },
   "got_prereq_from" : "Makefile.PL",
   "kwalitee" : {
      "buildtool_not_executable" : 1,
      "consistent_version" : 0,
      "distname_matches_name_in_meta" : 1,
      "extractable" : 1,
      "extracts_nicely" : 1,
      "has_abstract_in_pod" : 1,
      "has_buildtool" : 1,
      "has_changelog" : 1,
      "has_human_readable_license" : 1,
      "has_known_license_in_source_file" : 1,
      "has_license_in_source_file" : 1,
      "has_manifest" : 1,
      "has_meta_yml" : 1,
      "has_proper_version" : 1,
      "has_readme" : 1,
      "has_separate_license_file" : 0,
      "has_tests" : 1,
      "has_tests_in_t_dir" : 1,
      "has_version" : 1,
      "kwalitee" : "86.36",
      "manifest_matches_dist" : 1,
      "meta_json_conforms_to_known_spec" : 1,
      "meta_json_is_parsable" : 1,
      "meta_yml_conforms_to_known_spec" : 0,
      "meta_yml_declares_perl_version" : 0,
      "meta_yml_has_license" : 0,
      "meta_yml_has_provides" : 0,
      "meta_yml_has_repository_resource" : 0,
      "meta_yml_is_parsable" : 1,
      "no_abstract_stub_in_pod" : 1,
      "no_broken_auto_install" : 1,
      "no_broken_module_install" : 1,
      "no_dot_dirs" : 1,
      "no_dot_underscore_files" : 1,
      "no_generated_files" : 1,
      "no_invalid_versions" : 1,
      "no_local_dirs" : 1,
      "no_mymeta_files" : 1,
      "no_pax_headers" : 1,
      "no_pod_errors" : 1,
      "no_stdin_for_prompting" : 1,
      "no_symlinks" : 1,
      "package_version_matches_dist_version" : 0,
      "portable_filenames" : 1,
      "proper_libs" : 1,
      "use_strict" : 1,
      "use_warnings" : 0,
      "valid_signature" : 1
   },
   "latest_mtime" : 1068644531,
   "license" : "defined in POD (Aladin.pm)",
   "license_in_pod" : 1,
   "licenses" : {
      "GPL_1" : [
         "Aladin.pm",
         "LowLevel/LowLevel.pm"
      ],
      "GPL_2" : [
         "Aladin.pm",
         "LowLevel/LowLevel.pm"
      ],
      "GPL_3" : [
         "Aladin.pm",
         "LowLevel/LowLevel.pm"
      ]
   },
   "manifest_matches_dist" : 1,
   "meta_yml" : {
      "distribution_type" : "module",
      "generated_by" : "ExtUtils::MakeMaker version 6.10_07",
      "installdirs" : "site",
      "meta-spec" : {},
      "name" : "Astro-Aladin",
      "requires" : null,
      "version" : "2.0.2",
      "version_from" : null
   },
   "meta_yml_is_parsable" : 1,
   "meta_yml_spec_version" : "1.0",
   "modules" : [
      {
         "file" : "Aladin.pm",
         "in_basedir" : 1,
         "in_lib" : 0,
         "module" : "Astro::Aladin"
      },
      {
         "file" : "LowLevel/LowLevel.pm",
         "in_basedir" : 0,
         "in_lib" : 0,
         "module" : "Astro::Aladin::LowLevel"
      }
   ],
   "no_pax_headers" : 1,
   "package" : "Astro-Aladin-2.0.2.tar.gz",
   "prereq" : [],
   "released_epoch" : 1068644738,
   "size_packed" : 14255,
   "size_unpacked" : 42389,
   "uses" : {
      "used_in_code" : {
         "5.7.3" : 1,
         "Carp" : 2,
         "Errno" : 1,
         "File::Spec" : 2,
         "POSIX" : 1,
         "strict" : 2,
         "threads" : 1,
         "threads::shared" : 1,
         "vars" : 2
      },
      "used_in_config" : {
         "Config" : 1,
         "ExtUtils::MakeMaker" : 2,
         "threads" : 1,
         "threads::shared" : 1
      },
      "used_in_tests" : {
         "Config" : 1,
         "Data::Dumper" : 2,
         "Test" : 2,
         "strict" : 2
      }
   },
   "valid_signature" : -1,
   "version" : "2.0.2",
   "versions" : {
      "Aladin.pm" : {
         "Astro::Aladin" : "1.3"
      },
      "LowLevel/LowLevel.pm" : {
         "Astro::Aladin::LowLevel" : "1.2"
      }
   },
   "vname" : "Astro-Aladin-2.0.2"
}