Authen-PAM

Metadata

Analyzed metadata and errors of Authen-PAM.

{
   "abstracts_in_pod" : {
      "Authen::PAM" : "Perl interface to PAM library"
   },
   "author" : "NIKIP",
   "buildfile_executable" : 0,
   "dirs_array" : [
      "d",
      "PAM"
   ],
   "dist" : "Authen-PAM",
   "dynamic_config" : 0,
   "easily_repackageable_by_debian" : "has_tests_in_t_dir",
   "easily_repackageable_by_fedora" : "fits_fedora_license",
   "error" : {
      "proper_libs" : "d/PAM.pm",
      "use_strict" : "Authen::PAM",
      "use_warnings" : "Authen::PAM"
   },
   "extension" : "tar.gz",
   "extractable" : 1,
   "extracts_nicely" : 1,
   "file__build" : 0,
   "file_blib" : 0,
   "file_build" : 0,
   "file_changelog" : "Changes",
   "file_makefile" : 0,
   "file_makefile_pl" : "Makefile.PL",
   "file_manifest" : "MANIFEST",
   "file_meta_yml" : "META.yml",
   "file_pm_to_blib" : 0,
   "file_readme" : "README",
   "file_test_pl" : "test.pl",
   "files_array" : [
      "PAM.xs",
      "typemap",
      "README",
      "test.pl",
      "Changes",
      "configure",
      "PAM_config.h.in",
      "Makefile.PL",
      "META.yml",
      "configure.ac",
      "pam.cfg.in",
      "MANIFEST",
      "PAM.pm.in",
      "d/PAM.pm",
      "PAM/FAQ.pod"
   ],
   "files_hash" : {
      "Changes" : {
         "mtime" : 1127326199,
         "size" : 4948
      },
      "MANIFEST" : {
         "mtime" : 1118064551,
         "size" : 219
      },
      "META.yml" : {
         "mtime" : 1127326311,
         "size" : 330
      },
      "Makefile.PL" : {
         "mtime" : 1118064552,
         "size" : 1746,
         "used" : [
            "Config",
            "ExtUtils::MakeMaker"
         ]
      },
      "PAM.pm.in" : {
         "mtime" : 1120126214,
         "size" : 10354
      },
      "PAM.xs" : {
         "mtime" : 1120126590,
         "size" : 17000
      },
      "PAM/FAQ.pod" : {
         "license" : "Perl_5",
         "mtime" : 1120126316,
         "size" : 5005
      },
      "PAM_config.h.in" : {
         "mtime" : 1118064553,
         "size" : 2186
      },
      "README" : {
         "mtime" : 1127326126,
         "size" : 5078
      },
      "configure" : {
         "mtime" : 1120127164,
         "size" : 145958
      },
      "configure.ac" : {
         "mtime" : 1120127159,
         "size" : 2758
      },
      "d/PAM.pm" : {
         "license" : "Perl_5",
         "module" : "Authen::PAM",
         "mtime" : 1127326280,
         "size" : 5899
      },
      "pam.cfg.in" : {
         "mtime" : 1118064557,
         "size" : 51
      },
      "test.pl" : {
         "mtime" : 1127326126,
         "size" : 4338
      },
      "typemap" : {
         "mtime" : 1127326147,
         "size" : 44
      }
   },
   "got_prereq_from" : "META.yml",
   "kwalitee" : {
      "buildtool_not_executable" : 1,
      "consistent_version" : 1,
      "distname_matches_name_in_meta" : 1,
      "easily_repackageable_by_debian" : 0,
      "easily_repackageable_by_fedora" : 0,
      "extractable" : 1,
      "extracts_nicely" : 1,
      "fits_fedora_license" : 0,
      "has_abstract_in_pod" : 1,
      "has_buildtool" : 1,
      "has_changelog" : 1,
      "has_human_readable_license" : 1,
      "has_known_license_in_source_file" : 1,
      "has_license_in_source_file" : 1,
      "has_manifest" : 1,
      "has_meta_yml" : 1,
      "has_proper_version" : 1,
      "has_readme" : 1,
      "has_separate_license_file" : 0,
      "has_tests" : 1,
      "has_tests_in_t_dir" : 0,
      "has_version" : 1,
      "kwalitee" : "86.36",
      "manifest_matches_dist" : 1,
      "meta_json_conforms_to_known_spec" : 1,
      "meta_json_is_parsable" : 1,
      "meta_yml_conforms_to_known_spec" : 1,
      "meta_yml_declares_perl_version" : 0,
      "meta_yml_has_license" : 0,
      "meta_yml_has_provides" : 0,
      "meta_yml_has_repository_resource" : 0,
      "meta_yml_is_parsable" : 1,
      "no_abstract_stub_in_pod" : 1,
      "no_broken_auto_install" : 1,
      "no_broken_module_install" : 1,
      "no_dot_dirs" : 1,
      "no_dot_underscore_files" : 1,
      "no_generated_files" : 1,
      "no_invalid_versions" : 1,
      "no_local_dirs" : 1,
      "no_mymeta_files" : 1,
      "no_pax_headers" : 1,
      "no_pod_errors" : 1,
      "no_stdin_for_prompting" : 1,
      "no_symlinks" : 1,
      "package_version_matches_dist_version" : 1,
      "portable_filenames" : 1,
      "proper_libs" : 0,
      "use_strict" : 0,
      "use_warnings" : 0,
      "valid_signature" : 1
   },
   "latest_mtime" : 1127326311,
   "license" : "defined in POD (PAM/FAQ.pod)",
   "license_file" : "PAM/FAQ.pod,d/PAM.pm",
   "license_in_pod" : 1,
   "license_type" : "Perl_5",
   "licenses" : {
      "Perl_5" : [
         "PAM/FAQ.pod",
         "d/PAM.pm"
      ]
   },
   "manifest_matches_dist" : 1,
   "meta_yml" : {
      "distribution_type" : "module",
      "generated_by" : "ExtUtils::MakeMaker version 6.17",
      "installdirs" : "site",
      "meta-spec" : {},
      "name" : "Authen-PAM",
      "requires" : {
         "POSIX" : "0"
      },
      "version" : "0.16",
      "version_from" : "PAM.pm"
   },
   "meta_yml_is_parsable" : 1,
   "meta_yml_spec_version" : "1.0",
   "modules" : [
      {
         "file" : "d/PAM.pm",
         "in_basedir" : 0,
         "in_lib" : 0,
         "module" : "Authen::PAM"
      }
   ],
   "needs_compiler" : 1,
   "no_pax_headers" : 1,
   "package" : "Authen-PAM-0.16.tar.gz",
   "prereq" : [
      {
         "is_prereq" : 1,
         "requires" : "POSIX",
         "type" : "runtime_requires",
         "version" : "0"
      }
   ],
   "released_epoch" : 1127328366,
   "size_packed" : 45922,
   "size_unpacked" : 205914,
   "uses" : {
      "used_in_config" : {
         "Config" : 1,
         "ExtUtils::MakeMaker" : 1
      }
   },
   "valid_signature" : -1,
   "version" : "0.16",
   "versions" : {
      "d/PAM.pm" : {
         "Authen::PAM" : "0.16"
      }
   },
   "vname" : "Authen-PAM-0.16"
}