Kwalitee Issues

has_manifest

Add a MANIFEST to the distribution. Your buildtool should be able to autogenerate it (eg "make manifest" or "./Build manifest")

has_meta_yml

Add a META.yml to the distribution. Your buildtool should be able to autogenerate it.

has_readme

Add a README to the distribution. It should contain a quick description of your module and how to install it.

has_tests

Add tests!

manifest_matches_dist

Run a proper command ("make manifest" or "./Build manifest", maybe with a force option), or use a distribution builder to generate the MANIFEST. Or update MANIFEST manually.

Error: Cannot find MANIFEST in dist.

no_pod_errors

Remove the POD errors. You can check for POD errors automatically by including Test::Pod to your test suite.

Error: Authen-PluggableCaptcha-0.05/lib/Authen/PluggableCaptcha/Challenge.pm -- Around line 72: =over without closing =backAround line 118: =over is the last thing in the document?! Authen-PluggableCaptcha-0.05/lib/Authen/PluggableCaptcha/ErrorLoggingObject.pm -- Around line 24: =over without closing =back Authen-PluggableCaptcha-0.05/lib/Authen/PluggableCaptcha/Render/Image/Imager/effects.pm -- Around line 23: =pod directives shouldn't be over one line long! Ignoring all 2 lines of content Authen-PluggableCaptcha-0.05/lib/Authen/PluggableCaptcha/Render/Image/Imager/layers.pm -- Around line 25: =pod directives shouldn't be over one line long! Ignoring all 2 lines of content Authen-PluggableCaptcha-0.05/lib/Authen/PluggableCaptcha/Render/Image/Imager.pm -- Around line 142: =pod directives shouldn't be over one line long! Ignoring all 2 lines of contentAround line 170: =pod directives shouldn't be over one line long! Ignoring all 3 lines of content Authen-PluggableCaptcha-0.05/lib/Authen/PluggableCaptcha/Render/Text/HTML.pm -- Around line 41: =pod directives shouldn't be over one line long! Ignoring all 2 lines of content Authen-PluggableCaptcha-0.05/lib/Authen/PluggableCaptcha/Render/Text/Plain.pm -- Around line 39: =pod directives shouldn't be over one line long! Ignoring all 2 lines of content Authen-PluggableCaptcha-0.05/lib/Authen/PluggableCaptcha.pm -- Around line 294: You forgot a '=back' before '=head1'Around line 545: =pod directives shouldn't be over one line long! Ignoring all 2 lines of contentAround line 587: =pod directives shouldn't be over one line long! Ignoring all 2 lines of contentAround line 657: =pod directives shouldn't be over one line long! Ignoring all 2 lines of contentAround line 671: =pod directives shouldn't be over one line long! Ignoring all 2 lines of contentAround line 688: =pod directives shouldn't be over one line long! Ignoring all 2 lines of contentAround line 760: =pod directives shouldn't be over one line long! Ignoring all 2 lines of contentAround line 822: =pod directives shouldn't be over one line long! Ignoring all 2 lines of content

prereq_matches_use

List all used modules in META.yml requires

Error:

  • Imager
  • Imager::Color
  • strict
  • vars
  • warnings

use_strict

Add 'use strict' (or its equivalents) to all modules, or convince us that your favorite module is well-known enough and people can easily see the modules are strictly written.

Error: Authen::PluggableCaptcha::Tutorial

consistent_version

Split the distribution, or fix the version numbers to make them consistent (use the highest version number to avoid version downgrade).

Error: 0.01,0.02,0.03,0.05

has_meta_json

Add a META.json to the distribution. Your buildtool should be able to autogenerate it.

has_tests_in_t_dir

Add tests or move tests.pl to the t/ directory!

meta_yml_has_license

Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.

use_warnings

Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: Authen::PluggableCaptcha, Authen::PluggableCaptcha::Challenge, Authen::PluggableCaptcha::Challenge::DoMath, Authen::PluggableCaptcha::Challenge::TypeString, Authen::PluggableCaptcha::Helpers, Authen::PluggableCaptcha::KeyManager, Authen::PluggableCaptcha::Render, Authen::PluggableCaptcha::Render::Image, Authen::PluggableCaptcha::Render::Image::Imager, Authen::PluggableCaptcha::Render::Image::Imager::effects, Authen::PluggableCaptcha::Render::Image::Imager::effects::sinewarp, Authen::PluggableCaptcha::Render::Image::Imager::layers, Authen::PluggableCaptcha::Render::Image::Imager::layers::bg, Authen::PluggableCaptcha::Render::Image::Imager::layers::distraction_lines, Authen::PluggableCaptcha::Render::Image::Imager::layers::text, Authen::PluggableCaptcha::Render::Text, Authen::PluggableCaptcha::Render::Text::HTML, Authen::PluggableCaptcha::Render::Text::Plain, Authen::PluggableCaptcha::Tutorial

has_separate_license_file

This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.

Modules

Name Abstract Version View
Authen::PluggableCaptcha A pluggable Captcha framework for Perl 0.05 metacpan
Authen::PluggableCaptcha::Challenge 0.02 metacpan
Authen::PluggableCaptcha::Challenge::DoMath 0.01 metacpan
Authen::PluggableCaptcha::Challenge::TypeString 0.02 metacpan
Authen::PluggableCaptcha::ErrorLoggingObject 0.03 metacpan
Authen::PluggableCaptcha::Helpers 0.01 metacpan
Authen::PluggableCaptcha::KeyManager 0.01 metacpan
Authen::PluggableCaptcha::Render 0.02 metacpan
Authen::PluggableCaptcha::Render::Image 0.01 metacpan
Authen::PluggableCaptcha::Render::Image::Imager 0.02 metacpan
Authen::PluggableCaptcha::Render::Image::Imager::effects 0.01 metacpan
Authen::PluggableCaptcha::Render::Image::Imager::effects::sinewarp 0.01 metacpan
Authen::PluggableCaptcha::Render::Image::Imager::layers 0.01 metacpan
Authen::PluggableCaptcha::Render::Image::Imager::layers::bg 0.01 metacpan
Authen::PluggableCaptcha::Render::Image::Imager::layers::distraction_lines 0.01 metacpan
Authen::PluggableCaptcha::Render::Image::Imager::layers::text 0.01 metacpan
Authen::PluggableCaptcha::Render::Text 0.02 metacpan
Authen::PluggableCaptcha::Render::Text::HTML 0.02 metacpan
Authen::PluggableCaptcha::Render::Text::Plain 0.02 metacpan
Authen::PluggableCaptcha::StandardAttributesObject 0.01 metacpan
Authen::PluggableCaptcha::ValidityObject 0.01 metacpan

Other Files

Changes metacpan
Makefile.PL metacpan