Kwalitee Issues

manifest_matches_dist

Run a proper command ("make manifest" or "./Build manifest", maybe with a force option), or use a distribution builder to generate the MANIFEST. Or update MANIFEST manually.

Error:

  • MANIFEST (21) does not match dist (40):
  • Missing in MANIFEST: ._Changes, ._Makefile.PL, ._README, ._ignore.txt, lib/._Blitz.pm, lib/Blitz/._API.pm, lib/Blitz/._Exercise.pm, lib/Blitz/._Rush.pm, lib/Blitz/._Sprint.pm, lib/Blitz/._Validate.pm, t/._00-load.t, t/._blitzexecute.t, t/._blitzlogin.t, t/._blitzobject.t, t/._blitzvalidate.t, t/._boilerplate.t, t/._manifest.t, t/._pod-coverage.t, t/._pod.t

use_strict

Add 'use strict' (or its equivalents) to all modules, or convince us that your favorite module is well-known enough and people can easily see the modules are strictly written.

Error: ._Blitz, Blitz::._API, Blitz::._Exercise, Blitz::._Rush, Blitz::._Sprint, Blitz::._Validate

has_meta_json

Add a META.json to the distribution. Your buildtool should be able to autogenerate it.

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

no_dot_underscore_files

If you use Mac OS X, set COPYFILE_DISABLE (for OS 10.5 and better) or COPY_EXTENDED_ATTRIBUTES_DISABLE (for OS 10.4) environmental variable to true to exclude dot underscore files from a distribution.

Error:

  • ._Changes
  • ._Makefile.PL
  • ._README
  • ._ignore.txt
  • lib/._Blitz.pm
  • lib/Blitz/._API.pm
  • lib/Blitz/._Exercise.pm
  • lib/Blitz/._Rush.pm
  • lib/Blitz/._Sprint.pm
  • lib/Blitz/._Validate.pm
  • t/._00-load.t
  • t/._blitzexecute.t
  • t/._blitzlogin.t
  • t/._blitzobject.t
  • t/._blitzvalidate.t
  • t/._boilerplate.t
  • t/._manifest.t
  • t/._pod-coverage.t
  • t/._pod.t

use_warnings

Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: ._Blitz, Blitz::._API, Blitz::._Exercise, Blitz::._Rush, Blitz::._Sprint, Blitz::._Validate

has_separate_license_file

This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

meta_yml_has_repository_resource

Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).

Modules

Name Abstract Version View
Blitz Perl module for API access to Blitz 0.01 metacpan
Blitz::API Perl module for API access to Blitz metacpan
Blitz::Exercise Superclass for Sprint and Rush modules metacpan
Blitz::Rush metacpan
Blitz::Sprint Perl module for executing sprints on Blitz.io Subclass of Blitz::Exercise metacpan
Blitz::Validate Perl module for assisting with the validation of calls to Blitz.io metacpan

Other Files

Changes metacpan
MANIFEST metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan