CPAN-Digger

Prerequisites

CPAN-Digger declares the following 65 modules as prerequisites.

Listed PrerequisitesRequired VersionLatest DistKwalitee
Archive::Any0.0932Archive-Any-0.0941125.71
Archive::Tar1.90Archive-Tar-2.00128.57
Archive::Zip1.30Archive-Zip-1.37128.57
Capture::Tiny0.10Capture-Tiny-0.25134.29
Carp0Carp-1.3301125.71
Cwd0PathTools-3.47122.86
DBD::SQLite1.37DBD-SQLite-1.42128.57
DBI1.623DBI-1.631122.86
Dancer1.3110Dancer-1.3126120.00
Data::Dumper0Data-Dumper-2.151108.57
Encode2.47Encode-2.62125.71
File::Basename0perl0.00
File::Copy0perl0.00
File::Copy::Recursive0.38File-Copy-Recursive-0.38128.57
File::Find::Rule0.33File-Find-Rule-0.33117.14
File::Path0File-Path-2.09128.57
File::ShareDir1.03File-ShareDir-1.102128.57
File::Spec0PathTools-3.47122.86
File::Temp0File-Temp-0.2304131.43
Getopt::Long0Getopt-Long-2.42125.71
JSON2.53JSON-2.90128.57
JSON::XS2.33JSON-XS-3.01114.29
List::Util0Scalar-List-Utils-1.40125.71
Moose2.0604Moose-2.1211134.29
MooseX::StrictConstructor0.19MooseX-StrictConstructor-0.19131.43
POSIX0perl0.00
PPI::Document1.215PPI-1.218128.57
PPI::Find1.215PPI-1.218128.57
PPIx::EditorTools0.18PPIx-EditorTools-0.18122.86
Parse::CPAN::Packages2.38Parse-CPAN-Packages-2.38128.57
Parse::CPAN::Whois0.02Parse-CPAN-Whois-0.02131.43
Perl::Critic1.118Perl-Critic-1.122131.43
Perl::Critic::Bangs1.10Perl-Critic-Bangs-1.10131.43
Perl::Critic::Compatibility1.001Perl-Critic-Compatibility-1.001128.57
Perl::Critic::Deprecated1.108Perl-Critic-Deprecated-1.119125.71
Perl::Critic::Itch0.07Perl-Critic-Itch-0.07125.71
Perl::Critic::Lax0.009Perl-Critic-Lax-0.011131.43
Perl::Critic::More1.000Perl-Critic-More-1.003131.43
Perl::Critic::Nits1.0.0Perl-Critic-Nits-v1.0.0128.57
Perl::Critic::OTRS0.02Perl-Critic-OTRS-0.05128.57
Perl::Critic::PetPeeves::JTRAMMELL0.02Perl-Critic-PetPeeves-JTRAMMELL-0.04128.57
Perl::Critic::Policy::CodeLayout::ProhibitSpaceIndentation1.02Perl-Critic-Policy-CodeLayout-ProhibitSpaceIndentation-1.02131.43
Perl::Critic::Policy::CodeLayout::TabIndentSpaceAlign1.0.2Perl-Critic-Policy-CodeLayout-TabIndentSpaceAlign-v1.0.5134.29
Perl::Critic::Policy::logicLAB::ProhibitShellDispatch0.01Perl-Critic-Policy-logicLAB-ProhibitShellDispatch-0.04134.29
Perl::Critic::Policy::logicLAB::ProhibitUseLib0.01Perl-Critic-Policy-logicLAB-ProhibitUseLib-0.03134.29
Perl::Critic::Policy::logicLAB::RequireSheBang0.03Perl-Critic-Policy-logicLAB-RequireSheBang-0.06134.29
Perl::Critic::Policy::logicLAB::RequireVersionFormat0.03Perl-Critic-Policy-logicLAB-RequireVersionFormat-0.07134.29
Perl::Critic::Pulp75Perl-Critic-Pulp-85131.43
Perl::Critic::RENEEB0.01Perl-Critic-RENEEB-0.01128.57
Perl::Critic::Storable0.01Perl-Critic-Storable-0.01128.57
Perl::Critic::StricterSubs0.03Perl-Critic-StricterSubs-0.03128.57
Perl::Critic::Swift1.0.3Perl-Critic-Swift-v1.0.3131.43
Perl::Critic::Tics0.006Perl-Critic-Tics-0.009131.43
Perl::MinimumVersion1.31Perl-MinimumVersion-1.38134.29
Plack1.0014Plack-1.0031128.57
Plack::Handler::FCGI0Plack-1.0031128.57
Plack::Runner0Plack-1.0031128.57
Plack::Util0Plack-1.0031128.57
Pod::Simple3.23Pod-Simple-3.28122.86
Pod::Simple::HTML0Pod-Simple-3.28122.86
Template2.24Template-Toolkit-2.25128.57
Time::HiRes0Time-HiRes-1.9726125.71
YAML0.84YAML-1.11128.57
autodie2.13autodie-2.25131.43
perl5.008008perl0.00

CPAN-Digger declares the following 4 modules as build prerequisites.

Listed Build PrerequisitesRequired VersionLatest DistKwalitee
ExtUtils::MakeMaker6.59ExtUtils-MakeMaker-6.98131.43
Test::Deep0.110Test-Deep-0.113131.43
Test::More0.98Test-Simple-1.001003128.57
Test::NoWarnings1.04Test-NoWarnings-1.04128.57

CPAN-Digger declares the following 1 modules as optional prerequisites.

Listed Optional PrerequisitesRequired VersionLatest DistKwalitee
ExtUtils::MakeMaker6.59ExtUtils-MakeMaker-6.98131.428571428571