Catalyst-Authentication-Realm-Adaptor

Metadata

Analyzed metadata and errors of Catalyst-Authentication-Realm-Adaptor.

{
   "abstracts_in_pod" : {
      "Catalyst::Authentication::Realm::Adaptor" : "Adjust parameters of authentication processes on the fly"
   },
   "author" : "FLORA",
   "buildfile_executable" : 0,
   "dir_lib" : "lib",
   "dir_t" : "t",
   "dirs_array" : [
      "lib",
      "lib/Catalyst",
      "lib/Catalyst/Authentication",
      "lib/Catalyst/Authentication/Realm",
      "t",
      "inc",
      "inc/Module",
      "inc/Module/Install"
   ],
   "dist" : "Catalyst-Authentication-Realm-Adaptor",
   "dynamic_config" : 0,
   "error" : {},
   "extension" : "tar.gz",
   "extractable" : 1,
   "extracts_nicely" : 1,
   "file__build" : 0,
   "file_blib" : 0,
   "file_build" : 0,
   "file_changelog" : "Changes",
   "file_makefile" : 0,
   "file_makefile_pl" : "Makefile.PL",
   "file_manifest" : "MANIFEST",
   "file_meta_yml" : "META.yml",
   "file_pm_to_blib" : 0,
   "file_readme" : "README",
   "files_array" : [
      "README",
      "Changes",
      "Makefile.PL",
      "META.yml",
      "MANIFEST",
      "MANIFEST.SKIP",
      "lib/Catalyst/Authentication/Realm/Adaptor.pm"
   ],
   "files_hash" : {
      "Changes" : {
         "mtime" : 1269812687,
         "size" : 137
      },
      "MANIFEST" : {
         "mtime" : 1269813168,
         "size" : 386
      },
      "MANIFEST.SKIP" : {
         "mtime" : 1269813033,
         "size" : 111
      },
      "META.yml" : {
         "mtime" : 1269813167,
         "size" : 661
      },
      "Makefile.PL" : {
         "mtime" : 1269813143,
         "size" : 459,
         "used" : [
            "inc::Module::Install"
         ]
      },
      "README" : {
         "mtime" : 1269813177,
         "size" : 13551
      },
      "inc/Module/Install.pm" : {
         "mtime" : 1269813166,
         "no_index" : 1,
         "size" : 11513
      },
      "inc/Module/Install/Base.pm" : {
         "mtime" : 1269813166,
         "no_index" : 1,
         "size" : 1014
      },
      "inc/Module/Install/Can.pm" : {
         "mtime" : 1269813167,
         "no_index" : 1,
         "size" : 1755
      },
      "inc/Module/Install/Fetch.pm" : {
         "mtime" : 1269813167,
         "no_index" : 1,
         "size" : 2455
      },
      "inc/Module/Install/Makefile.pm" : {
         "mtime" : 1269813167,
         "no_index" : 1,
         "size" : 11408
      },
      "inc/Module/Install/Metadata.pm" : {
         "mtime" : 1269813166,
         "no_index" : 1,
         "size" : 16896
      },
      "inc/Module/Install/Win32.pm" : {
         "mtime" : 1269813167,
         "no_index" : 1,
         "size" : 1795
      },
      "inc/Module/Install/WriteAll.pm" : {
         "mtime" : 1269813167,
         "no_index" : 1,
         "size" : 1279
      },
      "lib/Catalyst/Authentication/Realm/Adaptor.pm" : {
         "license" : "Perl_5",
         "module" : "Catalyst::Authentication::Realm::Adaptor",
         "mtime" : 1269813160,
         "size" : 20032,
         "used" : [
            "Carp",
            "Moose",
            "strict",
            "warnings"
         ]
      },
      "t/00-load.t" : {
         "mtime" : 1269812687,
         "no_index" : 1,
         "size" : 230,
         "used" : [
            "Test::More"
         ]
      },
      "t/pod-coverage.t" : {
         "mtime" : 1269812687,
         "no_index" : 1,
         "size" : 606,
         "used" : [
            "Test::More",
            "strict",
            "warnings"
         ],
         "used_in_eval" : [
            "Pod::Coverage",
            "Test::Pod::Coverage"
         ]
      },
      "t/pod.t" : {
         "mtime" : 1269812687,
         "no_index" : 1,
         "size" : 232,
         "used" : [
            "Test::More",
            "strict",
            "warnings"
         ],
         "used_in_eval" : [
            "Test::Pod"
         ]
      }
   },
   "got_prereq_from" : "META.yml",
   "included_modules" : [
      "Module::Install::Makefile",
      "Module::Install::Win32",
      "Module::Install::Fetch",
      "Module::Install",
      "Module::Install::Base",
      "Module::Install::Metadata",
      "Module::Install::Can",
      "Module::Install::WriteAll"
   ],
   "kwalitee" : {
      "buildtool_not_executable" : 1,
      "consistent_version" : 1,
      "distname_matches_name_in_meta" : 1,
      "extractable" : 1,
      "extracts_nicely" : 1,
      "has_abstract_in_pod" : 1,
      "has_buildtool" : 1,
      "has_changelog" : 1,
      "has_human_readable_license" : 1,
      "has_known_license_in_source_file" : 1,
      "has_license_in_source_file" : 1,
      "has_manifest" : 1,
      "has_meta_yml" : 1,
      "has_proper_version" : 1,
      "has_readme" : 1,
      "has_separate_license_file" : 0,
      "has_tests" : 1,
      "has_tests_in_t_dir" : 1,
      "has_version" : 1,
      "kwalitee" : "100.00",
      "manifest_matches_dist" : 1,
      "meta_json_conforms_to_known_spec" : 1,
      "meta_json_is_parsable" : 1,
      "meta_yml_conforms_to_known_spec" : 1,
      "meta_yml_declares_perl_version" : 1,
      "meta_yml_has_license" : 1,
      "meta_yml_has_provides" : 0,
      "meta_yml_has_repository_resource" : 0,
      "meta_yml_is_parsable" : 1,
      "no_abstract_stub_in_pod" : 1,
      "no_broken_auto_install" : 1,
      "no_broken_module_install" : 1,
      "no_dot_dirs" : 1,
      "no_dot_underscore_files" : 1,
      "no_generated_files" : 1,
      "no_invalid_versions" : 1,
      "no_local_dirs" : 1,
      "no_mymeta_files" : 1,
      "no_pax_headers" : 1,
      "no_pod_errors" : 1,
      "no_stdin_for_prompting" : 1,
      "no_symlinks" : 1,
      "package_version_matches_dist_version" : 1,
      "portable_filenames" : 1,
      "proper_libs" : 1,
      "use_strict" : 1,
      "use_warnings" : 1,
      "valid_signature" : 1
   },
   "latest_mtime" : 1269813177,
   "license" : "perl defined in META.yml",
   "license_file" : "lib/Catalyst/Authentication/Realm/Adaptor.pm",
   "license_from_yaml" : "perl",
   "license_in_pod" : 1,
   "license_type" : "Perl_5",
   "licenses" : {
      "Perl_5" : [
         "lib/Catalyst/Authentication/Realm/Adaptor.pm"
      ]
   },
   "manifest_matches_dist" : 1,
   "meta_yml" : {
      "abstract" : "Adjust parameters of authentication processes on the fly",
      "author" : [
         "Jay Kuri, C<< <jayk at cpan.org> >>"
      ],
      "build_requires" : {
         "ExtUtils::MakeMaker" : "6.42",
         "Test::More" : "0.42"
      },
      "configure_requires" : {
         "ExtUtils::MakeMaker" : "6.42"
      },
      "distribution_type" : "module",
      "generated_by" : "Module::Install version 0.95",
      "license" : "perl",
      "meta-spec" : {
         "url" : "http://module-build.sourceforge.net/META-spec-v1.4.html",
         "version" : "1.4"
      },
      "name" : "Catalyst-Authentication-Realm-Adaptor",
      "no_index" : {
         "directory" : [
            "inc",
            "t"
         ]
      },
      "requires" : {
         "Catalyst::Plugin::Authentication" : "0.10003",
         "Catalyst::Runtime" : "0",
         "Moose" : "0",
         "perl" : "5.8.1"
      },
      "resources" : {
         "license" : "http://dev.perl.org/licenses/"
      },
      "version" : "0.02"
   },
   "meta_yml_is_parsable" : 1,
   "meta_yml_spec_version" : "1.4",
   "module_install" : {
      "version" : "0.95"
   },
   "modules" : [
      {
         "file" : "lib/Catalyst/Authentication/Realm/Adaptor.pm",
         "in_basedir" : 0,
         "in_lib" : 1,
         "module" : "Catalyst::Authentication::Realm::Adaptor"
      }
   ],
   "no_index" : "^inc/;^t/",
   "no_pax_headers" : 1,
   "package" : "Catalyst-Authentication-Realm-Adaptor-0.02.tar.gz",
   "prereq" : [
      {
         "is_build_prereq" : 1,
         "requires" : "ExtUtils::MakeMaker",
         "type" : "build_requires",
         "version" : "6.42"
      },
      {
         "requires" : "ExtUtils::MakeMaker",
         "type" : "configure_requires",
         "version" : "6.42"
      },
      {
         "is_prereq" : 1,
         "requires" : "Catalyst::Runtime",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "Catalyst::Plugin::Authentication",
         "type" : "runtime_requires",
         "version" : "0.10003"
      },
      {
         "is_build_prereq" : 1,
         "requires" : "Test::More",
         "type" : "build_requires",
         "version" : "0.42"
      },
      {
         "is_prereq" : 1,
         "requires" : "Moose",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "perl",
         "type" : "runtime_requires",
         "version" : "5.8.1"
      }
   ],
   "released_epoch" : 1269813225,
   "size_packed" : 24529,
   "size_unpacked" : 84520,
   "uses" : {
      "used_in_code" : {
         "Carp" : 1,
         "Moose" : 1,
         "strict" : 1,
         "warnings" : 1
      },
      "used_in_config" : {
         "inc::Module::Install" : 1
      },
      "used_in_eval_in_tests" : {
         "Pod::Coverage" : 1,
         "Test::Pod" : 1,
         "Test::Pod::Coverage" : 1
      },
      "used_in_tests" : {
         "Test::More" : 3,
         "strict" : 2,
         "warnings" : 2
      }
   },
   "valid_signature" : -1,
   "version" : "0.02",
   "versions" : {
      "lib/Catalyst/Authentication/Realm/Adaptor.pm" : {
         "Catalyst::Authentication::Realm::Adaptor" : "0.02"
      }
   },
   "vname" : "Catalyst-Authentication-Realm-Adaptor-0.02"
}