Kwalitee Issues

prereq_matches_use

List all used modules in META.yml requires

Error:

  • Catalyst::Engine::CGI
  • Catalyst::Engine::HTTP::Restarter::Watcher
  • Data::Dump
  • HTTP::Date
  • HTTP::Headers
  • HTTP::Response
  • HTTP::Status

has_meta_json

Add a META.json to the distribution. Your buildtool should be able to autogenerate it.

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

use_warnings

Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: Catalyst::Engine::HTTP::Prefork, Catalyst::Engine::HTTP::Prefork::Handler, Catalyst::Engine::HTTP::Prefork::Restarter

build_prereq_matches_use

List all modules used in the test suite in META.yml build_requires

Error:

  • CGI::Simple::Cookie
  • Data::Dump
  • HTTP::Headers
  • HTTP::Headers::Util
  • HTTP::Request
  • HTTP::Request::Common
  • HTTP::Response
  • Path::Class::Dir
  • URI
  • URI::Escape
  • YAML

has_separate_license_file

This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

Modules

Name Abstract Version View
Catalyst::Engine::HTTP::Prefork High-performance pre-forking Catalyst engine 0.51 metacpan
Catalyst::Engine::HTTP::Prefork::Handler metacpan
Catalyst::Engine::HTTP::Prefork::Restarter metacpan

Other Files

Changes metacpan
MANIFEST metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan