Kwalitee Issues

has_readme

Add a README to the distribution. It should contain a quick description of your module and how to install it.

consistent_version

Split the distribution, or fix the version numbers to make them consistent (use the highest version number to avoid version downgrade).

Error: 2.143070,2.200002

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

has_separate_license_file

This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

meta_yml_has_repository_resource

Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).

Modules

Name Abstract Version View
Catalyst::Plugin::AutoCRUD Instant AJAX web front-end for DBIx::Class 2.200002 metacpan
Catalyst::Plugin::AutoCRUD::Controller::AJAX 2.143070 metacpan
Catalyst::Plugin::AutoCRUD::Controller::DisplayEngine::ExtJS2 2.143070 metacpan
Catalyst::Plugin::AutoCRUD::Controller::DisplayEngine::Skinny 2.143070 metacpan
Catalyst::Plugin::AutoCRUD::Controller::Root 2.143070 metacpan
Catalyst::Plugin::AutoCRUD::Controller::Static 2.143070 metacpan
Catalyst::Plugin::AutoCRUD::Model::DBIC 2.143070 metacpan
Catalyst::Plugin::AutoCRUD::Model::StorageEngine::DBIC 2.143070 metacpan
Catalyst::Plugin::AutoCRUD::Model::StorageEngine::DBIC::CRUD 2.143070 metacpan
Catalyst::Plugin::AutoCRUD::Model::StorageEngine::DBIC::Metadata 2.143070 metacpan
Catalyst::Plugin::AutoCRUD::View::JSON 2.143070 metacpan
Catalyst::Plugin::AutoCRUD::View::TT 2.143070 metacpan
SQL::Translator::AutoCRUD::Quick 2.143070 metacpan
SQL::Translator::AutoCRUD::Utils 2.143070 metacpan
SQL::Translator::Filter::AutoCRUD::CatalystModel 2.143070 metacpan
SQL::Translator::Filter::AutoCRUD::ColumnsAndPKs 2.143070 metacpan
SQL::Translator::Filter::AutoCRUD::DisplayName 2.143070 metacpan
SQL::Translator::Filter::AutoCRUD::ExtJSxType 2.143070 metacpan
SQL::Translator::Filter::AutoCRUD::StorageEngine::DBIC::AccessorDisplayName 2.143070 metacpan
SQL::Translator::Filter::AutoCRUD::StorageEngine::DBIC::DynamicDefault 2.143070 metacpan
SQL::Translator::Filter::AutoCRUD::StorageEngine::DBIC::ProxyColumns 2.143070 metacpan
SQL::Translator::Filter::AutoCRUD::StorageEngine::DBIC::Relationships 2.143070 metacpan
SQL::Translator::Filter::AutoCRUD::StorageEngine::DBIC::ViewsAsTables 2.143070 metacpan

Other Files

Changes metacpan
MANIFEST metacpan
META.json metacpan
META.yml metacpan
Makefile.PL metacpan