Class-Usul

Prerequisites

Class-Usul declares the following 57 modules as prerequisites.

Listed PrerequisitesRequired VersionLatest DistKwalitee
Class::Inspector1.24Class-Inspector-1.28134.38
Class::Load0.18Class-Load-0.21137.50
Class::Null1.09Class-Null-2.110730137.50
Crypt::CBC2.3Crypt-CBC-2.33118.75
Crypt::Twofish21.02Crypt-Twofish2-1.02112.50
Data::Printer0.24Data-Printer-0.35131.25
Date::Format2.22TimeDate-2.30121.88
DateTime::Format::Epoch0.11DateTime-Format-Epoch-0.13134.38
Digest::MD52.39Digest-MD5-2.53134.38
Digest::SHA12.11Digest-SHA1-2.13134.38
Email::Date::Format1.002Email-Date-Format-1.004137.50
File::DataClassv0.16.0File-DataClass-0.44.1134.38
File::Gettextv0.16.0File-Gettext-0.24.1134.38
Getopt::Mixed1.1Getopt-Mixed-1.12134.38
Git::Class0.12Git-Class-0.13134.38
IO::Interactivev0.0.5IO-Interactive-0.0.6134.38
IPC::Cmd0.42IPC-Cmd-0.92131.25
IPC::Open31.02perl0.00
IPC::SRLockv0.9.0IPC-SRLock-0.22.1134.38
Import::Into1.001Import-Into-1.002004137.50
Log::Handler0.63Log-Handler-0.82131.25
Module::Build0.38Module-Build-0.4206131.25
Module::CoreList2.24Module-CoreList-5.021002131.25
Module::Load::Conditional0.26Module-Load-Conditional-0.62131.25
Module::Pluggable3.9Module-Pluggable-5.1118.75
Moose2.0801Moose-2.1210137.50
MooseX::Aliases0.1MooseX-Aliases-0.11134.38
MooseX::AttributeShortcuts0.014MooseX-AttributeShortcuts-0.024137.50
MooseX::ClassAttribute0.27MooseX-ClassAttribute-0.27134.38
MooseX::Getopt0.5MooseX-Getopt-0.63137.50
MooseX::MethodAttributes0.24MooseX-MethodAttributes-0.29137.50
MooseX::Role::Parameterized0.19MooseX-Role-Parameterized-1.02134.38
MooseX::Role::WithOverloading0.08MooseX-Role-WithOverloading-0.13137.50
MooseX::Traits::Pluggable0.1MooseX-Traits-Pluggable-0.12134.38
MooseX::Types0.25MooseX-Types-0.44137.50
MooseX::Types::LoadableClass0.007MooseX-Types-LoadableClass-0.012137.50
POSIX1.09perl0.00
Path::Class0.16Path-Class-0.33131.25
Perl::Version1.009Perl-Version-1.013134.38
Pod::Eventual0.09333Pod-Eventual-0.094001134.38
Pod::Man2.22podlators-2.5.3121.88
Pod::Parser1.37Pod-Parser-1.62121.88
SVN::Class0.12SVN-Class-0.17131.25
Scalar::Util1.19Scalar-List-Utils-1.39125.00
Sub::Exporter0.982Sub-Exporter-0.987134.38
Sub::Exporter::Progressive0.001006Sub-Exporter-Progressive-0.001011134.38
Term::ReadKey2.3TermReadKey-2.32125.00
Text::Autoformat1.13Text-Autoformat-1.669004128.13
Text::Format0.53Text-Format-0.59137.50
Time::Zone2.22TimeDate-2.30121.88
Try::Tiny0.09Try-Tiny-0.22137.50
YAML::Syck1.05YAML-Syck-1.27134.38
namespace::autoclean0.09namespace-autoclean-0.19137.50
namespace::clean0.11namespace-clean-0.25131.25
parent0.221parent-0.228121.88
perl5.01perl0.00
version0.77version-0.9908131.25

Class-Usul declares the following 4 modules as build prerequisites.

Listed Build PrerequisitesRequired VersionLatest DistKwalitee
Class::Null1.09Class-Null-2.110730137.50
Exception::Class1.23Exception-Class-1.38134.38
Math::BigInt1.89Math-BigInt-1.9993128.13
Test::More0.74Test-Simple-1.001003131.25

Class-Usul declares the following 5 modules as optional prerequisites.

Listed Optional PrerequisitesRequired VersionLatest DistKwalitee
App::cpanminus1.6005App-cpanminus-1.7004128.125
Module::Build0.38Module-Build-0.4206131.25
Pod::Markdown1.322Pod-Markdown-2.002137.5
Proc::ProcessTable0.42Proc-ProcessTable-0.50115.625
version0.77version-0.9908131.25