Kwalitee Issues


Add a META.yml to the distribution. Your buildtool should be able to autogenerate it.


List all used modules in META.yml requires


  • Curses


Split the distribution, or fix the version numbers to make them consistent (use the highest version number to avoid version downgrade).

Error: 0.1,1.102,1.103,1.104,1.997


Add =head1 LICENSE and/or the proper text of the well-known license to the main module in your code.


Add a META.json to the distribution. Your buildtool should be able to autogenerate it.


Add tests or move to the t/ directory!


Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.


Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: Curses::Widgets, Curses::Widgets::ButtonSet, Curses::Widgets::Calendar, Curses::Widgets::ComboBox, Curses::Widgets::Label, Curses::Widgets::ListBox, Curses::Widgets::ListBox::MultiColumn, Curses::Widgets::Menu, Curses::Widgets::ProgressBar, Curses::Widgets::TextField, Curses::Widgets::TextMemo


Name Abstract Version View
Curses::Widgets Base widget class for use with the Curses::Application framework 1.997 metacpan
Curses::Widgets::ButtonSet Button Set Widgets 1.103 metacpan
Curses::Widgets::Calendar Calendar Widgets 1.103 metacpan
Curses::Widgets::ComboBox Combo-Box Widgets 1.103 metacpan
Curses::Widgets::Label Label Widgets 1.102 metacpan
Curses::Widgets::ListBox List Box Widgets 1.104 metacpan
Curses::Widgets::ListBox::MultiColumn Multi-Column List Box Widgets 0.1 metacpan
Curses::Widgets::Menu Menu Widgets 1.103 metacpan
Curses::Widgets::ProgressBar Progress Bar Widgets 1.103 metacpan
Curses::Widgets::TextField Text Field Widgets 1.103 metacpan
Curses::Widgets::TextMemo Text Memo Widgets 1.104 metacpan

Other Files

MANIFEST metacpan
Makefile.PL metacpan
README metacpan