Dancer-Session-MongoDB

Metadata

Analyzed metadata and errors of Dancer-Session-MongoDB.

{
   "abstracts_in_pod" : {
      "Dancer::Session::MongoDB" : "MongoDB session backend for Dancer."
   },
   "author" : "IDOPEREL",
   "buildfile_executable" : 0,
   "dir_lib" : "lib",
   "dir_t" : "t",
   "dirs_array" : [
      "lib",
      "lib/Dancer",
      "lib/Dancer/Session",
      "t"
   ],
   "dist" : "Dancer-Session-MongoDB",
   "dynamic_config" : 0,
   "easily_repackageable_by_fedora" : "fits_fedora_license",
   "error" : {
      "metayml_is_parsable" : "META.yml was not found",
      "valid_signature" : "WARNING: This key is not certified with a trusted signature!\nPrimary key fingerprint: D8B4 918C 1EC7 6AC4 7BA2  083D 6B83 8740 014C D747\n"
   },
   "extension" : "tar.gz",
   "external_license_file" : "LICENSE",
   "extractable" : 1,
   "extracts_nicely" : 1,
   "file__build" : 0,
   "file_blib" : 0,
   "file_build" : 0,
   "file_changelog" : "Changes",
   "file_dist_ini" : "dist.ini",
   "file_license" : "LICENSE",
   "file_makefile" : 0,
   "file_makefile_pl" : "Makefile.PL",
   "file_manifest" : "MANIFEST",
   "file_meta_json" : "META.json",
   "file_pm_to_blib" : 0,
   "file_readme" : "README",
   "file_signature" : "SIGNATURE",
   "files_array" : [
      "dist.ini",
      "README",
      "META.json",
      "Changes",
      "INSTALL",
      "Makefile.PL",
      "SIGNATURE",
      "MANIFEST",
      "LICENSE",
      "MANIFEST.SKIP",
      "lib/Dancer/Session/MongoDB.pm",
      "t/00-load.t",
      "t/01-basic.t",
      "t/release-dist-manifest.t"
   ],
   "files_hash" : {
      "Changes" : {
         "mtime" : 1396302308,
         "size" : 811
      },
      "INSTALL" : {
         "mtime" : 1396302308,
         "size" : 1028
      },
      "LICENSE" : {
         "mtime" : 1396302308,
         "size" : 18352
      },
      "MANIFEST" : {
         "mtime" : 1396302308,
         "size" : 257
      },
      "MANIFEST.SKIP" : {
         "mtime" : 1396302308,
         "size" : 235
      },
      "META.json" : {
         "mtime" : 1396302308,
         "size" : 1512
      },
      "Makefile.PL" : {
         "mtime" : 1396302308,
         "size" : 1482,
         "used" : [
            "5.006",
            "ExtUtils::MakeMaker",
            "strict",
            "warnings"
         ]
      },
      "README" : {
         "mtime" : 1396302308,
         "size" : 4476
      },
      "SIGNATURE" : {
         "mtime" : 1396302308,
         "size" : 1530
      },
      "dist.ini" : {
         "mtime" : 1396302308,
         "size" : 158
      },
      "lib/Dancer/Session/MongoDB.pm" : {
         "license" : "GPL_1,GPL_2,GPL_3",
         "module" : "Dancer::Session::MongoDB",
         "mtime" : 1396302308,
         "size" : 6106,
         "used" : [
            "Carp",
            "Dancer::Config",
            "Dancer::ModuleLoader",
            "Dancer::Session::Abstract",
            "MongoDB",
            "strict",
            "vars",
            "version",
            "warnings"
         ]
      },
      "t/00-load.t" : {
         "mtime" : 1396302308,
         "size" : 205,
         "used" : [
            "Test::More"
         ]
      },
      "t/01-basic.t" : {
         "mtime" : 1396302308,
         "size" : 821,
         "used" : [
            "Dancer::Config",
            "Dancer::Session::MongoDB",
            "Test::More",
            "strict",
            "warnings"
         ]
      },
      "t/release-dist-manifest.t" : {
         "mtime" : 1396302308,
         "required" : [
            "Test::More"
         ],
         "size" : 310,
         "used" : [
            "Test::More"
         ],
         "used_in_eval" : [
            "Test::DistManifest"
         ]
      }
   },
   "got_prereq_from" : "META.yml",
   "kwalitee" : {
      "buildtool_not_executable" : 1,
      "consistent_version" : 1,
      "easily_repackageable_by_debian" : 1,
      "easily_repackageable_by_fedora" : 0,
      "extractable" : 1,
      "extracts_nicely" : 1,
      "fits_fedora_license" : 0,
      "has_abstract_in_pod" : 1,
      "has_buildtool" : 1,
      "has_changelog" : 1,
      "has_human_readable_license" : 1,
      "has_known_license_in_source_file" : 1,
      "has_license_in_source_file" : 1,
      "has_manifest" : 1,
      "has_meta_yml" : 0,
      "has_proper_version" : 1,
      "has_readme" : 1,
      "has_separate_license_file" : 1,
      "has_tests" : 1,
      "has_tests_in_t_dir" : 1,
      "has_version" : 1,
      "kwalitee" : "90.24",
      "manifest_matches_dist" : 1,
      "metayml_conforms_to_known_spec" : 0,
      "metayml_declares_perl_version" : 0,
      "metayml_has_license" : 1,
      "metayml_has_provides" : 0,
      "metayml_has_repository_resource" : 1,
      "metayml_is_parsable" : 0,
      "no_abstract_stub_in_pod" : 1,
      "no_broken_auto_install" : 1,
      "no_broken_module_install" : 1,
      "no_dot_dirs" : 1,
      "no_dot_underscore_files" : 1,
      "no_generated_files" : 1,
      "no_invalid_versions" : 1,
      "no_local_dirs" : 1,
      "no_mymeta_files" : 1,
      "no_pax_headers" : 1,
      "no_pod_errors" : 1,
      "no_stdin_for_prompting" : 1,
      "no_symlinks" : 1,
      "package_version_matches_dist_version" : 1,
      "portable_filenames" : 1,
      "proper_libs" : 1,
      "use_strict" : 1,
      "use_warnings" : 1,
      "valid_signature" : 1
   },
   "latest_mtime" : 1396302308,
   "license" : "ARRAY(0x592d7b0) defined in META.yml defined in LICENSE",
   "license_from_yaml" : [
      "perl_5"
   ],
   "license_in_pod" : 1,
   "licenses" : {
      "GPL_1" : [
         "lib/Dancer/Session/MongoDB.pm"
      ],
      "GPL_2" : [
         "lib/Dancer/Session/MongoDB.pm"
      ],
      "GPL_3" : [
         "lib/Dancer/Session/MongoDB.pm"
      ]
   },
   "manifest_matches_dist" : 1,
   "meta_yml" : {
      "abstract" : "MongoDB session backend for Dancer.",
      "author" : [
         "Ido Perlmuter <ido@ido50.net>"
      ],
      "dynamic_config" : 0,
      "generated_by" : "Dist::Zilla version 5.015, CPAN::Meta::Converter version 2.133380",
      "license" : [
         "perl_5"
      ],
      "meta-spec" : {
         "url" : "http://search.cpan.org/perldoc?CPAN::Meta::Spec",
         "version" : "2"
      },
      "name" : "Dancer-Session-MongoDB",
      "prereqs" : {
         "configure" : {
            "requires" : {
               "ExtUtils::MakeMaker" : "6.30"
            }
         },
         "runtime" : {
            "requires" : {
               "Carp" : "0",
               "Dancer::Config" : "0",
               "Dancer::ModuleLoader" : "0",
               "Dancer::Session::Abstract" : "0",
               "MongoDB" : "0",
               "base" : "0",
               "perl" : "5.006",
               "strict" : "0",
               "vars" : "0",
               "version" : "0",
               "warnings" : "0"
            }
         },
         "test" : {
            "requires" : {
               "Test::More" : "0"
            }
         }
      },
      "release_status" : "stable",
      "resources" : {
         "bugtracker" : {
            "web" : "https://github.com/ido50/Dancer-Session-MongoDB/issues"
         },
         "homepage" : "http://search.cpan.org/dist/Dancer-Session-MongoDB",
         "repository" : {
            "type" : "git",
            "url" : "git://github.com/ido50/Dancer-Session-MongoDB.git",
            "web" : "https://github.com/ido50/Dancer-Session-MongoDB"
         }
      },
      "version" : "1.000000"
   },
   "metayml_is_parsable" : 1,
   "modules" : [
      {
         "file" : "lib/Dancer/Session/MongoDB.pm",
         "in_basedir" : 0,
         "in_lib" : 1,
         "module" : "Dancer::Session::MongoDB"
      }
   ],
   "no_pax_headers" : 1,
   "package" : "Dancer-Session-MongoDB-1.000000.tar.gz",
   "prereq" : [
      {
         "is_prereq" : 1,
         "requires" : "version",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "Dancer::Config",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "vars",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "Dancer::ModuleLoader",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "Carp",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_build_prereq" : 1,
         "requires" : "Test::More",
         "type" : "test_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "MongoDB",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "strict",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "requires" : "ExtUtils::MakeMaker",
         "type" : "configure_requires",
         "version" : "6.30"
      },
      {
         "is_prereq" : 1,
         "requires" : "Dancer::Session::Abstract",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "perl",
         "type" : "runtime_requires",
         "version" : "5.006"
      },
      {
         "is_prereq" : 1,
         "requires" : "base",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "warnings",
         "type" : "runtime_requires",
         "version" : "0"
      }
   ],
   "released_epoch" : 1396302389,
   "size_packed" : 14236,
   "size_unpacked" : 37283,
   "uses" : {
      "required_in_tests" : {
         "Test::More" : 1
      },
      "used_in_code" : {
         "Carp" : 1,
         "Dancer::Config" : 1,
         "Dancer::ModuleLoader" : 1,
         "Dancer::Session::Abstract" : 1,
         "MongoDB" : 1,
         "strict" : 1,
         "vars" : 1,
         "version" : 1,
         "warnings" : 1
      },
      "used_in_config" : {
         "5.006" : 1,
         "ExtUtils::MakeMaker" : 1,
         "strict" : 1,
         "warnings" : 1
      },
      "used_in_eval_in_tests" : {
         "Test::DistManifest" : 1
      },
      "used_in_tests" : {
         "Dancer::Config" : 1,
         "Test::More" : 3,
         "strict" : 1,
         "warnings" : 1
      }
   },
   "valid_signature" : 0,
   "version" : "1.000000",
   "versions" : {
      "lib/Dancer/Session/MongoDB.pm" : {
         "Dancer::Session::MongoDB" : "1.000000"
      }
   },
   "vname" : "Dancer-Session-MongoDB-1.000000"
}