Under maintenance.

Most probably CPANTS databases are being regenerated from scratch due to major changes in Kwalitee metrics or updates of relevant modules/perl. Usually this maintenance takes about a day or two, and some of the information may be old or missing tentatively. Sorry for the inconvenience.

Kwalitee Issues

no_pod_errors

Remove the POD errors. You can check for POD errors automatically by including Test::Pod to your test suite.

Error: Data-Stag-0.14/Data/Stag/HashDB.pm -- Around line 40: Deleting unknown formatting code N<> Data-Stag-0.14/scripts/stag-autoschema.pl -- Around line 137: Expected text after =item, not a bullet Data-Stag-0.14/scripts/stag-diff.pl -- Around line 189: =over should be: '=over' or '=over positive_number' Data-Stag-0.14/scripts/stag-handle.pl -- Around line 138: =over should be: '=over' or '=over positive_number' Data-Stag-0.14/scripts/stag-join.pl -- Around line 108: '=item' outside of any '=over'Around line 118: You forgot a '=back' before '=head1' Data-Stag-0.14/scripts/stag-parse.pl -- Around line 152: Expected text after =item, not a bullet

use_strict

Add 'use strict' (or its equivalents) to all modules, or convince us that your favorite module is well-known enough and people can easily see the modules are strictly written.

Error: Data::Stag::Base, Data::Stag::StagDB, Data::Stag::StagI

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

meta_yml_has_license

Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.

proper_libs

Move your *.pm files in a directory named 'lib'. The directory structure should look like 'lib/Your/Module.pm' for a module named 'Your::Module'. If you need to provide additional files, e.g. for testing, that should not be considered for Kwalitee, then you should look at the 'provides' map in META.yml to limit the files scanned; or use the 'no_index' map to exclude parts of the distribution.

Error: Data/Stag.pm, Data/Stag/Arr2HTML.pm, Data/Stag/Base.pm, Data/Stag/BaseGenerator.pm, Data/Stag/ChainHandler.pm, Data/Stag/DTDWriter.pm, Data/Stag/GraphHandler.pm, Data/Stag/HashDB.pm, Data/Stag/ITextParser.pm, Data/Stag/ITextWriter.pm, Data/Stag/IndentParser.pm, Data/Stag/IndentWriter.pm, Data/Stag/JSONWriter.pm, Data/Stag/PerlWriter.pm, Data/Stag/PodParser.pm, Data/Stag/SAX2Stag.pm, Data/Stag/Simple.pm, Data/Stag/StagDB.pm, Data/Stag/StagI.pm, Data/Stag/StagImpl.pm, Data/Stag/SxprParser.pm, Data/Stag/SxprWriter.pm, Data/Stag/Util.pm, Data/Stag/Writer.pm, Data/Stag/XMLParser.pm, Data/Stag/XMLWriter.pm, Data/Stag/XSLHandler.pm, Data/Stag/XSLTHandler.pm, Data/Stag/null.pm, Data/Stag/BaseHandler.pm

use_warnings

Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: Data::Stag, Data::Stag::Arr2HTML, Data::Stag::Base, Data::Stag::BaseGenerator, Data::Stag::ChainHandler, Data::Stag::DTDWriter, Data::Stag::GraphHandler, Data::Stag::HashDB, Data::Stag::ITextParser, Data::Stag::ITextWriter, Data::Stag::IndentParser, Data::Stag::IndentWriter, Data::Stag::JSONWriter, Data::Stag::PerlWriter, Data::Stag::PodParser, Data::Stag::SAX2Stag, Data::Stag::Simple, Data::Stag::StagDB, Data::Stag::StagI, Data::Stag::StagImpl, Data::Stag::SxprParser, Data::Stag::SxprWriter, Data::Stag::Util, Data::Stag::Writer, Data::Stag::XMLParser, Data::Stag::XMLWriter, Data::Stag::XSLHandler, Data::Stag::XSLTHandler, Data::Stag::null, MyPersonHandler

has_separate_license_file

This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

meta_yml_has_repository_resource

Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).

Modules

Name Abstract Version View
Data::Stag Structured Tags datastructures 0.14 metacpan
Data::Stag::Arr2HTML null 0.14 metacpan
Data::Stag::Base 0.14 metacpan
Data::Stag::BaseGenerator base class for parsers and other event generators metacpan
Data::Stag::ChainHandler Chain Handler 0.14 metacpan
Data::Stag::DTDWriter DTD Writer 0.14 metacpan
Data::Stag::GraphHandler Graph Handler 0.14 metacpan
Data::Stag::HashDB build indexes over Stag files or objects 0.14 metacpan
Data::Stag::ITextParser 0.14 metacpan
Data::Stag::ITextWriter writes stag events into stag IText format 0.14 metacpan
Data::Stag::IndentParser 0.14 metacpan
Data::Stag::IndentWriter writes stag events into stag indent format 0.14 metacpan
Data::Stag::JSONWriter writes stag events into JSON files 0.14 metacpan
Data::Stag::PerlWriter writes stag events into perl POD documentation 0.14 metacpan
Data::Stag::PodParser 0.14 metacpan
Data::Stag::SAX2Stag converts SAX events into Stag events 0.14 metacpan
Data::Stag::Simple Simple 0.14 metacpan
Data::Stag::StagDB persistent storage and retrieval of stag nodes 0.14 metacpan
Data::Stag::StagI metacpan
Data::Stag::StagImpl default implementation for Data::Stag 0.14 metacpan
Data::Stag::SxprParser 0.14 metacpan
Data::Stag::SxprWriter writes Stag S-expression format 0.14 metacpan
Data::Stag::Util 0.14 metacpan
Data::Stag::Writer base class for all Writers 0.14 metacpan
Data::Stag::XMLParser 0.14 metacpan
Data::Stag::XMLWriter writes stag events into XML files 0.14 metacpan
Data::Stag::XSLHandler XSL Handler metacpan
Data::Stag::XSLTHandler XSLT Handler metacpan
Data::Stag::null 0.14 metacpan

Provides

Name File View
Data::Stag::BaseHandler Data/Stag/BaseHandler.pm metacpan

Other Files

Changes metacpan
MANIFEST metacpan
META.json metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan