Debian-Apt-PM

Metadata

Analyzed metadata and errors of Debian-Apt-PM.

{
   "abstracts_in_pod" : {
      "Acme::SysPath::SPc" : "build-time system path configuration",
      "Debian::Apt::PM" : "locate Perl Modules in Debian repositories",
      "SettingUpBuildSystem" : "How to set-up a chrooted build system"
   },
   "author" : "JKUTEJ",
   "buildfile_executable" : 0,
   "dir_lib" : "lib",
   "dir_t" : "t",
   "dirs_array" : [
      "lib",
      "lib/Debian",
      "lib/Debian/Apt",
      "lib/Debian/Apt/PM",
      "sharedstate",
      "sharedstate/dh-make-pm",
      "t",
      "patches",
      "cache",
      "cache/apt",
      "cache/apt/apt-pm",
      "cache/apt/apt-pm/deb-src",
      "cache/apt/apt-pm/deb",
      "examples",
      "examples/reprepo",
      "examples/reprepo/www",
      "examples/reprepo/www/repo",
      "examples/reprepo/www/repo/conf",
      "examples/reprepo/bin",
      "examples/web",
      "examples/web/CPAN",
      "examples/repo",
      "examples/repo/unstable",
      "script"
   ],
   "dist" : "Debian-Apt-PM",
   "dynamic_config" : 1,
   "error" : {
      "consistent_version" : "0.08,0.09"
   },
   "extension" : "tar.gz",
   "extractable" : 1,
   "extracts_nicely" : 1,
   "file__build" : 0,
   "file_blib" : 0,
   "file_build" : 0,
   "file_build_pl" : "Build.PL",
   "file_changelog" : "Changes",
   "file_makefile" : 0,
   "file_manifest" : "MANIFEST",
   "file_meta_json" : "META.json",
   "file_meta_yml" : "META.yml",
   "file_pm_to_blib" : 0,
   "file_readme" : "README",
   "files_array" : [
      "README",
      "Build.PL",
      "META.json",
      "Changes",
      "META.yml",
      "MANIFEST",
      "lib/Debian/Apt/PM.pm",
      "lib/Debian/Apt/PM/SPc.pm",
      "lib/Debian/Apt/PM/SettingUpBuildSystem.pod",
      "sharedstate/dh-make-pm/.exists",
      "t/pod-spell.t",
      "t/pod-coverage.t",
      "t/01_Debian-Apt-PM.t",
      "t/distribution.t",
      "t/PerlPackages.bz2",
      "t/00_compile.t",
      "t/PerlPackages2.bz2",
      "t/pod.t",
      "patches/DhMakePerl.pm.patch",
      "patches/Distribution.pm.patch",
      "patches/FromCPAN.pm.patch",
      "cache/apt/apt-pm/deb-src/.exists",
      "cache/apt/apt-pm/deb/.exists",
      "examples/mass-build",
      "examples/reprepo/.bash_profile",
      "examples/reprepo/www/repo/.htaccess",
      "examples/reprepo/www/repo/conf/uploaders",
      "examples/reprepo/www/repo/conf/distributions",
      "examples/reprepo/bin/import-new-packages",
      "examples/web/grid.css",
      "examples/web/reset.css",
      "examples/web/index.html",
      "examples/web/jquery.getParams.js",
      "examples/web/spinner.gif",
      "examples/web/style.css",
      "examples/web/jquery-1.5.2.js",
      "examples/web/jquery.ba-hashchange.js",
      "examples/web/script.js",
      "examples/web/md5.js",
      "examples/web/CPAN/.exists",
      "examples/repo/Makefile",
      "examples/repo/Release.conf",
      "examples/repo/unstable/.exists",
      "script/apt-cpan",
      "script/dh-make-pm",
      "script/dpkg-scanpmpackages",
      "script/apt-pm-web",
      "script/apt-pm"
   ],
   "files_hash" : {
      "Build.PL" : {
         "mtime" : 1356211926,
         "size" : 2711,
         "used" : [
            "5.010",
            "Module::Build::SysPath",
            "strict",
            "warnings"
         ]
      },
      "Changes" : {
         "mtime" : 1356211926,
         "size" : 1681
      },
      "MANIFEST" : {
         "mtime" : 1356211926,
         "size" : 1143
      },
      "META.json" : {
         "mtime" : 1356211926,
         "size" : 2690
      },
      "META.yml" : {
         "mtime" : 1356211926,
         "size" : 1581
      },
      "README" : {
         "mtime" : 1356211926,
         "size" : 6821
      },
      "cache/apt/apt-pm/deb-src/.exists" : {
         "mtime" : 1356211926,
         "size" : 0
      },
      "cache/apt/apt-pm/deb/.exists" : {
         "mtime" : 1356211926,
         "size" : 0
      },
      "examples/mass-build" : {
         "mtime" : 1356211926,
         "size" : 7042
      },
      "examples/repo/Makefile" : {
         "mtime" : 1356211926,
         "size" : 711
      },
      "examples/repo/Release.conf" : {
         "mtime" : 1356211926,
         "size" : 242
      },
      "examples/repo/unstable/.exists" : {
         "mtime" : 1356211926,
         "size" : 0
      },
      "examples/reprepo/.bash_profile" : {
         "mtime" : 1356211926,
         "size" : 533
      },
      "examples/reprepo/bin/import-new-packages" : {
         "mtime" : 1356211926,
         "size" : 944
      },
      "examples/reprepo/www/repo/.htaccess" : {
         "mtime" : 1356211926,
         "size" : 17
      },
      "examples/reprepo/www/repo/conf/distributions" : {
         "mtime" : 1356211926,
         "size" : 393
      },
      "examples/reprepo/www/repo/conf/uploaders" : {
         "mtime" : 1356211926,
         "size" : 74
      },
      "examples/web/CPAN/.exists" : {
         "mtime" : 1356211926,
         "size" : 0
      },
      "examples/web/grid.css" : {
         "mtime" : 1356211926,
         "size" : 4609
      },
      "examples/web/index.html" : {
         "mtime" : 1356211926,
         "size" : 2326
      },
      "examples/web/jquery-1.5.2.js" : {
         "mtime" : 1356211926,
         "size" : 219227
      },
      "examples/web/jquery.ba-hashchange.js" : {
         "mtime" : 1356211926,
         "size" : 16427
      },
      "examples/web/jquery.getParams.js" : {
         "mtime" : 1356211926,
         "size" : 1370
      },
      "examples/web/md5.js" : {
         "mtime" : 1356211926,
         "size" : 11918
      },
      "examples/web/reset.css" : {
         "mtime" : 1356211926,
         "size" : 1062
      },
      "examples/web/script.js" : {
         "mtime" : 1356211926,
         "size" : 3956
      },
      "examples/web/spinner.gif" : {
         "mtime" : 1356211926,
         "size" : 1553
      },
      "examples/web/style.css" : {
         "mtime" : 1356211926,
         "size" : 451
      },
      "lib/Debian/Apt/PM.pm" : {
         "license" : "GPL_1,GPL_2,GPL_3",
         "module" : "Debian::Apt::PM",
         "mtime" : 1356211926,
         "size" : 16228,
         "used" : [
            "5.010",
            "AptPkg::Config",
            "CPAN::Version",
            "Carp",
            "Debian::Apt::PM::SPc",
            "Dpkg::Version",
            "File::is",
            "IO::Any",
            "IO::Uncompress::Bunzip2",
            "JSON::Util",
            "LWP::Simple",
            "List::MoreUtils",
            "Moose",
            "Parse::Deb::Control",
            "Storable",
            "strict",
            "warnings"
         ]
      },
      "lib/Debian/Apt/PM/SPc.pm" : {
         "module" : "Debian::Apt::PM::SPc",
         "mtime" : 1356211926,
         "size" : 700,
         "used" : [
            "File::Spec",
            "Sys::Path",
            "strict",
            "warnings"
         ]
      },
      "lib/Debian/Apt/PM/SettingUpBuildSystem.pod" : {
         "mtime" : 1356211926,
         "size" : 5971
      },
      "patches/DhMakePerl.pm.patch" : {
         "mtime" : 1356211926,
         "size" : 1008
      },
      "patches/Distribution.pm.patch" : {
         "mtime" : 1356211926,
         "size" : 1270
      },
      "patches/FromCPAN.pm.patch" : {
         "mtime" : 1356211926,
         "size" : 1096
      },
      "script/apt-cpan" : {
         "mtime" : 1356211926,
         "size" : 1948
      },
      "script/apt-pm" : {
         "mtime" : 1356211926,
         "size" : 2631
      },
      "script/apt-pm-web" : {
         "mtime" : 1356211926,
         "size" : 4210
      },
      "script/dh-make-pm" : {
         "mtime" : 1356211926,
         "size" : 11467
      },
      "script/dpkg-scanpmpackages" : {
         "mtime" : 1356211926,
         "size" : 11450
      },
      "sharedstate/dh-make-pm/.exists" : {
         "mtime" : 1356211926,
         "size" : 0
      },
      "t/00_compile.t" : {
         "mtime" : 1356211926,
         "size" : 219,
         "used" : [
            "Test::More",
            "strict"
         ],
         "used_in_eval" : [
            "Test::Compile"
         ]
      },
      "t/01_Debian-Apt-PM.t" : {
         "mtime" : 1356211926,
         "size" : 8452,
         "used" : [
            "FindBin",
            "Test::Differences",
            "Test::Exception",
            "Test::More",
            "lib",
            "strict",
            "warnings"
         ]
      },
      "t/PerlPackages.bz2" : {
         "mtime" : 1356211926,
         "size" : 419
      },
      "t/PerlPackages2.bz2" : {
         "mtime" : 1356211926,
         "size" : 447
      },
      "t/distribution.t" : {
         "mtime" : 1356211926,
         "size" : 122,
         "used" : [
            "Test::More"
         ],
         "used_in_eval" : [
            "Test::Distribution"
         ]
      },
      "t/pod-coverage.t" : {
         "mtime" : 1356211926,
         "size" : 551,
         "used" : [
            "Test::More",
            "strict",
            "warnings"
         ],
         "used_in_eval" : [
            "Pod::Coverage",
            "Test::Pod::Coverage"
         ]
      },
      "t/pod-spell.t" : {
         "mtime" : 1356211926,
         "size" : 528,
         "used" : [
            "Test::More"
         ],
         "used_in_eval" : [
            "Test::Spelling"
         ]
      },
      "t/pod.t" : {
         "mtime" : 1356211926,
         "size" : 232,
         "used" : [
            "Test::More",
            "strict",
            "warnings"
         ],
         "used_in_eval" : [
            "Test::Pod"
         ]
      }
   },
   "got_prereq_from" : "META.yml",
   "kwalitee" : {
      "buildtool_not_executable" : 1,
      "consistent_version" : 0,
      "distname_matches_name_in_meta" : 1,
      "extractable" : 1,
      "extracts_nicely" : 1,
      "has_abstract_in_pod" : 1,
      "has_buildtool" : 1,
      "has_changelog" : 1,
      "has_human_readable_license" : 1,
      "has_known_license_in_source_file" : 1,
      "has_license_in_source_file" : 1,
      "has_manifest" : 1,
      "has_meta_yml" : 1,
      "has_proper_version" : 1,
      "has_readme" : 1,
      "has_separate_license_file" : 0,
      "has_tests" : 1,
      "has_tests_in_t_dir" : 1,
      "has_version" : 1,
      "kwalitee" : "95.45",
      "manifest_matches_dist" : 1,
      "meta_json_conforms_to_known_spec" : 1,
      "meta_json_is_parsable" : 1,
      "meta_yml_conforms_to_known_spec" : 1,
      "meta_yml_declares_perl_version" : 0,
      "meta_yml_has_license" : 1,
      "meta_yml_has_provides" : 1,
      "meta_yml_has_repository_resource" : 1,
      "meta_yml_is_parsable" : 1,
      "no_abstract_stub_in_pod" : 1,
      "no_broken_auto_install" : 1,
      "no_broken_module_install" : 1,
      "no_dot_dirs" : 1,
      "no_dot_underscore_files" : 1,
      "no_generated_files" : 1,
      "no_invalid_versions" : 1,
      "no_local_dirs" : 1,
      "no_mymeta_files" : 1,
      "no_pax_headers" : 1,
      "no_pod_errors" : 1,
      "no_stdin_for_prompting" : 1,
      "no_symlinks" : 1,
      "package_version_matches_dist_version" : 1,
      "portable_filenames" : 1,
      "proper_libs" : 1,
      "use_strict" : 1,
      "use_warnings" : 1,
      "valid_signature" : 1
   },
   "latest_mtime" : 1356211926,
   "license" : "perl defined in META.yml",
   "license_from_yaml" : "perl",
   "license_in_pod" : 1,
   "licenses" : {
      "GPL_1" : [
         "lib/Debian/Apt/PM.pm"
      ],
      "GPL_2" : [
         "lib/Debian/Apt/PM.pm"
      ],
      "GPL_3" : [
         "lib/Debian/Apt/PM.pm"
      ]
   },
   "manifest_matches_dist" : 1,
   "meta_json_is_parsable" : 1,
   "meta_json_spec_version" : "2",
   "meta_yml" : {
      "abstract" : "locate Perl Modules in Debian repositories",
      "author" : [
         "Jozef Kutej <jkutej@cpan.org>"
      ],
      "build_requires" : {
         "Module::Build::SysPath" : "0.13",
         "Test::Differences" : "0",
         "Test::Exception" : "0",
         "Test::More" : "0"
      },
      "configure_requires" : {
         "Module::Build" : "0.3607",
         "Module::Build::SysPath" : "0.13"
      },
      "dynamic_config" : "1",
      "generated_by" : "Module::Build version 0.38, CPAN::Meta::Converter version 2.112621",
      "keywords" : [
         "debian",
         "perl",
         "modules"
      ],
      "license" : "perl",
      "meta-spec" : {
         "url" : "http://module-build.sourceforge.net/META-spec-v1.4.html",
         "version" : "1.4"
      },
      "name" : "Debian-Apt-PM",
      "provides" : {
         "Debian::Apt::PM" : {
            "file" : "lib/Debian/Apt/PM.pm",
            "version" : "0.09"
         },
         "Debian::Apt::PM::SPc" : {
            "file" : "lib/Debian/Apt/PM/SPc.pm",
            "version" : "0.08"
         }
      },
      "requires" : {
         "AptPkg::Config" : "0",
         "CPAN" : "0",
         "CPAN::Module" : "0",
         "CPAN::PackageDetails" : "0",
         "CPAN::Patches" : "0",
         "CPAN::Patches::Plugin::Debian" : "0.03",
         "CPAN::Version" : "0",
         "Carp" : "0",
         "Data::Header::Fields" : "0.04",
         "DateTime" : "0",
         "Digest::MD5" : "0",
         "Dpkg::Version" : "0",
         "File::Basename" : "0",
         "File::Copy" : "0",
         "File::Find::Rule" : "0",
         "File::HomeDir" : "0",
         "File::Path" : "2.01",
         "File::Temp" : "0",
         "File::is" : "0",
         "Getopt::Long" : "0",
         "IO::Any" : "0",
         "IO::Uncompress::Bunzip2" : "0",
         "IO::Uncompress::Gunzip" : "0",
         "JSON::Util" : "0.04",
         "LWP::Simple" : "0",
         "List::MoreUtils" : "0",
         "MetaCPAN::API" : "0",
         "Module::Build::ModuleInfo" : "0",
         "Module::Depends::Intrusive" : "0",
         "Moose" : "0",
         "Parallel::Iterator" : "0",
         "Parse::Deb::Control" : "0.04",
         "Pod::Usage" : "0",
         "Storable" : "0"
      },
      "resources" : {
         "bugtracker" : "http://github.com/jozef/Debian-Apt-PM/issues",
         "license" : "http://dev.perl.org/licenses/",
         "repository" : "git://github.com/jozef/Debian-Apt-PM.git"
      },
      "version" : "0.09"
   },
   "meta_yml_is_parsable" : 1,
   "meta_yml_spec_version" : "1.4",
   "modules" : [
      {
         "file" : "lib/Debian/Apt/PM/SPc.pm",
         "in_basedir" : 0,
         "in_lib" : 1,
         "module" : "Debian::Apt::PM::SPc"
      },
      {
         "file" : "lib/Debian/Apt/PM.pm",
         "in_basedir" : 0,
         "in_lib" : 1,
         "module" : "Debian::Apt::PM"
      }
   ],
   "no_pax_headers" : 1,
   "package" : "Debian-Apt-PM-0.09.tar.gz",
   "prereq" : [
      {
         "is_prereq" : 1,
         "requires" : "Storable",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "JSON::Util",
         "type" : "runtime_requires",
         "version" : "0.04"
      },
      {
         "is_prereq" : 1,
         "requires" : "CPAN::Patches",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "Pod::Usage",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "DateTime",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "List::MoreUtils",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_build_prereq" : 1,
         "requires" : "Module::Build::SysPath",
         "type" : "build_requires",
         "version" : "0.13"
      },
      {
         "requires" : "Module::Build::SysPath",
         "type" : "configure_requires",
         "version" : "0.13"
      },
      {
         "is_prereq" : 1,
         "requires" : "Data::Header::Fields",
         "type" : "runtime_requires",
         "version" : "0.04"
      },
      {
         "is_prereq" : 1,
         "requires" : "File::Path",
         "type" : "runtime_requires",
         "version" : "2.01"
      },
      {
         "is_prereq" : 1,
         "requires" : "Digest::MD5",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "CPAN::Version",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "Parse::Deb::Control",
         "type" : "runtime_requires",
         "version" : "0.04"
      },
      {
         "is_prereq" : 1,
         "requires" : "File::Basename",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "requires" : "Module::Build",
         "type" : "configure_requires",
         "version" : "0.3607"
      },
      {
         "is_prereq" : 1,
         "requires" : "Module::Build::ModuleInfo",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "Carp",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "IO::Uncompress::Bunzip2",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "Parallel::Iterator",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "LWP::Simple",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "File::Temp",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "File::is",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "IO::Any",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "File::Find::Rule",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "CPAN::Patches::Plugin::Debian",
         "type" : "runtime_requires",
         "version" : "0.03"
      },
      {
         "is_prereq" : 1,
         "requires" : "Getopt::Long",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "File::HomeDir",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "IO::Uncompress::Gunzip",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "File::Copy",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "CPAN::Module",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "CPAN::PackageDetails",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "Dpkg::Version",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_build_prereq" : 1,
         "requires" : "Test::Differences",
         "type" : "build_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "AptPkg::Config",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "CPAN",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "MetaCPAN::API",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_build_prereq" : 1,
         "requires" : "Test::Exception",
         "type" : "build_requires",
         "version" : "0"
      },
      {
         "is_build_prereq" : 1,
         "requires" : "Test::More",
         "type" : "build_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "Moose",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "Module::Depends::Intrusive",
         "type" : "runtime_requires",
         "version" : "0"
      }
   ],
   "released_epoch" : 1356212166,
   "size_packed" : 132596,
   "size_unpacked" : 358431,
   "uses" : {
      "used_in_code" : {
         "5.010" : 1,
         "AptPkg::Config" : 1,
         "CPAN::Version" : 1,
         "Carp" : 1,
         "Dpkg::Version" : 1,
         "File::Spec" : 1,
         "File::is" : 1,
         "IO::Any" : 1,
         "IO::Uncompress::Bunzip2" : 1,
         "JSON::Util" : 1,
         "LWP::Simple" : 1,
         "List::MoreUtils" : 1,
         "Moose" : 1,
         "Parse::Deb::Control" : 1,
         "Storable" : 1,
         "Sys::Path" : 1,
         "strict" : 2,
         "warnings" : 2
      },
      "used_in_config" : {
         "5.010" : 1,
         "Module::Build::SysPath" : 1,
         "strict" : 1,
         "warnings" : 1
      },
      "used_in_eval_in_tests" : {
         "Pod::Coverage" : 1,
         "Test::Compile" : 1,
         "Test::Distribution" : 1,
         "Test::Pod" : 1,
         "Test::Pod::Coverage" : 1,
         "Test::Spelling" : 1
      },
      "used_in_tests" : {
         "FindBin" : 1,
         "Test::Differences" : 1,
         "Test::Exception" : 1,
         "Test::More" : 6,
         "lib" : 1,
         "strict" : 4,
         "warnings" : 3
      }
   },
   "valid_signature" : -1,
   "version" : "0.09",
   "versions" : {
      "lib/Debian/Apt/PM.pm" : {
         "Debian::Apt::PM" : "0.09"
      },
      "lib/Debian/Apt/PM/SPc.pm" : {
         "Debian::Apt::PM::SPc" : "0.08"
      }
   },
   "vname" : "Debian-Apt-PM-0.09"
}