Kwalitee Issues

no_pod_errors

Remove the POD errors. You can check for POD errors automatically by including Test::Pod to your test suite.

Error: Device-OUI-1.04/lib/Device/OUI.pm -- Around line 370: alternative text 'Class::Accessor::Grouped/get_inherited' contains non-escaped | or /Around line 408: alternative text '/search_url_for' contains non-escaped | or / alternative text 'perlfunc/sprintf' contains non-escaped | or /Around line 426: alternative text '/oui' contains non-escaped | or /Around line 434: alternative text '/load_cache_from_file' contains non-escaped | or / alternative text '/cache_file' contains non-escaped | or / alternative text '/cache_file' contains non-escaped | or /Around line 446: alternative text '/load_cache_from_web' contains non-escaped | or / alternative text '/file_url' contains non-escaped | or / alternative text '/file_url' contains non-escaped | or /Around line 453: alternative text 'LWP::Simple/mirror' contains non-escaped | or /Around line 477: alternative text '/cache_db' contains non-escaped | or /Around line 482: alternative text '/cache_db' contains non-escaped | or /Around line 510: alternative text '/normalized' contains non-escaped | or /Around line 590: alternative text '/cache_db' contains non-escaped | or / alternative text '/cache_file' contains non-escaped | or / alternative text '/search_url' contains non-escaped | or / alternative text '/file_url' contains non-escaped | or /Around line 611: alternative text '/cache' contains non-escaped | or /Around line 620: alternative text '/search_url' contains non-escaped | or /Around line 624: alternative text '/cache_db' contains non-escaped | or /Around line 632: alternative text '/cache_file' contains non-escaped | or /Around line 635: alternative text '/cache_db' contains non-escaped | or /Around line 661: alternative text '/search_url' contains non-escaped | or /Around line 675: alternative text 'LWP::Simple/mirror' contains non-escaped | or /Around line 681: alternative text '/cache_file' contains non-escaped | or / alternative text '/file_url' contains non-escaped | or /Around line 687: alternative text 'LWP::Simple/get' contains non-escaped | or /Around line 693: alternative text '/oui_cmp' contains non-escaped | or /Around line 708: alternative text '/load_cache_from_web' contains non-escaped | or / alternative text '/load_cache_from_file' contains non-escaped | or /Around line 724: alternative text '/cache_db' contains non-escaped | or /Around line 745: alternative text '/load_cache_from_web' contains non-escaped | or /

has_meta_json

Add a META.json to the distribution. Your buildtool should be able to autogenerate it.

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

has_separate_license_file

This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

meta_yml_has_repository_resource

Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).

Modules

Name Abstract Version View
Device::OUI Resolve an Organizationally Unique Identifier 1.04 metacpan

Other Files

Changes metacpan
MANIFEST metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan