Diamond

Metadata

Analyzed metadata and errors of Diamond.

{
   "abstracts_in_pod" : {
      "Diamond" : "Diamond. Is. A. Markup. Orientated. New. Direction. "
   },
   "author" : "LOGICUS",
   "buildfile_executable" : 0,
   "dir_lib" : "lib",
   "dir_t" : "t",
   "dir_xt" : "xt",
   "dirs_array" : [
      "lib",
      "t",
      "inc",
      "inc/Module",
      "inc/Module/Install",
      "xt"
   ],
   "dist" : "Diamond",
   "dynamic_config" : 0,
   "error" : {
      "manifest_matches_dist" : [
         "MANIFEST (26) does not match dist (25):",
         "Missing in MANIFEST: ",
         "Missing in Dist: .gitignore"
      ],
      "use_warnings" : "Diamond"
   },
   "extension" : "tar.gz",
   "extractable" : 1,
   "extracts_nicely" : 1,
   "file__build" : 0,
   "file_blib" : 0,
   "file_build" : 0,
   "file_changelog" : "Changes",
   "file_makefile" : 0,
   "file_makefile_pl" : "Makefile.PL",
   "file_manifest" : "MANIFEST",
   "file_meta_yml" : "META.yml",
   "file_pm_to_blib" : 0,
   "file_readme" : "README",
   "files_array" : [
      "README",
      "versions.pl",
      "Changes",
      "Makefile.PL",
      "META.yml",
      "MANIFEST",
      "lib/Diamond.pm"
   ],
   "files_hash" : {
      "Changes" : {
         "mtime" : 1328123814,
         "size" : 122
      },
      "MANIFEST" : {
         "mtime" : 1328122946,
         "size" : 555
      },
      "META.yml" : {
         "mtime" : 1328123455,
         "size" : 1277
      },
      "Makefile.PL" : {
         "mtime" : 1328122929,
         "required" : [
            "FileHandle",
            "lib::Diamond"
         ],
         "size" : 359,
         "used" : [
            "inc::Module::Install"
         ]
      },
      "README" : {
         "mtime" : 1328122864,
         "size" : 418
      },
      "inc/Module/AutoInstall.pm" : {
         "mtime" : 1282686747,
         "no_index" : 1,
         "size" : 22681
      },
      "inc/Module/Install.pm" : {
         "mtime" : 1282686746,
         "no_index" : 1,
         "size" : 12381
      },
      "inc/Module/Install/AutoInstall.pm" : {
         "mtime" : 1282686747,
         "no_index" : 1,
         "size" : 1946
      },
      "inc/Module/Install/Base.pm" : {
         "mtime" : 1282686746,
         "no_index" : 1,
         "size" : 1127
      },
      "inc/Module/Install/Can.pm" : {
         "mtime" : 1282687005,
         "no_index" : 1,
         "size" : 1755
      },
      "inc/Module/Install/Fetch.pm" : {
         "mtime" : 1282687005,
         "no_index" : 1,
         "size" : 2455
      },
      "inc/Module/Install/Include.pm" : {
         "mtime" : 1282686747,
         "no_index" : 1,
         "size" : 525
      },
      "inc/Module/Install/Makefile.pm" : {
         "mtime" : 1282686746,
         "no_index" : 1,
         "size" : 11802
      },
      "inc/Module/Install/Metadata.pm" : {
         "mtime" : 1282686746,
         "no_index" : 1,
         "size" : 17936
      },
      "inc/Module/Install/ReadmeFromPod.pm" : {
         "mtime" : 1282686746,
         "no_index" : 1,
         "size" : 612
      },
      "inc/Module/Install/Repository.pm" : {
         "mtime" : 1282687005,
         "no_index" : 1,
         "size" : 2222
      },
      "inc/Module/Install/Win32.pm" : {
         "mtime" : 1282687005,
         "no_index" : 1,
         "size" : 1795
      },
      "inc/Module/Install/WriteAll.pm" : {
         "mtime" : 1282687005,
         "no_index" : 1,
         "size" : 1278
      },
      "lib/Diamond.pm" : {
         "license" : "Perl_5",
         "module" : "Diamond",
         "mtime" : 1328123666,
         "size" : 7736,
         "used" : [
            "Exporter",
            "ExtUtils::MakeMaker",
            "strict"
         ]
      },
      "t/00_compile.t" : {
         "mtime" : 1328123532,
         "no_index" : 1,
         "size" : 67,
         "used" : [
            "Test::More",
            "strict"
         ]
      },
      "versions.pl" : {
         "mtime" : 1282686627,
         "size" : 2257
      },
      "xt/perlcritic.t" : {
         "mtime" : 1255424710,
         "no_index" : 1,
         "size" : 147
      },
      "xt/pod.t" : {
         "mtime" : 1255424710,
         "no_index" : 1,
         "size" : 129
      },
      "xt/podspell.t" : {
         "mtime" : 1328123510,
         "no_index" : 1,
         "size" : 225
      },
      "xt/synopsis.t" : {
         "mtime" : 1255424710,
         "no_index" : 1,
         "size" : 112
      }
   },
   "got_prereq_from" : "META.yml",
   "included_modules" : [
      "Module::Install::Base",
      "Module::Install::Repository",
      "Module::Install::Fetch",
      "Module::Install::Can",
      "Module::Install::Metadata",
      "Module::Install",
      "Module::Install::WriteAll",
      "Module::Install::Include",
      "Module::Install::ReadmeFromPod",
      "Module::Install::Win32",
      "Module::Install::Makefile",
      "Module::Install::AutoInstall",
      "Module::AutoInstall"
   ],
   "kwalitee" : {
      "buildtool_not_executable" : 1,
      "consistent_version" : 1,
      "distname_matches_name_in_meta" : 1,
      "extractable" : 1,
      "extracts_nicely" : 1,
      "has_abstract_in_pod" : 1,
      "has_buildtool" : 1,
      "has_changelog" : 1,
      "has_human_readable_license" : 1,
      "has_known_license_in_source_file" : 1,
      "has_license_in_source_file" : 1,
      "has_manifest" : 1,
      "has_meta_yml" : 1,
      "has_proper_version" : 0,
      "has_readme" : 1,
      "has_separate_license_file" : 0,
      "has_tests" : 1,
      "has_tests_in_t_dir" : 1,
      "has_version" : 0,
      "kwalitee" : "88.64",
      "manifest_matches_dist" : 0,
      "meta_json_conforms_to_known_spec" : 1,
      "meta_json_is_parsable" : 1,
      "meta_yml_conforms_to_known_spec" : 1,
      "meta_yml_declares_perl_version" : 1,
      "meta_yml_has_license" : 1,
      "meta_yml_has_provides" : 0,
      "meta_yml_has_repository_resource" : 1,
      "meta_yml_is_parsable" : 1,
      "no_abstract_stub_in_pod" : 1,
      "no_broken_auto_install" : 1,
      "no_broken_module_install" : 1,
      "no_dot_dirs" : 1,
      "no_dot_underscore_files" : 1,
      "no_generated_files" : 1,
      "no_invalid_versions" : 1,
      "no_local_dirs" : 1,
      "no_mymeta_files" : 1,
      "no_pax_headers" : 1,
      "no_pod_errors" : 1,
      "no_stdin_for_prompting" : 1,
      "no_symlinks" : 1,
      "package_version_matches_dist_version" : 0,
      "portable_filenames" : 1,
      "proper_libs" : 1,
      "use_strict" : 1,
      "use_warnings" : 0,
      "valid_signature" : 1
   },
   "latest_mtime" : 1328123814,
   "license" : "perl defined in META.yml",
   "license_file" : "lib/Diamond.pm",
   "license_from_yaml" : "perl",
   "license_in_pod" : 1,
   "license_type" : "Perl_5",
   "licenses" : {
      "Perl_5" : [
         "lib/Diamond.pm"
      ]
   },
   "manifest_matches_dist" : 0,
   "meta_yml" : {
      "abstract" : "Diamond",
      "author" : [
         "Simon James Odell <simonjamesodell@live.co.uk>"
      ],
      "build_requires" : {
         "ExtUtils::MakeMaker" : "6.42"
      },
      "configure_requires" : {
         "ExtUtils::MakeMaker" : "6.42"
      },
      "distribution_type" : "module",
      "generated_by" : "Module::Install version 1.00",
      "license" : "perl",
      "meta-spec" : {
         "url" : "http://module-build.sourceforge.net/META-spec-v1.4.html",
         "version" : "1.4"
      },
      "name" : "Diamond",
      "no_index" : {
         "directory" : [
            "inc",
            "t",
            "xt"
         ]
      },
      "requires" : {
         "CGI::Compile" : "0.12",
         "CGI::Emulate::PSGI" : "0.10",
         "CGI::PSGI" : "0.11",
         "Catalyst::Engine::PSGI" : "0.11",
         "Corona" : "0.1004",
         "Devel::StackTrace::WithLexicals" : "0.06",
         "FCGI" : "0.71",
         "FCGI::Client" : "0.04",
         "FCGI::ProcManager" : "0.19",
         "Flea" : "0.02",
         "HTTP::Server::Simple::PSGI" : "0.14",
         "IO::Handle::Util" : "0.01",
         "Net::FastCGI" : "0.12",
         "PSGI" : "1.03",
         "Plack" : "0.9945",
         "Plack::App::Proxy" : "0.15",
         "Plack::Handler::AnyEvent::ReverseHTTP" : "0.04",
         "Plack::Middleware::Auth::Digest" : "0.03",
         "Plack::Middleware::ConsoleLogger" : "0.02",
         "Plack::Middleware::Debug" : "0.09",
         "Plack::Middleware::Deflater" : "0.03",
         "Plack::Middleware::Header" : "0.03",
         "Plack::Middleware::ReverseProxy" : "0.06",
         "Plack::Middleware::Session" : "0.12",
         "Starlet" : "0.10",
         "Starman" : "0.2006",
         "Twiggy" : "0.1006",
         "perl" : "5.8.1"
      },
      "resources" : {
         "license" : "http://dev.perl.org/licenses/",
         "repository" : "git://github.com/DiamondML/Diamond.git"
      },
      "version" : "0.25"
   },
   "meta_yml_is_parsable" : 1,
   "meta_yml_spec_version" : "1.4",
   "module_install" : {
      "version" : "1.00"
   },
   "modules" : [
      {
         "file" : "lib/Diamond.pm",
         "in_basedir" : 0,
         "in_lib" : 1,
         "module" : "Diamond"
      }
   ],
   "no_index" : "^inc/;^t/;^xt/",
   "no_pax_headers" : 1,
   "package" : "Diamond.tar.gz",
   "prereq" : [
      {
         "is_prereq" : 1,
         "requires" : "FCGI::Client",
         "type" : "runtime_requires",
         "version" : "0.04"
      },
      {
         "is_prereq" : 1,
         "requires" : "FCGI::ProcManager",
         "type" : "runtime_requires",
         "version" : "0.19"
      },
      {
         "is_prereq" : 1,
         "requires" : "Catalyst::Engine::PSGI",
         "type" : "runtime_requires",
         "version" : "0.11"
      },
      {
         "is_prereq" : 1,
         "requires" : "Starlet",
         "type" : "runtime_requires",
         "version" : "0.10"
      },
      {
         "is_prereq" : 1,
         "requires" : "Plack::Middleware::Session",
         "type" : "runtime_requires",
         "version" : "0.12"
      },
      {
         "is_prereq" : 1,
         "requires" : "Devel::StackTrace::WithLexicals",
         "type" : "runtime_requires",
         "version" : "0.06"
      },
      {
         "is_prereq" : 1,
         "requires" : "Net::FastCGI",
         "type" : "runtime_requires",
         "version" : "0.12"
      },
      {
         "is_prereq" : 1,
         "requires" : "Twiggy",
         "type" : "runtime_requires",
         "version" : "0.1006"
      },
      {
         "is_build_prereq" : 1,
         "requires" : "ExtUtils::MakeMaker",
         "type" : "build_requires",
         "version" : "6.42"
      },
      {
         "requires" : "ExtUtils::MakeMaker",
         "type" : "configure_requires",
         "version" : "6.42"
      },
      {
         "is_prereq" : 1,
         "requires" : "Plack::Middleware::ConsoleLogger",
         "type" : "runtime_requires",
         "version" : "0.02"
      },
      {
         "is_prereq" : 1,
         "requires" : "Plack::Middleware::Debug",
         "type" : "runtime_requires",
         "version" : "0.09"
      },
      {
         "is_prereq" : 1,
         "requires" : "Plack",
         "type" : "runtime_requires",
         "version" : "0.9945"
      },
      {
         "is_prereq" : 1,
         "requires" : "Starman",
         "type" : "runtime_requires",
         "version" : "0.2006"
      },
      {
         "is_prereq" : 1,
         "requires" : "Flea",
         "type" : "runtime_requires",
         "version" : "0.02"
      },
      {
         "is_prereq" : 1,
         "requires" : "CGI::Emulate::PSGI",
         "type" : "runtime_requires",
         "version" : "0.10"
      },
      {
         "is_prereq" : 1,
         "requires" : "IO::Handle::Util",
         "type" : "runtime_requires",
         "version" : "0.01"
      },
      {
         "is_prereq" : 1,
         "requires" : "Plack::App::Proxy",
         "type" : "runtime_requires",
         "version" : "0.15"
      },
      {
         "is_prereq" : 1,
         "requires" : "Plack::Middleware::Auth::Digest",
         "type" : "runtime_requires",
         "version" : "0.03"
      },
      {
         "is_prereq" : 1,
         "requires" : "Plack::Middleware::Deflater",
         "type" : "runtime_requires",
         "version" : "0.03"
      },
      {
         "is_prereq" : 1,
         "requires" : "FCGI",
         "type" : "runtime_requires",
         "version" : "0.71"
      },
      {
         "is_prereq" : 1,
         "requires" : "Plack::Middleware::ReverseProxy",
         "type" : "runtime_requires",
         "version" : "0.06"
      },
      {
         "is_prereq" : 1,
         "requires" : "Plack::Middleware::Header",
         "type" : "runtime_requires",
         "version" : "0.03"
      },
      {
         "is_prereq" : 1,
         "requires" : "PSGI",
         "type" : "runtime_requires",
         "version" : "1.03"
      },
      {
         "is_prereq" : 1,
         "requires" : "Corona",
         "type" : "runtime_requires",
         "version" : "0.1004"
      },
      {
         "is_prereq" : 1,
         "requires" : "perl",
         "type" : "runtime_requires",
         "version" : "5.8.1"
      },
      {
         "is_prereq" : 1,
         "requires" : "CGI::PSGI",
         "type" : "runtime_requires",
         "version" : "0.11"
      },
      {
         "is_prereq" : 1,
         "requires" : "HTTP::Server::Simple::PSGI",
         "type" : "runtime_requires",
         "version" : "0.14"
      },
      {
         "is_prereq" : 1,
         "requires" : "Plack::Handler::AnyEvent::ReverseHTTP",
         "type" : "runtime_requires",
         "version" : "0.04"
      },
      {
         "is_prereq" : 1,
         "requires" : "CGI::Compile",
         "type" : "runtime_requires",
         "version" : "0.12"
      }
   ],
   "released_epoch" : 1328123967,
   "size_packed" : 28909,
   "size_unpacked" : 91919,
   "uses" : {
      "required_in_config" : {
         "FileHandle" : 1,
         "lib::Diamond" : 1
      },
      "used_in_code" : {
         "Exporter" : 1,
         "ExtUtils::MakeMaker" : 1,
         "strict" : 1
      },
      "used_in_config" : {
         "inc::Module::Install" : 1
      },
      "used_in_tests" : {
         "Test::More" : 1,
         "strict" : 1
      }
   },
   "valid_signature" : -1,
   "version" : null,
   "versions" : {
      "lib/Diamond.pm" : {
         "Diamond" : "0.25"
      }
   },
   "vname" : "Diamond"
}