Kwalitee Issues

has_license_in_source_file

Add =head1 LICENSE and the text of the license to the main module in your code.

has_proper_version

Remove all letters from the version number. If you want to mark a release as a developer release, use the scheme 'Module-1.00_01'

meta_yml_conforms_to_known_spec

Take a look at the META.yml Spec at http://module-build.sourceforge.net/META-spec-v1.4.html (for version 1.4) or http://search.cpan.org/perldoc?CPAN::Meta::Spec (for version 2), and change your META.yml accordingly.

Error: License '<undef>' is invalid (license) [Validation: 1.3];Missing mandatory field, 'license' (license) [Validation: 1.3]

no_pod_errors

Remove the POD errors. You can check for POD errors automatically by including Test::Pod to your test suite.

Error: Document-0.03-3/lib/Document/Directory.pm -- Around line 182: You forgot a '=back' before '=head1'Around line 217: =back doesn't take any parameters, but you said =back 4 Document-0.03-3/lib/Document/LogFile.pm -- Around line 151: =back doesn't take any parameters, but you said =back 4Around line 165: =back doesn't take any parameters, but you said =back 4 Document-0.03-3/lib/Document/Members.pm -- Around line 206: You forgot a '=back' before '=head1'Around line 208: '=item' outside of any '=over'Around line 239: =back doesn't take any parameters, but you said =back 4Around line 322: =back doesn't take any parameters, but you said =back 4 Document-0.03-3/lib/Document/NotesFile.pm -- Around line 155: =back doesn't take any parameters, but you said =back 4Around line 170: =back doesn't take any parameters, but you said =back 4 Document-0.03-3/lib/Document/PageId.pm -- Around line 245: =back doesn't take any parameters, but you said =back 4Around line 303: =back doesn't take any parameters, but you said =back 4Around line 325: =back doesn't take any parameters, but you said =back 4 Document-0.03-3/lib/Document/PageIterator.pm -- Around line 350: =back doesn't take any parameters, but you said =back 4 Document-0.03-3/lib/Document/Toc.pm -- Around line 687: =back doesn't take any parameters, but you said =back 4Around line 707: =back doesn't take any parameters, but you said =back 4 Document-0.03-3/lib/Document/TocFile.pm -- Around line 585: =back doesn't take any parameters, but you said =back 4Around line 671: =back doesn't take any parameters, but you said =back 4Around line 735: =back doesn't take any parameters, but you said =back 4 Document-0.03-3/lib/File/Spec/BaseParse.pm -- Around line 356: =back doesn't take any parameters, but you said =back 4Around line 461: =back doesn't take any parameters, but you said =back 4Around line 518: =back doesn't take any parameters, but you said =back 4 Document-0.03-3/lib/File/Spec/Dated.pm -- Around line 370: =back doesn't take any parameters, but you said =back 4Around line 387: =back doesn't take any parameters, but you said =back 4 Document-0.03-3/lib/File/Spec/DatedPage.pm -- Around line 348: =back doesn't take any parameters, but you said =back 4Around line 365: =back doesn't take any parameters, but you said =back 4 Document-0.03-3/lib/File/Spec/PublicationPage.pm -- Around line 566: =back doesn't take any parameters, but you said =back 4Around line 583: =back doesn't take any parameters, but you said =back 4

package_version_matches_dist_version

Fix the version(s).

prereq_matches_use

List all used modules in META.yml requires

Error:

  • File::Spec
  • File::Spec::Unix

has_known_license_in_source_file

Add =head1 LICENSE and/or the proper text of the well-known license to the main module in your code.

has_meta_json

Add a META.json to the distribution. Your buildtool should be able to autogenerate it.

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

meta_yml_has_license

Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.

use_warnings

Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: Document::Directory, Document::LogFile, Document::Members, Document::NotesFile, Document::PageId, Document::PageIterator, Document::Toc, Document::TocFile, File::Spec::BaseParse, File::Spec::Dated, File::Spec::DatedPage, File::Spec::PublicationPage

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

meta_yml_has_repository_resource

Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).

Modules

Name Abstract Version View
Document::Directory Manage an archival Document directory. metacpan
Document::LogFile LogFile file manager. metacpan
Document::Members Manage a Members file. metacpan
Document::NotesFile NotesFile file manager. metacpan
Document::PageId Page Identifier Class. metacpan
Document::PageIterator Page Iterator Class. metacpan
Document::Toc Manage a Table of contents file. metacpan
Document::TocFile Manage a Table of contents file. metacpan
File::Spec::BaseParse Parse a basic file name spec in a system independant way. metacpan
File::Spec::Dated Object to parse dated archive filenames. metacpan
File::Spec::DatedPage Parse a dated and page numbered file name in a system independant way. metacpan
File::Spec::PublicationPage Parse a dated and page numbered archive file name in a system independant way. metacpan

Other Files

Changes metacpan
MANIFEST metacpan
META.yml metacpan
Makefile.PL metacpan
README.perl metacpan