Kwalitee Issues

meta_yml_conforms_to_known_spec

Take a look at the META.yml Spec at http://module-build.sourceforge.net/META-spec-v1.4.html (for version 1.4) or http://search.cpan.org/perldoc?CPAN::Meta::Spec (for version 2), and change your META.yml accordingly.

Error: '<undef>' for 'File::PathConvert' is not a valid version. (requires -> File::PathConvert) [Validation: 1.0];'<undef>' for 'SGI::FAM' is not a valid version. (requires -> SGI::FAM) [Validation: 1.0];'<undef>' for 'Test::Helper' is not a valid version. (requires -> Test::Helper) [Validation: 1.0];'<undef>' for 'Tk' is not a valid version. (requires -> Tk) [Validation: 1.0];'<undef>' for 'Tk::WorldCanvas' is not a valid version. (requires -> Tk::WorldCanvas) [Validation: 1.0];'<undef>' for 'YAML' is not a valid version. (requires -> YAML) [Validation: 1.0]

no_pod_errors

Remove the POD errors. You can check for POD errors automatically by including Test::Pod to your test suite.

Error: Draft-0.06/lib/File/Atomism.pm -- Around line 130: '=item' outside of any '=over'Around line 133: You forgot a '=back' before '=head1'

prereq_matches_use

List all used modules in META.yml requires

Error:

  • Cwd
  • Exporter
  • File::Path
  • File::Spec
  • File::stat
  • Sys::Hostname
  • Time::HiRes
  • strict
  • vars
  • warnings

consistent_version

Split the distribution, or fix the version numbers to make them consistent (use the highest version number to avoid version downgrade).

Error: 0.06,0.1

has_meta_json

Add a META.json to the distribution. Your buildtool should be able to autogenerate it.

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

meta_yml_has_license

Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.

build_prereq_matches_use

List all modules used in the test suite in META.yml build_requires

Error:

  • Test
  • lib

has_separate_license_file

This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

meta_yml_has_repository_resource

Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).

Modules

Name Abstract Version View
Draft CAD directory-based file format demo 0.06 metacpan
Draft::Drawing CAD drawing type metacpan
Draft::Entity::Line CAD line drawing-object metacpan
Draft::Entity::Reference CAD reference drawing-object metacpan
Draft::Protozoa::Eml CAD drawing-object base class metacpan
Draft::Protozoa::Eml::Line::Draft1 CAD line drawing-object metacpan
Draft::Protozoa::Eml::Reference::Draft1 CAD reference drawing-object metacpan
Draft::Protozoa::Yml CAD drawing-object base class metacpan
Draft::Protozoa::Yml::Line::Draft1 metacpan
Draft::Protozoa::Yml::Reference::Draft1 metacpan
Draft::TkGui Display a Draft world metacpan
Draft::TkGui::Drawing Tk drawing type metacpan
Draft::TkGui::Entity::Line a line metacpan
Draft::TkGui::Entity::Reference reference metacpan
File::Atomism atomised directory file formats 0.1 metacpan
File::Atomism::Protozoa CAD drawing as an atomised directory metacpan
File::Atomism::utils Misc file handling stuff metacpan

Other Files

Changes metacpan
MANIFEST metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan