Kwalitee Issues

has_abstract_in_pod

Provide a short description in the NAME section of the pod (after the module name followed by a hyphen) at least for the main module of this distribution.

has_manifest

Add a MANIFEST to the distribution. Your buildtool should be able to autogenerate it (eg "make manifest" or "./Build manifest")

has_meta_yml

Add a META.yml to the distribution. Your buildtool should be able to autogenerate it.

has_proper_version

Remove all letters from the version number. If you want to mark a release as a developer release, use the scheme 'Module-1.00_01'

has_tests

Add tests!

manifest_matches_dist

Run a proper command ("make manifest" or "./Build manifest", maybe with a force option), or use a distribution builder to generate the MANIFEST. Or update MANIFEST manually.

Error: Cannot find MANIFEST in dist.

package_version_matches_dist_version

Fix the version(s).

prereq_matches_use

List all used modules in META.yml requires

Error:

  • Bio::Das::ProServer::SourceAdaptor
  • Bio::Das::ProServer::SourceAdaptor::Transport::generic
  • Compress::Zlib
  • DBI
  • Data::UUID
  • MQdb::DBObject
  • MQdb::Database
  • MQdb::MappedQuery

consistent_version

Split the distribution, or fix the version numbers to make them consistent (use the highest version number to avoid version downgrade).

Error: 0.953,1.007,1.010

has_meta_json

Add a META.json to the distribution. Your buildtool should be able to autogenerate it.

has_tests_in_t_dir

Add tests or move tests.pl to the t/ directory!

meta_yml_has_license

Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.

no_dot_underscore_files

If you use Mac OS X, set COPYFILE_DISABLE (for OS 10.5 and better) or COPY_EXTENDED_ATTRIBUTES_DISABLE (for OS 10.4) environmental variable to true to exclude dot underscore files from a distribution.

Error:

  • www/edgeexpress/jscript/._prototype-1.5.1.1.js
  • www/edgeexpress/jscript/._prototype-1.5.1.2.js
  • www/edgeexpress/jscript/._prototype-1.6.0.2.js
  • www/edgeexpress/jscript/._prototype-1.6.0.3.js

use_warnings

Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: EEDB, EEDB::Assembly, EEDB::Chrom, EEDB::ChromChunk, EEDB::Edge, EEDB::EdgeSet, EEDB::EdgeSource, EEDB::Experiment, EEDB::Expression, EEDB::Feature, EEDB::FeatureSet, EEDB::FeatureSource, EEDB::Metadata, EEDB::MetadataSet, EEDB::Peer, EEDB::Symbol, EEDB::Tools::BEDLoader, EEDB::Tools::MultiLoader, EEDB::Tools::OverlapCompare, EEDB::Tools::PSLLoader

has_separate_license_file

This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.

Modules

Name Abstract Version View
Bio::Das::ProServer::SourceAdaptor::Transport::edgeexpress 1.007 metacpan
Bio::Das::ProServer::SourceAdaptor::edgeexpress 1.010 metacpan
EEDB 0.953 metacpan
EEDB::Assembly 0.953 metacpan
EEDB::Chrom 0.953 metacpan
EEDB::ChromChunk 0.953 metacpan
EEDB::Edge 0.953 metacpan
EEDB::EdgeSet 0.953 metacpan
EEDB::EdgeSource 0.953 metacpan
EEDB::Experiment 0.953 metacpan
EEDB::Expression 0.953 metacpan
EEDB::Feature 0.953 metacpan
EEDB::FeatureSet 0.953 metacpan
EEDB::FeatureSource 0.953 metacpan
EEDB::Metadata 0.953 metacpan
EEDB::MetadataSet 0.953 metacpan
EEDB::Peer 0.953 metacpan
EEDB::Symbol 0.953 metacpan
EEDB::Tools::BEDLoader 0.953 metacpan
EEDB::Tools::MultiLoader 0.953 metacpan
EEDB::Tools::OverlapCompare 0.953 metacpan
EEDB::Tools::PSLLoader 0.953 metacpan

Other Files

Changes metacpan
Makefile.PL metacpan
README metacpan