Kwalitee Issues

distname_matches_name_in_meta

Use a proper tool to make a distribution. You might also need to fix META files if you keep them in the repository.

Error: FLAT

extracts_nicely

Pack the distribution with a proper command such as "make dist" and "./Build dist", or use a distribution builder such as Dist::Zilla, Dist::Milla, Minilla.

has_proper_version

Remove all letters from the version number. If you want to mark a release as a developer release, use the scheme 'Module-1.00_01'

manifest_matches_dist

Run a proper command ("make manifest" or "./Build manifest", maybe with a force option), or use a distribution builder to generate the MANIFEST. Or update MANIFEST manually.

Error:

  • MANIFEST (41) does not match dist (52):
  • Missing in MANIFEST: Makefile.old, lib/CVS/Entries, lib/CVS/Repository, lib/CVS/Root, lib/FLAT.pm, samples/CVS/Entries, samples/CVS/Repository, samples/CVS/Root, t/CVS/Entries, t/CVS/Repository, t/CVS/Root, t/input/CVS/Entries, t/input/CVS/Repository, t/input/CVS/Root
  • Duplicates in MANIFEST: t/FLAT-FA-PRE.t, t/FLAT-FA-RE.t, t/FLAT.t

meta_yml_conforms_to_known_spec

Take a look at the META.yml Spec at http://module-build.sourceforge.net/META-spec-v1.4.html (for version 1.4) or http://search.cpan.org/perldoc?CPAN::Meta::Spec (for version 2), and change your META.yml accordingly.

Error: Expected a map structure from string or file. (requires) [Validation: 1.0]

package_version_matches_dist_version

Fix the version(s).

prereq_matches_use

List all used modules in META.yml requires

Error:

  • Carp
  • Data::Dumper
  • strict

use_strict

Add 'use strict' (or its equivalents) to all modules, or convince us that your favorite module is well-known enough and people can easily see the modules are strictly written.

Error: FLAT

has_meta_json

Add a META.json to the distribution. Your buildtool should be able to autogenerate it.

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

meta_yml_has_license

Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.

use_warnings

Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: FLAT, FLAT::Legacy::FA, FLAT::Legacy::FA::DFA, FLAT::Legacy::FA::NFA, FLAT::Legacy::FA::PFA, FLAT::Legacy::FA::PRE, FLAT::Legacy::FA::RE

build_prereq_matches_use

List all modules used in the test suite in META.yml build_requires

Error:

  • Test::More
  • lib

has_separate_license_file

This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

meta_yml_has_repository_resource

Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).

Modules

Name Abstract Version View
FLAT::Legacy::FA metacpan
FLAT::Legacy::FA::DFA metacpan
FLAT::Legacy::FA::NFA metacpan
FLAT::Legacy::FA::PFA metacpan
FLAT::Legacy::FA::PRE metacpan
FLAT::Legacy::FA::RE metacpan

Other Files

Changes metacpan
MANIFEST metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan