Under maintenance.

Most probably CPANTS databases are being regenerated from scratch due to major changes in Kwalitee metrics or updates of relevant modules/perl. Usually this maintenance takes about a day or two, and some of the information may be old or missing tentatively. Sorry for the inconvenience.

File-DataClass

Prerequisites

File-DataClass declares the following 35 modules as prerequisites.

Listed PrerequisitesRequired VersionLatest DistKwalitee
Lingua::EN::NameParse1.28Lingua-EN-NameParse-1.33131.43
Carp0Carp-1.38125.71
namespace::clean0.22namespace-clean-0.26128.57
Sub::Exporter::Progressive0.001006Sub-Exporter-Progressive-0.001011131.43
Scalar::Util1.18Scalar-List-Utils-1.45134.29
XML::Simple2.14XML-Simple-2.22134.29
IO::Dir1.05IO-1.25125.71
Hash::Merge0.08Hash-Merge-0.200134.29
parent0.224parent-0.234125.71
overload1.04perl0.00
Try::Tiny0.06Try-Tiny-0.24134.29
Encode2.12Encode-2.83125.71
Cache::FastMmap1.36Cache-FastMmap-1.43128.57
MooseX::ClassAttribute0.26MooseX-ClassAttribute-0.27131.43
Sub::Exporter0.982Sub-Exporter-0.987134.29
XML::Bare0.3XML-Bare-0.53125.71
Exception::Class1.23Exception-Class-1.40134.29
perl5.01perl0.00
IO::File1.13IO-1.25125.71
File::Temp0.20.00
Class::Null1.09Class-Null-2.110730131.43
MealMaster0.28MealMaster-0.28128.57
namespace::autoclean0.13namespace-autoclean-0.28134.29
File::Path2.08File-Path-2.12128.57
CHI0.33CHI-0.60125.71
IPC::Cmd0.68IPC-Cmd-0.94128.57
version0.74version-0.9916128.57
Date::Format2.22TimeDate-2.30120.00
JSON2.16JSON-2.90128.57
Text::Wrap2005.082401Text-Tabs+Wrap-2013.0523120.00
MooseX::Types0.25MooseX-Types-0.46134.29
Template::Stash2.9Template-Toolkit-2.26125.71
Moose2.0402Moose-2.1605134.29
XML::DTD0.09XML-DTD-0.11120.00
Template2.18Template-Toolkit-2.26125.71

File-DataClass declares the following 4 modules as build prerequisites.

Listed Build PrerequisitesRequired VersionLatest DistKwalitee
Test::More0.74Test-Simple-1.001014122.86
utf81.06perl0.00
Exception::Class1.23Exception-Class-1.40134.29
Text::Diff1.37Text-Diff-1.44134.29

File-DataClass declares the following 2 modules as optional prerequisites.

Listed Optional PrerequisitesRequired VersionLatest DistKwalitee
Module::Build0.32Module-Build-0.4216134.285714285714
version0.74version-0.9916128.571428571429