Under maintenance.

Most probably CPANTS databases are being regenerated from scratch due to major changes in Kwalitee metrics or updates of relevant modules/perl. Usually this maintenance takes about a day or two, and some of the information may be old or missing tentatively. Sorry for the inconvenience.

Kwalitee Issues

has_readme

Add a README to the distribution. It should contain a quick description of your module and how to install it.

no_broken_module_install

Upgrade the bundled version of Module::Install to the most current release. Alternatively, you can switch to another build system / installer that does not suffer from this problem. (ExtUtils::MakeMaker, Module::Build both of which have their own set of problems.)

no_pod_errors

Remove the POD errors. You can check for POD errors automatically by including Test::Pod to your test suite.

Error: Form-Sensible-0.20023/lib/Form/Sensible/Field/DateTime.pm -- Around line 225: You forgot a '=back' before '=head1' Form-Sensible-0.20023/lib/Form/Sensible/Field.pm -- Around line 459: Unterminated C<...> sequenceAround line 501: =back without =over Form-Sensible-0.20023/lib/Form/Sensible/Validator/Result.pm -- Around line 232: '=item' outside of any '=over' Form-Sensible-0.20023/lib/Form/Sensible.pm -- Around line 156: =over should be: '=over' or '=over positive_number'

consistent_version

Split the distribution, or fix the version numbers to make them consistent (use the highest version number to avoid version downgrade).

Error: 0.01,0.20023

has_meta_json

Add a META.json to the distribution. Your buildtool should be able to autogenerate it.

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

has_separate_license_file

This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

meta_yml_has_repository_resource

Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).

Modules

Name Abstract Version View
Form::Sensible A sensible way to handle form based user interface 0.20023 metacpan
Form::Sensible::DelegateConnection Represents a connection between one object and another metacpan
Form::Sensible::Field Field base class for Form::Sensible metacpan
Form::Sensible::Field::DateTime A DateTime field type. metacpan
Form::Sensible::Field::FileSelector Field used for file selection metacpan
Form::Sensible::Field::LongText Field for representing large amounts of character-string data. metacpan
Form::Sensible::Field::Number A Numeric field type. metacpan
Form::Sensible::Field::Select A multiple-choice option field metacpan
Form::Sensible::Field::SubForm encapsulate an entire form within another. metacpan
Form::Sensible::Field::Text Field for representing character-strings metacpan
Form::Sensible::Field::Toggle An on/off field metacpan
Form::Sensible::Field::Trigger A Trigger for user activity metacpan
Form::Sensible::Form Form::Sensible's Form class metacpan
Form::Sensible::Reflector A base class for writing Form::Sensible reflectors. 0.01 metacpan
Form::Sensible::Renderer Base class for Renderers. metacpan
Form::Sensible::Renderer::HTML an HTML based Form renderer metacpan
Form::Sensible::Renderer::HTML::RenderedForm A rendered form handle for HTML metacpan
Form::Sensible::Validator Default Validator for Form::Sensible forms metacpan
Form::Sensible::Validator::Result Validation results for a given form. metacpan

Other Files

Changes metacpan
MANIFEST metacpan
META.yml metacpan
Makefile.PL metacpan