Kwalitee Issues

manifest_matches_dist

Run a proper command ("make manifest" or "./Build manifest", maybe with a force option), or use a distribution builder to generate the MANIFEST. Or update MANIFEST manually.

Error:

  • MANIFEST (15) does not match dist (28):
  • Missing in MANIFEST: ._Changes, ._Makefile.PL, ._README, lib/FrameNet/WordNet/._Detour.pm, lib/FrameNet/WordNet/Detour/._Data.pm, lib/FrameNet/WordNet/Detour/._Frame.pm, script/._detour, t/._00-load.t, t/._01-module.t, t/._02-detour.t, t/._03-cmd.t, t/._pod-coverage.t, t/._pod.t

meta_yml_conforms_to_known_spec

Take a look at the META.yml Spec at http://module-build.sourceforge.net/META-spec-v1.4.html (for version 1.4) or http://search.cpan.org/perldoc?CPAN::Meta::Spec (for version 2), and change your META.yml accordingly.

Error: License '<undef>' is invalid (license) [Validation: 1.3];Missing mandatory field, 'license' (license) [Validation: 1.3]

use_strict

Add 'use strict' (or its equivalents) to all modules, or convince us that your favorite module is well-known enough and people can easily see the modules are strictly written.

Error: FrameNet::WordNet::._Detour, FrameNet::WordNet::Detour::._Data, FrameNet::WordNet::Detour::._Frame

consistent_version

Split the distribution, or fix the version numbers to make them consistent (use the highest version number to avoid version downgrade).

Error: 0.99,1.1

has_meta_json

Add a META.json to the distribution. Your buildtool should be able to autogenerate it.

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

meta_yml_has_license

Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.

no_dot_underscore_files

If you use Mac OS X, set COPYFILE_DISABLE (for OS 10.5 and better) or COPY_EXTENDED_ATTRIBUTES_DISABLE (for OS 10.4) environmental variable to true to exclude dot underscore files from a distribution.

Error:

  • ._Changes
  • ._Makefile.PL
  • ._README
  • lib/FrameNet/WordNet/._Detour.pm
  • lib/FrameNet/WordNet/Detour/._Data.pm
  • lib/FrameNet/WordNet/Detour/._Frame.pm
  • script/._detour
  • t/._00-load.t
  • t/._01-module.t
  • t/._02-detour.t
  • t/._03-cmd.t
  • t/._pod-coverage.t
  • t/._pod.t

use_warnings

Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: FrameNet::WordNet::._Detour, FrameNet::WordNet::Detour::._Data, FrameNet::WordNet::Detour::._Frame

has_separate_license_file

This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

meta_yml_has_repository_resource

Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).

Modules

Name Abstract Version View
FrameNet::WordNet::Detour a WordNet to FrameNet Detour. 1.1 metacpan
FrameNet::WordNet::Detour::Data A class representing the results of the Detour. 0.99 metacpan
FrameNet::WordNet::Detour::Frame A class representing one single frame. 0.99 metacpan

Other Files

Changes metacpan
MANIFEST metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan