Kwalitee Issues


Add a Makefile.PL (for ExtUtils::MakeMaker/Module::Install) or a Build.PL (for Module::Build and its friends), or use a distribution builder such as Dist::Zilla, Dist::Milla, Minilla.


Take a look at the META.yml Spec at (for version 1.4) or (for version 2), and change your META.yml accordingly.

Error: Expected a map structure from string or file. (requires) [Validation: 1.0]


Remove the offending files/directories!

Error: Makefile


Add 'use strict' (or its equivalents) to all modules, or convince us that your favorite module is well-known enough and people can easily see the modules are strictly written.

Error: Fry::Config::Default, Fry::Config::YAML, Fry::ReadLine::Default


Add a META.json to the distribution. Your buildtool should be able to autogenerate it.


If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.


Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.


Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: Fry::Base, Fry::Cmd, Fry::Config::Default, Fry::Config::YAML, Fry::Dump::DataDumper, Fry::Dump::Default, Fry::Dump::TreeDumper, Fry::Error, Fry::Lib, Fry::Lib::DBI, Fry::Lib::Default, Fry::Lib::Inspector, Fry::List, Fry::Obj, Fry::Opt, Fry::ReadLine::Default, Fry::ReadLine::Gnu, Fry::ShellI, Fry::Sub, Fry::Type, Fry::Var, Fry::View::CLI


This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.


Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.


Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).


Name Abstract Version View
Fry::Base Base class providing minimal set of handy methods. Some used to communicate between shell components and used to communicate between shell components. metacpan
Fry::Cmd Class for shell commands. metacpan
Fry::Config::Default Default Config plugin for Fry::Shell. metacpan
Fry::Config::YAML Fry::Shell Config plugin which uses YAML. metacpan
Fry::Dump::DataDumper Dump plugin for Fry::Shell which uses Data::Dumper. metacpan
Fry::Dump::Default Default Dump plugin for Fry::Shell metacpan
Fry::Dump::TreeDumper Dump plugin for Fry::Shell which uses Data::TreeDumper. metacpan
Fry::Error Redefines warn and die to trigger actions by error levels and tags. metacpan
Fry::Lib Class for shell libraries. metacpan
Fry::Lib::DBI Autoloaded library for DBI's object methods. metacpan
Fry::Lib::Default Default library loaded by Fry::Shell metacpan
Fry::Lib::Inspector Autoloaded library for Class::Inspector's class methods. metacpan
Fry::List Base class serving as a container for its subclass's objects. metacpan
Fry::Obj metacpan
Fry::Opt Class for shell options. metacpan
Fry::ReadLine::Default Default ReadLine plugin for Fry::Shell. metacpan
Fry::ReadLine::Gnu ReadLine plugin for Fry::Shell which uses Term::ReadLine::Gnu. metacpan
Fry::Shell Flexible shell framework which encourages using loadable libraries of functions. 0.15 metacpan
Fry::ShellI Extended Fry::Shell interface to be used by libraries and plugins as needed. metacpan
Fry::Sub Class for shell subroutines metacpan
Fry::Type metacpan
Fry::Var Class for shell variables. metacpan
Fry::View::CLI Default View plugin for Fry::Shell displaying to the commandline. metacpan


Name File View
Fry::Sub::_Methods lib/Fry/ metacpan

Other Files

Changes metacpan
MANIFEST metacpan
META.yml metacpan
README metacpan