Kwalitee Issues

no_pod_errors

Remove the POD errors. You can check for POD errors automatically by including Test::Pod to your test suite.

Error: FuzzyRecongiser-0.01/lib/EBI/FGPT/FuzzyRecogniser.pm -- Around line 140: '=item' outside of any '=over' =over without closing =back

prereq_matches_use

List all used modules in META.yml requires

Error:

  • Bio::Phenotype::OMIM::OMIMparser
  • GO::Parser
  • MeSH::Parser::ASCII
  • OWL::Simple::Parser

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

build_prereq_matches_use

List all modules used in the test suite in META.yml build_requires

Error:

  • Data::Dumper
  • lib

has_separate_license_file

This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.

meta_yml_has_repository_resource

Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).

Modules

Name Abstract Version View
EBI::FGPT::FuzzyRecogniser 0.01 metacpan
EBI::FGPT::FuzzyRecogniser::OntologyTerm 0.01 metacpan
EBI::FGPT::FuzzyRecogniser::OntologyTerm::Annotation 0.01 metacpan
EBI::FGPT::FuzzyRecogniser::OntologyTerm::Label The great new EBI::FGPT::FuzzyRecogniser::OntologyTerm::Label! 0 metacpan
EBI::FGPT::FuzzyRecogniser::OntologyTerm::Synonym The great new EBI::FGPT::FuzzyRecogniser::OntologyTerm::Synonym! 0.01 metacpan

Other Files

Build.PL metacpan
Changes metacpan
MANIFEST metacpan
META.json metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan