The site is under maintenance.

Most probably the CPANTS databases are being regenerated from scratch behind the scenes due to the major change in Kwalitee metrics or the update of relevant modules/perl. Usually this maintenance takes about a day or two, and some of the information may be old or missing tentatively. Sorry for the inconvenience.

GD-Graph-splined

Metadata

Analyzed metadata and errors of GD-Graph-splined.

{
   "abstracts" : {
      "GD::Graph::splined" : "Smooth line graphs with GD::Graph"
   },
   "author" : "LGODDARD",
   "buildfile_executable" : 1,
   "dir_lib" : "lib",
   "dir_t" : "t",
   "dirs_array" : [
      "lib",
      "lib/GD",
      "lib/GD/Graph",
      "t"
   ],
   "dist" : "GD-Graph-splined",
   "dynamic_config" : 0,
   "easily_repackageable_by_fedora" : "fits_fedora_license",
   "error" : {},
   "extension" : "tar.gz",
   "extractable" : 1,
   "extracts_nicely" : 1,
   "file__build" : 0,
   "file_blib" : 0,
   "file_build" : 0,
   "file_changelog" : "Changes",
   "file_makefile" : 0,
   "file_makefile_pl" : "Makefile.PL",
   "file_manifest" : "MANIFEST",
   "file_meta_yml" : "META.yml",
   "file_pm_to_blib" : 0,
   "file_readme" : "README",
   "files_array" : [
      "README",
      "Changes",
      "Makefile.PL",
      "META.yml",
      "MANIFEST",
      "lib/GD/Graph/splined.pm",
      "t/GD-Graph-splined.t"
   ],
   "files_hash" : {
      "Changes" : {
         "mtime" : 1154522086,
         "size" : 177
      },
      "MANIFEST" : {
         "mtime" : 1154525652,
         "size" : 166
      },
      "META.yml" : {
         "mtime" : 1154525652,
         "size" : 435
      },
      "Makefile.PL" : {
         "mtime" : 1154525254,
         "size" : 452,
         "used" : [
            "ExtUtils::MakeMaker"
         ]
      },
      "README" : {
         "mtime" : 1154522651,
         "size" : 804
      },
      "lib/GD/Graph/splined.pm" : {
         "module" : "GD::Graph::splined",
         "mtime" : 1154525637,
         "size" : 4002,
         "used" : [
            "GD::Graph::area",
            "GD::Graph::axestype",
            "GD::Polyline",
            "strict",
            "warnings"
         ]
      },
      "t/GD-Graph-splined.t" : {
         "mtime" : 1154525559,
         "size" : 457,
         "used" : [
            "Test::More",
            "strict"
         ]
      }
   },
   "got_prereq_from" : "META.yml",
   "kwalitee" : {
      "buildtool_not_executable" : 0,
      "consistent_version" : 1,
      "easily_repackageable_by_debian" : 1,
      "easily_repackageable_by_fedora" : 0,
      "extractable" : 1,
      "extracts_nicely" : 1,
      "fits_fedora_license" : 0,
      "has_abstract_in_pod" : 1,
      "has_buildtool" : 1,
      "has_changelog" : 1,
      "has_human_readable_license" : 1,
      "has_known_license_in_source_file" : 0,
      "has_license_in_source_file" : 1,
      "has_manifest" : 1,
      "has_meta_yml" : 1,
      "has_proper_version" : 1,
      "has_readme" : 1,
      "has_separate_license_file" : 0,
      "has_tests" : 1,
      "has_tests_in_t_dir" : 1,
      "has_version" : 1,
      "kwalitee" : "87.80",
      "manifest_matches_dist" : 1,
      "metayml_conforms_to_known_spec" : 1,
      "metayml_declares_perl_version" : 0,
      "metayml_has_license" : 0,
      "metayml_has_provides" : 0,
      "metayml_is_parsable" : 1,
      "no_abstract_stub_in_pod" : 1,
      "no_broken_auto_install" : 1,
      "no_broken_module_install" : 1,
      "no_dot_dirs" : 1,
      "no_dot_underscore_files" : 1,
      "no_generated_files" : 1,
      "no_invalid_versions" : 1,
      "no_local_dirs" : 1,
      "no_mymeta_files" : 1,
      "no_pax_headers" : 1,
      "no_pod_errors" : 1,
      "no_stdin_for_prompting" : 1,
      "no_symlinks" : 1,
      "package_version_matches_dist_version" : 0,
      "portable_filenames" : 1,
      "proper_libs" : 1,
      "use_strict" : 1,
      "use_warnings" : 1,
      "valid_signature" : 1
   },
   "latest_mtime" : 1154525652,
   "license" : "defined in POD (lib/GD/Graph/splined.pm)",
   "license_in_pod" : 1,
   "manifest_matches_dist" : 1,
   "meta_yml" : {
      "distribution_type" : "module",
      "generated_by" : "ExtUtils::MakeMaker version 6.30",
      "installdirs" : "site",
      "meta-spec" : {},
      "name" : "GD-Graph-splined",
      "requires" : {
         "GD" : "2.18",
         "GD::Graph" : "1.35",
         "GD::Polyline" : "0.2"
      },
      "version" : "1.16",
      "version_from" : "lib/GD/Graph/splined.pm"
   },
   "metayml_is_parsable" : 1,
   "modules" : [
      {
         "file" : "lib/GD/Graph/splined.pm",
         "in_basedir" : 0,
         "in_lib" : 1,
         "module" : "GD::Graph::splined"
      }
   ],
   "no_pax_headers" : 1,
   "package" : "GD-Graph-splined-1.16.tar.gz",
   "prereq" : [
      {
         "is_prereq" : 1,
         "requires" : "GD::Graph",
         "type" : "runtime_requires",
         "version" : "1.35"
      },
      {
         "is_prereq" : 1,
         "requires" : "GD::Polyline",
         "type" : "runtime_requires",
         "version" : "0.2"
      },
      {
         "is_prereq" : 1,
         "requires" : "GD",
         "type" : "runtime_requires",
         "version" : "2.18"
      }
   ],
   "released_epoch" : 1154525725,
   "size_packed" : 3045,
   "size_unpacked" : 6493,
   "unknown_license_texts" : {
      "lib/GD/Graph/splined.pm" : "=head1 AUTHOR AND COPYRIGHT\n\nLee Goddard added to Martien Verbruggen's L<GD::Graph::area|GD::Graph::area> module\nthe ability to use Daniel J Harasty's L<GD::Polyline> module.\n\nThus, Copyright (c) 1995-2000 Martien Verbruggen\nwith parts copyright (c) 2006 Lee Goddard (lgoddard -at- cpan -dot- org).\n\nThis software is made available under the same terms as L<GD::Graph|GD::Graph>.\n"
   },
   "uses" : {
      "used_in_code" : {
         "GD::Graph::area" : 1,
         "GD::Graph::axestype" : 1,
         "GD::Polyline" : 1,
         "strict" : 1,
         "warnings" : 1
      },
      "used_in_config" : {
         "ExtUtils::MakeMaker" : 1
      },
      "used_in_tests" : {
         "Test::More" : 1,
         "strict" : 1
      }
   },
   "valid_signature" : -1,
   "version" : "1.16",
   "versions" : {
      "lib/GD/Graph/splined.pm" : {
         "GD::Graph::splined" : "0.01"
      }
   },
   "vname" : "GD-Graph-splined-1.16"
}