Geo-Coder-Mappy

Metadata

Analyzed metadata and errors of Geo-Coder-Mappy.

{
   "abstracts" : {
      "Geo::Coder::Mappy" : "Geocode addresses with the Mappy AJAX API"
   },
   "author" : "GRAY",
   "buildfile_executable" : 0,
   "dir_lib" : "lib",
   "dir_t" : "t",
   "dir_xt" : "xt",
   "dirs_array" : [
      "lib",
      "lib/Geo",
      "lib/Geo/Coder",
      "t",
      "ex",
      "xt"
   ],
   "dist" : "Geo-Coder-Mappy",
   "dynamic_config" : 0,
   "error" : {},
   "extension" : "tar.gz",
   "extractable" : 1,
   "extracts_nicely" : 1,
   "file__build" : 0,
   "file_blib" : 0,
   "file_build" : 0,
   "file_changelog" : "Changes",
   "file_makefile" : 0,
   "file_makefile_pl" : "Makefile.PL",
   "file_manifest" : "MANIFEST",
   "file_meta_yml" : "META.yml",
   "file_pm_to_blib" : 0,
   "file_readme" : "README",
   "files_array" : [
      "README",
      "Changes",
      "Makefile.PL",
      "META.yml",
      "MANIFEST",
      "lib/Geo/Coder/Mappy.pm",
      "ex/custom-useragent.pl",
      "xt/perlcritic.t",
      "xt/kwalitee.t",
      "xt/live.t",
      "xt/vars.t",
      "xt/pod_coverage.t",
      "xt/perlcriticrc",
      "xt/pod.t",
      "xt/portability_filenames.t"
   ],
   "files_hash" : {
      "Changes" : {
         "mtime" : 1301443297,
         "size" : 189
      },
      "MANIFEST" : {
         "mtime" : 1301443366,
         "size" : 328
      },
      "META.yml" : {
         "mtime" : 1301443365,
         "size" : 760
      },
      "Makefile.PL" : {
         "mtime" : 1301443090,
         "noed" : [
            "warnings"
         ],
         "size" : 1462,
         "used" : [
            "ExtUtils::MakeMaker",
            "strict",
            "warnings"
         ]
      },
      "README" : {
         "mtime" : 1300775850,
         "size" : 552
      },
      "ex/custom-useragent.pl" : {
         "mtime" : 1300832754,
         "size" : 620
      },
      "lib/Geo/Coder/Mappy.pm" : {
         "license" : "Perl_5",
         "module" : "Geo::Coder::Mappy",
         "mtime" : 1301443314,
         "size" : 7376,
         "used" : [
            "Carp",
            "Encode",
            "JSON",
            "LWP::UserAgent",
            "URI",
            "strict",
            "warnings"
         ]
      },
      "t/00_compile.t" : {
         "mtime" : 1300826638,
         "no_index" : 1,
         "size" : 95,
         "used" : [
            "Test::More",
            "strict",
            "warnings"
         ]
      },
      "t/01_new.t" : {
         "mtime" : 1300826859,
         "no_index" : 1,
         "size" : 431,
         "used" : [
            "Geo::Coder::Mappy",
            "Test::More",
            "strict",
            "warnings"
         ]
      },
      "xt/kwalitee.t" : {
         "mtime" : 1300675459,
         "size" : 178
      },
      "xt/live.t" : {
         "mtime" : 1300834360,
         "size" : 2335
      },
      "xt/perlcritic.t" : {
         "mtime" : 1300675459,
         "size" : 250
      },
      "xt/perlcriticrc" : {
         "mtime" : 1300675459,
         "size" : 429
      },
      "xt/pod.t" : {
         "mtime" : 1300675459,
         "size" : 168
      },
      "xt/pod_coverage.t" : {
         "mtime" : 1300675459,
         "size" : 184
      },
      "xt/portability_filenames.t" : {
         "mtime" : 1300675459,
         "size" : 174
      },
      "xt/vars.t" : {
         "mtime" : 1300675459,
         "size" : 148
      }
   },
   "got_prereq_from" : "META.yml",
   "kwalitee" : {
      "buildtool_not_executable" : 1,
      "consistent_version" : 1,
      "easily_repackageable_by_debian" : 1,
      "easily_repackageable_by_fedora" : 1,
      "extractable" : 1,
      "extracts_nicely" : 1,
      "fits_fedora_license" : 1,
      "has_abstract_in_pod" : 1,
      "has_buildtool" : 1,
      "has_changelog" : 1,
      "has_human_readable_license" : 1,
      "has_known_license_in_source_file" : 1,
      "has_license_in_source_file" : 1,
      "has_manifest" : 1,
      "has_meta_yml" : 1,
      "has_proper_version" : 1,
      "has_readme" : 1,
      "has_separate_license_file" : 0,
      "has_tests" : 1,
      "has_tests_in_t_dir" : 1,
      "has_version" : 1,
      "kwalitee" : "97.56",
      "manifest_matches_dist" : 1,
      "metayml_conforms_to_known_spec" : 1,
      "metayml_declares_perl_version" : 0,
      "metayml_has_license" : 1,
      "metayml_has_provides" : 0,
      "metayml_is_parsable" : 1,
      "no_abstract_stub_in_pod" : 1,
      "no_broken_auto_install" : 1,
      "no_broken_module_install" : 1,
      "no_dot_dirs" : 1,
      "no_dot_underscore_files" : 1,
      "no_generated_files" : 1,
      "no_invalid_versions" : 1,
      "no_local_dirs" : 1,
      "no_mymeta_files" : 1,
      "no_pax_headers" : 1,
      "no_pod_errors" : 1,
      "no_stdin_for_prompting" : 1,
      "no_symlinks" : 1,
      "package_version_matches_dist_version" : 1,
      "portable_filenames" : 1,
      "proper_libs" : 1,
      "use_strict" : 1,
      "use_warnings" : 1,
      "valid_signature" : 1
   },
   "latest_mtime" : 1301443366,
   "license" : "perl defined in META.yml",
   "license_file" : "lib/Geo/Coder/Mappy.pm",
   "license_from_yaml" : "perl",
   "license_in_pod" : 1,
   "license_type" : "Perl_5",
   "licenses" : {
      "Perl_5" : [
         "lib/Geo/Coder/Mappy.pm"
      ]
   },
   "manifest_matches_dist" : 1,
   "meta_yml" : {
      "abstract" : "Geocode addresses with the Mappy AJAX API",
      "author" : [
         "gray <gray@cpan.org>"
      ],
      "build_requires" : {
         "Test::More" : "0.82"
      },
      "configure_requires" : {
         "ExtUtils::MakeMaker" : "0"
      },
      "distribution_type" : "module",
      "generated_by" : "ExtUtils::MakeMaker version 6.56",
      "license" : "perl",
      "meta-spec" : {
         "url" : "http://module-build.sourceforge.net/META-spec-v1.4.html",
         "version" : "1.4"
      },
      "name" : "Geo-Coder-Mappy",
      "no_index" : {
         "directory" : [
            "t",
            "inc"
         ]
      },
      "recommends" : {
         "JSON::XS" : "2",
         "LWP::Protocol::https" : "6.02"
      },
      "requires" : {
         "Encode" : "0",
         "JSON" : "2",
         "LWP::UserAgent" : "6.02",
         "URI" : "1.36"
      },
      "resources" : {
         "repository" : "http://github.com/gray/geo-coder-mappy"
      },
      "version" : "0.02"
   },
   "metayml_is_parsable" : 1,
   "modules" : [
      {
         "file" : "lib/Geo/Coder/Mappy.pm",
         "in_basedir" : 0,
         "in_lib" : 1,
         "module" : "Geo::Coder::Mappy"
      }
   ],
   "no_index" : "^inc/;^t/",
   "no_pax_headers" : 1,
   "package" : "Geo-Coder-Mappy-0.02.tar.gz",
   "prereq" : [
      {
         "is_prereq" : 1,
         "requires" : "Encode",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "URI",
         "type" : "runtime_requires",
         "version" : "1.36"
      },
      {
         "is_optional_prereq" : 1,
         "requires" : "LWP::Protocol::https",
         "type" : "runtime_recommends",
         "version" : "6.02"
      },
      {
         "is_prereq" : 1,
         "requires" : "LWP::UserAgent",
         "type" : "runtime_requires",
         "version" : "6.02"
      },
      {
         "is_optional_prereq" : 1,
         "requires" : "JSON::XS",
         "type" : "runtime_recommends",
         "version" : "2"
      },
      {
         "requires" : "ExtUtils::MakeMaker",
         "type" : "configure_requires",
         "version" : "0"
      },
      {
         "is_build_prereq" : 1,
         "requires" : "Test::More",
         "type" : "build_requires",
         "version" : "0.82"
      },
      {
         "is_prereq" : 1,
         "requires" : "JSON",
         "type" : "runtime_requires",
         "version" : "2"
      }
   ],
   "released_epoch" : 1301443445,
   "size_packed" : 6074,
   "size_unpacked" : 15679,
   "uses" : {
      "noed_in_config" : {
         "warnings" : 1
      },
      "used_in_code" : {
         "Carp" : 1,
         "Encode" : 1,
         "JSON" : 1,
         "LWP::UserAgent" : 1,
         "URI" : 1,
         "strict" : 1,
         "warnings" : 1
      },
      "used_in_config" : {
         "ExtUtils::MakeMaker" : 1,
         "strict" : 1,
         "warnings" : 1
      },
      "used_in_tests" : {
         "Test::More" : 2,
         "strict" : 2,
         "warnings" : 2
      }
   },
   "valid_signature" : -1,
   "version" : "0.02",
   "versions" : {
      "lib/Geo/Coder/Mappy.pm" : {
         "Geo::Coder::Mappy" : "0.02"
      }
   },
   "vname" : "Geo-Coder-Mappy-0.02"
}