Kwalitee Issues

manifest_matches_dist

Run a proper command ("make manifest" or "./Build manifest", maybe with a force option), or use a distribution builder to generate the MANIFEST. Or update MANIFEST manually.

Error:

  • MANIFEST (52) does not match dist (51):
  • Missing in Dist: lib/Geo/GDAL/Const.dox

no_generated_files

Remove the offending files/directories!

Error: Makefile

prereq_matches_use

List all used modules in META.yml requires

Error:

  • DynaLoader
  • Exporter

use_strict

Add 'use strict' (or its equivalents) to all modules, or convince us that your favorite module is well-known enough and people can easily see the modules are strictly written.

Error: Geo::GDAL::Const, Geo::GNM

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

use_warnings

Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: Geo::GDAL::Const, Geo::GNM

has_separate_license_file

This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

Modules

Name Abstract Version View
Geo::GDAL Perl extension for the GDAL library for geospatial data 2.010002 metacpan
Geo::GDAL::Const metacpan
Geo::GNM metacpan
Geo::OGR 2.010002 metacpan
Geo::OSR metacpan

Provides

Name File View
Geo::GDAL::AsyncReader lib/Geo/GDAL.pm metacpan
Geo::GDAL::Band lib/Geo/GDAL.pm metacpan
Geo::GDAL::ColorTable lib/Geo/GDAL.pm metacpan
Geo::GDAL::Constc lib/Geo/GDAL/Const.pm metacpan
Geo::GDAL::Dataset lib/Geo/GDAL.pm metacpan
Geo::GDAL::Driver lib/Geo/GDAL.pm metacpan
Geo::GDAL::Extent lib/Geo/GDAL.pm metacpan
Geo::GDAL::GCP lib/Geo/GDAL.pm metacpan
Geo::GDAL::GDALBuildVRTOptions lib/Geo/GDAL.pm metacpan
Geo::GDAL::GDALDEMProcessingOptions lib/Geo/GDAL.pm metacpan
Geo::GDAL::GDALGridOptions lib/Geo/GDAL.pm metacpan
Geo::GDAL::GDALInfoOptions lib/Geo/GDAL.pm metacpan
Geo::GDAL::GDALNearblackOptions lib/Geo/GDAL.pm metacpan
Geo::GDAL::GDALRasterizeOptions lib/Geo/GDAL.pm metacpan
Geo::GDAL::GDALTranslateOptions lib/Geo/GDAL.pm metacpan
Geo::GDAL::GDALVectorTranslateOptions lib/Geo/GDAL.pm metacpan
Geo::GDAL::GDALWarpAppOptions lib/Geo/GDAL.pm metacpan
Geo::GDAL::GeoTransform lib/Geo/GDAL.pm metacpan
Geo::GDAL::MajorObject lib/Geo/GDAL.pm metacpan
Geo::GDAL::RasterAttributeTable lib/Geo/GDAL.pm metacpan
Geo::GDAL::Transformer lib/Geo/GDAL.pm metacpan
Geo::GDAL::VSIF lib/Geo/GDAL.pm metacpan
Geo::GDAL::XML lib/Geo/GDAL.pm metacpan
Geo::GDALc lib/Geo/GDAL.pm metacpan
Geo::GNM::GenericNetwork lib/Geo/GNM.pm metacpan
Geo::GNM::MajorObject lib/Geo/GNM.pm metacpan
Geo::GNM::Network lib/Geo/GNM.pm metacpan
Geo::GNMc lib/Geo/GNM.pm metacpan
Geo::OGR::DataSource lib/Geo/OGR.pm metacpan
Geo::OGR::Driver lib/Geo/OGR.pm metacpan
Geo::OGR::Feature lib/Geo/OGR.pm metacpan
Geo::OGR::FeatureDefn lib/Geo/OGR.pm metacpan
Geo::OGR::FieldDefn lib/Geo/OGR.pm metacpan
Geo::OGR::GeomFieldDefn lib/Geo/OGR.pm metacpan
Geo::OGR::Geometry lib/Geo/OGR.pm metacpan
Geo::OGR::Layer lib/Geo/OGR.pm metacpan
Geo::OGR::StyleTable lib/Geo/OGR.pm metacpan
Geo::OGRc lib/Geo/OGR.pm metacpan
Geo::OSR::CoordinateTransformation lib/Geo/OSR.pm metacpan
Geo::OSR::SpatialReference lib/Geo/OSR.pm metacpan
Geo::OSRc lib/Geo/OSR.pm metacpan

Other Files

Changes metacpan
Changes-in-the-API-in-2.0 metacpan
MANIFEST metacpan
META.json metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan