Kwalitee Issues

no_pax_headers

If you use Mac OS X >= 10.6, use gnu tar (/usr/bin/gnutar) to avoid PAX headers. It's also important to rename (shorten) long file names (>= 100 characters) in the distribution.

Error: PaxHeader/Geo-SpaceManager-0.93,PaxHeader/Geo-SpaceManager-0.93,Geo-SpaceManager-0.93/PaxHeader/Changes,Geo-SpaceManager-0.93/PaxHeader/Changes,Geo-SpaceManager-0.93/PaxHeader/lib,Geo-SpaceManager-0.93/PaxHeader/lib,Geo-SpaceManager-0.93/PaxHeader/LICENSE,Geo-SpaceManager-0.93/PaxHeader/LICENSE,Geo-SpaceManager-0.93/PaxHeader/Makefile.PL,Geo-SpaceManager-0.93/PaxHeader/Makefile.PL,Geo-SpaceManager-0.93/PaxHeader/MANIFEST,Geo-SpaceManager-0.93/PaxHeader/MANIFEST,Geo-SpaceManager-0.93/PaxHeader/META.yml,Geo-SpaceManager-0.93/PaxHeader/META.yml,Geo-SpaceManager-0.93/PaxHeader/README,Geo-SpaceManager-0.93/PaxHeader/README,Geo-SpaceManager-0.93/PaxHeader/t,Geo-SpaceManager-0.93/PaxHeader/t,Geo-SpaceManager-0.93/PaxHeader/Todo,Geo-SpaceManager-0.93/PaxHeader/Todo,Geo-SpaceManager-0.93/t/PaxHeader/01load.t,Geo-SpaceManager-0.93/t/PaxHeader/01load.t,Geo-SpaceManager-0.93/t/PaxHeader/02add.t,Geo-SpaceManager-0.93/t/PaxHeader/02add.t,Geo-SpaceManager-0.93/t/PaxHeader/03nearest.t,Geo-SpaceManager-0.93/t/PaxHeader/03nearest.t,Geo-SpaceManager-0.93/t/PaxHeader/04normal.t,Geo-SpaceManager-0.93/t/PaxHeader/04normal.t,Geo-SpaceManager-0.93/t/PaxHeader/05minimum.t,Geo-SpaceManager-0.93/t/PaxHeader/05minimum.t,Geo-SpaceManager-0.93/t/PaxHeader/06distance.t,Geo-SpaceManager-0.93/t/PaxHeader/06distance.t,Geo-SpaceManager-0.93/lib/PaxHeader/Geo,Geo-SpaceManager-0.93/lib/PaxHeader/Geo,Geo-SpaceManager-0.93/lib/Geo/PaxHeader/SpaceManager.pm,Geo-SpaceManager-0.93/lib/Geo/PaxHeader/SpaceManager.pm

has_meta_json

Add a META.json to the distribution. Your buildtool should be able to autogenerate it.

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

meta_yml_has_license

Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

meta_yml_has_repository_resource

Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).

Modules

Name Abstract Version View
Geo::SpaceManager Place rectangles without overlap 0.93 metacpan

Other Files

Changes metacpan
MANIFEST metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan