Kwalitee Issues

no_pod_errors

Remove the POD errors. You can check for POD errors automatically by including Test::Pod to your test suite.

Error: HTML-Widget-JavaScript-0.02/lib/HTML/Widget/JavaScript/Constraint/ASCII.pm -- Around line 50: Non-ASCII character seen before =encoding in 'Júnior,'. Assuming ISO8859-1 HTML-Widget-JavaScript-0.02/lib/HTML/Widget/JavaScript/Constraint/All.pm -- Around line 46: Non-ASCII character seen before =encoding in 'Júnior,'. Assuming ISO8859-1 HTML-Widget-JavaScript-0.02/lib/HTML/Widget/JavaScript/Constraint/AllOrNone.pm -- Around line 51: Non-ASCII character seen before =encoding in 'Júnior,'. Assuming ISO8859-1 HTML-Widget-JavaScript-0.02/lib/HTML/Widget/JavaScript/Constraint/Any.pm -- Around line 46: Non-ASCII character seen before =encoding in 'Júnior,'. Assuming ISO8859-1 HTML-Widget-JavaScript-0.02/lib/HTML/Widget/JavaScript/Constraint/Email.pm -- Around line 53: Non-ASCII character seen before =encoding in 'Júnior,'. Assuming ISO8859-1 HTML-Widget-JavaScript-0.02/lib/HTML/Widget/JavaScript/Constraint/Equal.pm -- Around line 46: Non-ASCII character seen before =encoding in 'Júnior,'. Assuming ISO8859-1 HTML-Widget-JavaScript-0.02/lib/HTML/Widget/JavaScript/Constraint/HTTP.pm -- Around line 50: Non-ASCII character seen before =encoding in 'Júnior,'. Assuming ISO8859-1 HTML-Widget-JavaScript-0.02/lib/HTML/Widget/JavaScript/Constraint/In.pm -- Around line 50: Non-ASCII character seen before =encoding in 'Júnior,'. Assuming ISO8859-1 HTML-Widget-JavaScript-0.02/lib/HTML/Widget/JavaScript/Constraint/Integer.pm -- Around line 50: Non-ASCII character seen before =encoding in 'Júnior,'. Assuming ISO8859-1 HTML-Widget-JavaScript-0.02/lib/HTML/Widget/JavaScript/Constraint/Length.pm -- Around line 61: Non-ASCII character seen before =encoding in 'Júnior,'. Assuming ISO8859-1 HTML-Widget-JavaScript-0.02/lib/HTML/Widget/JavaScript/Constraint/Printable.pm -- Around line 50: Non-ASCII character seen before =encoding in 'Júnior,'. Assuming ISO8859-1 HTML-Widget-JavaScript-0.02/lib/HTML/Widget/JavaScript/Constraint/Range.pm -- Around line 61: Non-ASCII character seen before =encoding in 'Júnior,'. Assuming ISO8859-1 HTML-Widget-JavaScript-0.02/lib/HTML/Widget/JavaScript/Constraint/String.pm -- Around line 50: Non-ASCII character seen before =encoding in 'Júnior,'. Assuming ISO8859-1 HTML-Widget-JavaScript-0.02/lib/HTML/Widget/JavaScript/Result.pm -- Around line 84: Non-ASCII character seen before =encoding in 'Júnior,'. Assuming ISO8859-1 HTML-Widget-JavaScript-0.02/lib/HTML/Widget/JavaScript.pm -- Around line 89: Non-ASCII character seen before =encoding in 'Júnior,'. Assuming ISO8859-1

has_meta_json

Add a META.json to the distribution. Your buildtool should be able to autogenerate it.

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

meta_yml_has_license

Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.

has_separate_license_file

This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

meta_yml_has_repository_resource

Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).

Modules

Name Abstract Version View
HTML::Widget::JavaScript Adds JavaScript validation to HTML::Widget 0.02 metacpan
HTML::Widget::JavaScript::Constraint::ASCII JavaScript ASCII Constraint 0.02 metacpan
HTML::Widget::JavaScript::Constraint::All JavaScript All Constraint 0.02 metacpan
HTML::Widget::JavaScript::Constraint::AllOrNone JavaScript AllOrNone Constraint 0.02 metacpan
HTML::Widget::JavaScript::Constraint::Any JavaScript Any Constraint 0.02 metacpan
HTML::Widget::JavaScript::Constraint::Email JavaScript Email Constraint 0.02 metacpan
HTML::Widget::JavaScript::Constraint::Equal JavaScript Equal Constraint 0.02 metacpan
HTML::Widget::JavaScript::Constraint::HTTP JavaScript HTTP Constraint 0.02 metacpan
HTML::Widget::JavaScript::Constraint::In JavaScript In Constraint 0.02 metacpan
HTML::Widget::JavaScript::Constraint::Integer JavaScript Integer Constraint 0.02 metacpan
HTML::Widget::JavaScript::Constraint::Length JavaScript Length Constraint 0.02 metacpan
HTML::Widget::JavaScript::Constraint::Printable JavaScript Printable Constraint 0.02 metacpan
HTML::Widget::JavaScript::Constraint::Range JavaScript Range Constraint 0.02 metacpan
HTML::Widget::JavaScript::Constraint::String JavaScript String Constraint 0.02 metacpan
HTML::Widget::JavaScript::Result Result Class which supports JavaScript parameter validation 0.02 metacpan

Other Files

Changes metacpan
MANIFEST metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan