Hubot

Prerequisites

Hubot declares the following 23 modules as prerequisites.

Listed PrerequisitesRequired VersionLatest DistKwalitee
AnyEvent0AnyEvent-7.07112.50
AnyEvent::Campfire::Client0AnyEvent-Campfire-Client-0.0.2128.13
AnyEvent::HTTP0AnyEvent-HTTP-2.21118.75
AnyEvent::HTTP::ScopedClient0AnyEvent-HTTP-ScopedClient-0.0.5131.25
AnyEvent::IRC::Client0AnyEvent-IRC-0.97134.38
Cwd0PathTools-3.47125.00
Encode0Encode-2.62128.13
File::Slurp0File-Slurp-9999.19121.88
Getopt::Long::Descriptive0Getopt-Long-Descriptive-0.097134.38
HTTP::Request0HTTP-Message-6.06131.25
Hubot::TextMessage0Hubot-0.2.7125.00
JSON::XS0JSON-XS-3.01115.63
LWP::Protocol::https0LWP-Protocol-https-6.06134.38
LWP::UserAgent0libwww-perl-6.08128.13
Moose0Moose-2.1210137.50
Pod::Usage0Pod-Usage-1.64118.75
Time::HiRes0Time-HiRes-1.9726128.13
Try::Tiny0Try-Tiny-0.22137.50
URI0URI-1.64134.38
URI::QueryParam0URI-1.64134.38
namespace::autoclean0namespace-autoclean-0.19137.50
strict0perl0.00
warnings0perl0.00

Hubot declares the following 1 modules as build prerequisites.

Listed Build PrerequisitesRequired VersionLatest DistKwalitee
Test::More0Test-Simple-1.001003131.25

Hubot declares the following 1 modules as optional prerequisites.

Listed Optional PrerequisitesRequired VersionLatest DistKwalitee
ExtUtils::MakeMaker6.30ExtUtils-MakeMaker-6.98134.375