Hubot

Prerequisites

Hubot declares the following 23 modules as prerequisites.

Listed PrerequisitesRequired VersionLatest DistKwalitee
AnyEvent0AnyEvent-7.08114.29
AnyEvent::Campfire::Client0AnyEvent-Campfire-Client-0.0.2125.71
AnyEvent::HTTP0AnyEvent-HTTP-2.21120.00
AnyEvent::HTTP::ScopedClient0AnyEvent-HTTP-ScopedClient-0.0.5128.57
AnyEvent::IRC::Client0AnyEvent-IRC-0.97131.43
Cwd0PathTools-3.47122.86
Encode0Encode-2.67125.71
File::Slurp0File-Slurp-9999.19120.00
Getopt::Long::Descriptive0Getopt-Long-Descriptive-0.098131.43
HTTP::Request0HTTP-Message-6.06128.57
Hubot::TextMessage0Hubot-0.2.7122.86
JSON::XS0JSON-XS-3.01117.14
LWP::Protocol::https0LWP-Protocol-https-6.06131.43
LWP::UserAgent0libwww-perl-6.08125.71
Moose0Moose-2.1403134.29
Pod::Usage0Pod-Usage-1.64117.14
Time::HiRes0Time-HiRes-1.9726125.71
Try::Tiny0Try-Tiny-0.22134.29
URI0URI-1.65131.43
URI::QueryParam0URI-1.65131.43
namespace::autoclean0namespace-autoclean-0.22134.29
strict0perl0.00
warnings0perl0.00

Hubot declares the following 1 modules as build prerequisites.

Listed Build PrerequisitesRequired VersionLatest DistKwalitee
Test::More0Test-Simple-1.001009128.57

Hubot declares the following 1 modules as optional prerequisites.

Listed Optional PrerequisitesRequired VersionLatest DistKwalitee
ExtUtils::MakeMaker6.30ExtUtils-MakeMaker-7.04131.428571428571