Kwalitee Issues

has_abstract_in_pod

Provide a short description in the NAME section of the pod (after the module name followed by a hyphen) at least for the main module of this distribution.

has_license_in_source_file

Add =head1 LICENSE and the text of the license to the main module in your code.

has_manifest

Add a MANIFEST to the distribution. Your buildtool should be able to autogenerate it (eg "make manifest" or "./Build manifest")

has_meta_yml

Add a META.yml to the distribution. Your buildtool should be able to autogenerate it.

has_tests

Add tests!

manifest_matches_dist

Run a proper command ("make manifest" or "./Build manifest", maybe with a force option), or use a distribution builder to generate the MANIFEST. Or update MANIFEST manually.

Error: Cannot find MANIFEST in dist.

package_version_matches_dist_version

Fix the version(s).

prereq_matches_use

List all used modules in META.yml requires

Error:

  • IDS::DataSource
  • IDS::Utils

use_strict

Add 'use strict' (or its equivalents) to all modules, or convince us that your favorite module is well-known enough and people can easily see the modules are strictly written.

Error: IDS::DataSource::HTTP, IDS::DataSource::HTTP::Params, IDS::DataSource::HTTP::Part

consistent_version

Split the distribution, or fix the version numbers to make them consistent (use the highest version number to avoid version downgrade).

Error: 1.0,2.0

has_known_license_in_source_file

Add =head1 LICENSE and/or the proper text of the well-known license to the main module in your code.

has_meta_json

Add a META.json to the distribution. Your buildtool should be able to autogenerate it.

has_tests_in_t_dir

Add tests or move tests.pl to the t/ directory!

meta_yml_has_license

Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.

use_warnings

Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: IDS::DataSource::HTTP::Params

Modules

Name Abstract Version View
IDS::DataSource::HTTP 2.0 metacpan
IDS::DataSource::HTTP::Accept 1.0 metacpan
IDS::DataSource::HTTP::AcceptParams 1.0 metacpan
IDS::DataSource::HTTP::Agent 1.0 metacpan
IDS::DataSource::HTTP::Authorization 1.0 metacpan
IDS::DataSource::HTTP::CacheControl 1.0 metacpan
IDS::DataSource::HTTP::Charset 1.0 metacpan
IDS::DataSource::HTTP::Cookie 1.0 metacpan
IDS::DataSource::HTTP::Date 1.0 metacpan
IDS::DataSource::HTTP::ETag 1.0 metacpan
IDS::DataSource::HTTP::EmailAddr 1.0 metacpan
IDS::DataSource::HTTP::Encoding 1.0 metacpan
IDS::DataSource::HTTP::Expectation 1.0 metacpan
IDS::DataSource::HTTP::Host 1.0 metacpan
IDS::DataSource::HTTP::IfModifiedSince 1.0 metacpan
IDS::DataSource::HTTP::IfRange 1.0 metacpan
IDS::DataSource::HTTP::Int 1.0 metacpan
IDS::DataSource::HTTP::Language 1.0 metacpan
IDS::DataSource::HTTP::MD5 1.0 metacpan
IDS::DataSource::HTTP::MethodLine 1.0 metacpan
IDS::DataSource::HTTP::Params 1.0 metacpan
IDS::DataSource::HTTP::Part 2.0 metacpan
IDS::DataSource::HTTP::Range 1.0 metacpan
IDS::DataSource::HTTP::Referer 1.0 metacpan
IDS::DataSource::HTTP::Request 2.0 metacpan
IDS::DataSource::HTTP::RetryAfter 1.0 metacpan
IDS::DataSource::HTTP::URI 1.0 metacpan
IDS::DataSource::HTTP::URIAuthority 1.0 metacpan
IDS::DataSource::HTTP::URIPath 1.0 metacpan
IDS::DataSource::HTTP::Via 1.0 metacpan
IDS::DataSource::HTTP::XForwarded 1.0 metacpan

Other Files

Changes metacpan
Makefile.PL metacpan
README metacpan