Kwalitee Issues


Take a look at the META.yml Spec at (for version 1.4) or (for version 2), and change your META.yml accordingly.

Error: Expected a list structure (author) [Validation: 1.3];Expected a map structure from string or file. (requires) [Validation: 1.3];License '<undef>' is invalid (license) [Validation: 1.3];Missing mandatory field, 'abstract' (abstract) [Validation: 1.3];Missing mandatory field, 'author' (author) [Validation: 1.3];Missing mandatory field, 'license' (license) [Validation: 1.3];value is an undefined string (abstract) [Validation: 1.3]


Remove the POD errors. You can check for POD errors automatically by including Test::Pod to your test suite.

Error: IPTables-IPv4-DBTarpit-0.44/Tools/ -- Around line 527: =cut found outside a pod block. Skipping to next block. IPTables-IPv4-DBTarpit-0.44/libdbtarpit.pod -- Around line 41: You can't have =items (as at line 67) unless the first thing after the =over is an =item


Add 'use strict' (or its equivalents) to all modules, or convince us that your favorite module is well-known enough and people can easily see the modules are strictly written.

Error: IPTables::IPv4::DBTarpit


Split the distribution, or fix the version numbers to make them consistent (use the highest version number to avoid version downgrade).

Error: 0.06,0.44,1.14


Add a META.json to the distribution. Your buildtool should be able to autogenerate it.


If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.


Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.


Move your *.pm files in a directory named 'lib'. The directory structure should look like 'lib/Your/' for a module named 'Your::Module'. If you need to provide additional files, e.g. for testing, that should not be considered for Kwalitee, then you should look at the 'provides' map in META.yml to limit the files scanned; or use the 'no_index' map to exclude parts of the distribution.

Error:,, Tools/


Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: IPTables::IPv4::DBTarpit, IPTables::IPv4::DBTarpit::CTest, IPTables::IPv4::DBTarpit::Inst, IPTables::IPv4::DBTarpit::Tools


This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.


Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.


Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).


Name Abstract Version View
IPTables::IPv4::DBTarpit 0.44 metacpan
IPTables::IPv4::DBTarpit::CTest metacpan
IPTables::IPv4::DBTarpit::Inst support for installation 0.06 metacpan
IPTables::IPv4::DBTarpit::Tools to manipulate tarpit database 1.14 metacpan

Other Files

Changes metacpan
MANIFEST metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan
Tools/MANIFEST metacpan
Tools/Makefile.PL metacpan