Kwalitee Issues

prereq_matches_use

List all used modules in META.yml requires

Error:

  • Carp
  • Exporter
  • strict
  • vars

consistent_version

Split the distribution, or fix the version numbers to make them consistent (use the highest version number to avoid version downgrade).

Error: 0.02,0.03,0.08

has_meta_json

Add a META.json to the distribution. Your buildtool should be able to autogenerate it.

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

use_warnings

Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: JavaScript::Code, JavaScript::Code::Accessor, JavaScript::Code::Array, JavaScript::Code::Block, JavaScript::Code::Condition, JavaScript::Code::Element, JavaScript::Code::Expression, JavaScript::Code::Expression::Arithmetic, JavaScript::Code::Expression::Boolean, JavaScript::Code::Expression::Node, JavaScript::Code::Expression::Node::Arithmetic, JavaScript::Code::Expression::Node::Boolean, JavaScript::Code::Expression::Op, JavaScript::Code::Expression::Op::Addition, JavaScript::Code::Expression::Op::And, JavaScript::Code::Expression::Op::Division, JavaScript::Code::Expression::Op::Equal, JavaScript::Code::Expression::Op::Greater, JavaScript::Code::Expression::Op::GreaterEqual, JavaScript::Code::Expression::Op::Less, JavaScript::Code::Expression::Op::LessEqual, JavaScript::Code::Expression::Op::Multiplication, JavaScript::Code::Expression::Op::Not, JavaScript::Code::Expression::Op::NotEqual, JavaScript::Code::Expression::Op::Or, JavaScript::Code::Expression::Op::Subtraction, JavaScript::Code::Expression::Op::Term, JavaScript::Code::Function, JavaScript::Code::Function::BuildIn, JavaScript::Code::Function::Result, JavaScript::Code::Function::Result::Element, JavaScript::Code::Hash, JavaScript::Code::Number, JavaScript::Code::String, JavaScript::Code::Type, JavaScript::Code::Value, JavaScript::Code::Variable

build_prereq_matches_use

List all modules used in the test suite in META.yml build_requires

Error:

  • Test::More
  • strict
  • warnings

has_separate_license_file

This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.

meta_yml_has_repository_resource

Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).

Modules

Name Abstract Version View
JavaScript::Code A JavaScript Code Framework 0.08 metacpan
JavaScript::Code::Accessor A Accessor Class 0.08 metacpan
JavaScript::Code::Array A JavaScript Array Type 0.08 metacpan
JavaScript::Code::Block A JavaScript Block Element 0.08 metacpan
JavaScript::Code::Condition A JavaScript Condition 0.08 metacpan
JavaScript::Code::Element A JavaScript Hash 0.08 metacpan
JavaScript::Code::Expression A JavaScript Expression 0.08 metacpan
JavaScript::Code::Expression::Arithmetic A JavaScript Arithmetic Expression 0.08 metacpan
JavaScript::Code::Expression::Boolean A JavaScript Boolean Expression 0.08 metacpan
JavaScript::Code::Expression::Node Represents a Node in JavaScript Expression 0.08 metacpan
JavaScript::Code::Expression::Node::Arithmetic A Node For JavaScript Arithmetic Expressions 0.08 metacpan
JavaScript::Code::Expression::Node::Boolean A Node For JavaScript Boolean Expressions 0.08 metacpan
JavaScript::Code::Expression::Op 0.08 metacpan
JavaScript::Code::Expression::Op::Addition 0.02 metacpan
JavaScript::Code::Expression::Op::And 0.02 metacpan
JavaScript::Code::Expression::Op::Division 0.02 metacpan
JavaScript::Code::Expression::Op::Equal 0.02 metacpan
JavaScript::Code::Expression::Op::Greater 0.02 metacpan
JavaScript::Code::Expression::Op::GreaterEqual 0.02 metacpan
JavaScript::Code::Expression::Op::Less 0.02 metacpan
JavaScript::Code::Expression::Op::LessEqual 0.02 metacpan
JavaScript::Code::Expression::Op::Multiplication 0.02 metacpan
JavaScript::Code::Expression::Op::Not 0.02 metacpan
JavaScript::Code::Expression::Op::NotEqual 0.02 metacpan
JavaScript::Code::Expression::Op::Or 0.02 metacpan
JavaScript::Code::Expression::Op::Subtraction 0.02 metacpan
JavaScript::Code::Expression::Op::Term 0.03 metacpan
JavaScript::Code::Function A JavaScript Function 0.08 metacpan
JavaScript::Code::Function::BuildIn JavaScript Build-In Functions 0.08 metacpan
JavaScript::Code::Function::Result A JavaScript Function Result 0.08 metacpan
JavaScript::Code::Function::Result::Element A JavaScript Function Result Element 0.08 metacpan
JavaScript::Code::Hash 0.08 metacpan
JavaScript::Code::Number A JavaScript Number Type 0.08 metacpan
JavaScript::Code::String A JavaScript String Type 0.08 metacpan
JavaScript::Code::Type A JavaScript Type 0.08 metacpan
JavaScript::Code::Value A JavaScript Value 0.08 metacpan
JavaScript::Code::Variable A JavaScript Variable Element 0.08 metacpan

Other Files

Build.PL metacpan
MANIFEST metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan