Kwalitee Issues


Upgrade the bundled version of Module::Install to at least 0.89, but preferably to the most current release. Alternatively, you can switch to another build system / installer that does not suffer from this problem. (ExtUtils::MakeMaker, Module::Build both of which have their own set of problems.)


Add a META.json to the distribution. Your buildtool should be able to autogenerate it.


If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.


This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.


Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.


Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).


Name Abstract Version View
Jifty::Plugin::Authentication::Ldap LDAP Authentication Plugin for Jifty 1.01 metacpan
Jifty::Plugin::Authentication::Ldap::Action::LDAPLogin process LDAP login plugin metacpan
Jifty::Plugin::Authentication::Ldap::Action::LDAPLogout process LDAP logout plugin metacpan
Jifty::Plugin::Authentication::Ldap::Dispatcher metacpan
Jifty::Plugin::Authentication::Ldap::Mixin::Model::User Ldap mixin with User model metacpan
Jifty::Plugin::Authentication::Ldap::View provides templates for the pages and forms used by the ldap authentication plugin. metacpan

Other Files

Changes metacpan
MANIFEST metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan