KiokuDB

Prerequisites

KiokuDB declares the following 54 modules as prerequisites.

Listed PrerequisitesRequired VersionLatest DistKwalitee
B0perl0.00
B::Deparse0perl0.00
Cache::Ref0.02Cache-Ref-0.04128.57
Carp0Carp-1.3301125.71
Class::Load0Class-Load-0.22134.29
Data::Stream::Bulk0.08Data-Stream-Bulk-0.11131.43
Data::Stream::Bulk::Util0Data-Stream-Bulk-0.11131.43
Data::Swap0Data-Swap-0.08134.29
Data::UUID1.203Data-UUID-1.220122.86
Data::Visitor0.24Data-Visitor-0.30131.43
Digest::SHA0Digest-SHA-5.93134.29
Encode0Encode-2.67125.71
Hash::Util::FieldHash::Compat0Hash-Util-FieldHash-Compat-0.08134.29
IO::Handle0IO-1.25125.71
JSON2.12JSON-2.90128.57
JSON::XS2.231JSON-XS-3.01117.14
List::Util0Scalar-List-Utils-1.41125.71
Module::Pluggable::Object0Module-Pluggable-5.1117.14
Moose2.0000Moose-2.1403134.29
Moose::Exporter0Moose-2.1403134.29
Moose::Role0Moose-2.1403134.29
Moose::Util0Moose-2.1403134.29
Moose::Util::MetaRole0Moose-2.1403134.29
Moose::Util::TypeConstraints0Moose-2.1403134.29
MooseX::Clone0.04MooseX-Clone-0.05122.86
MooseX::Clone::Meta::Attribute::Trait::NoClone0MooseX-Clone-0.05122.86
MooseX::Role::Parameterized0.10MooseX-Role-Parameterized-1.08134.29
MooseX::YAML0.04MooseX-YAML-0.04120.00
POSIX0perl0.00
PadWalker1.9PadWalker-2.0122.86
Path::Class0Path-Class-0.35128.57
Scalar::Util0Scalar-List-Utils-1.41125.71
Scope::Guard0Scope-Guard-0.20134.29
Search::GIN::Driver0Search-GIN-0.09134.29
Search::GIN::Extract0Search-GIN-0.09134.29
Search::GIN::Query::Class0.03Search-GIN-0.09134.29
Set::Object1.26Set-Object-1.34125.71
Storable0Storable-2.51111.43
Sub::Exporter0Sub-Exporter-0.987131.43
Symbol0perl0.00
Test::Exception0Test-Exception-0.35128.57
Test::Moose0Moose-2.1403134.29
Test::More0.88Test-Simple-1.001012122.86
Throwable0Throwable-0.200012131.43
Tie::RefHash0Tie-RefHash-1.39120.00
Tie::ToObject0Tie-ToObject-0.03117.14
Try::Tiny0Try-Tiny-0.22134.29
YAML::XS0.30YAML-LibYAML-0.55125.71
constant0constant-1.27128.57
namespace::clean0.08namespace-clean-0.25128.57
overload0perl0.00
strict0perl0.00
utf80perl0.00
warnings0perl0.00

KiokuDB declares the following 14 modules as build prerequisites.

Listed Build PrerequisitesRequired VersionLatest DistKwalitee
Cache::Ref::CART0Cache-Ref-0.04128.57
Cache::Ref::CLOCK0Cache-Ref-0.04128.57
Data::Dumper0Data-Dumper-2.154108.57
Data::Stream::Bulk::Callback0Data-Stream-Bulk-0.11131.43
File::Spec0PathTools-3.47122.86
IO::Handle0IO-1.25125.71
IPC::Open30perl0.00
Search::GIN::Driver::Hash0Search-GIN-0.09134.29
Search::GIN::Extract::Class0Search-GIN-0.09134.29
Search::GIN::Extract::Delegate0Search-GIN-0.09134.29
Test::More0.88Test-Simple-1.001012122.86
base0base-2.18111.43
if0if-0.0601105.71
perl5.006perl0.00

KiokuDB declares the following 1 modules as optional prerequisites.

Listed Optional PrerequisitesRequired VersionLatest DistKwalitee
ExtUtils::MakeMaker6.30ExtUtils-MakeMaker-7.04131.428571428571