Kwalitee Issues

has_license_in_source_file

Add =head1 LICENSE and the text of the license to the main module in your code.

has_meta_yml

Add a META.yml to the distribution. Your buildtool should be able to autogenerate it.

has_tests

Add tests!

no_pod_errors

Remove the POD errors. You can check for POD errors automatically by including Test::Pod to your test suite.

Error: Krb4-1.1/Krb4.pm -- Around line 177: Expected text after =item, not a bulletAround line 182: Expected text after =item, not a bulletAround line 186: Expected text after =item, not a bulletAround line 195: Expected text after =item, not a bulletAround line 199: Expected text after =item, not a bulletAround line 203: Expected text after =item, not a bulletAround line 207: Expected text after =item, not a bulletAround line 212: Expected text after =item, not a bulletAround line 216: Expected text after =item, not a bulletAround line 220: Expected text after =item, not a bulletAround line 224: Expected text after =item, not a bulletAround line 229: Expected text after =item, not a bulletAround line 233: Expected text after =item, not a bulletAround line 241: Expected text after =item, not a bulletAround line 245: Expected text after =item, not a bulletAround line 249: Expected text after =item, not a bulletAround line 253: Expected text after =item, not a bulletAround line 258: Expected text after =item, not a bulletAround line 262: Expected text after =item, not a bulletAround line 266: Expected text after =item, not a bulletAround line 270: Expected text after =item, not a bulletAround line 274: Expected text after =item, not a bulletAround line 278: Expected text after =item, not a bullet

prereq_matches_use

List all used modules in META.yml requires

Error:

  • strict
  • vars

has_known_license_in_source_file

Add =head1 LICENSE and/or the proper text of the well-known license to the main module in your code.

has_meta_json

Add a META.json to the distribution. Your buildtool should be able to autogenerate it.

has_tests_in_t_dir

Add tests or move tests.pl to the t/ directory!

meta_yml_has_license

Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.

use_warnings

Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: Authen::Krb4

Modules

Name Abstract Version View
Authen::Krb4 Perl extension for Kerberos 4 1.1 metacpan

Other Files

Changes metacpan
MANIFEST metacpan
Makefile.PL metacpan
README metacpan