The site is under maintenance.

Most probably the CPANTS databases are being regenerated from scratch behind the scenes due to the major change in Kwalitee metrics or the update of relevant modules/perl. Usually this maintenance takes about a day or two, and some of the information may be old or missing tentatively. Sorry for the inconvenience.

LWP-Authen-Wsse

Metadata

Analyzed metadata and errors of LWP-Authen-Wsse.

{
   "abstracts" : {
      "LWP::Authen::Wsse" : "Library for enabling X-WSSE authentication in LWP"
   },
   "author" : "AUTRIJUS",
   "buildfile_executable" : 0,
   "dir_lib" : "lib",
   "dir_t" : "t",
   "dirs_array" : [
      "lib",
      "lib/LWP",
      "lib/LWP/Authen",
      "t",
      "inc",
      "inc/Module",
      "inc/Module/Install"
   ],
   "dist" : "LWP-Authen-Wsse",
   "dynamic_config" : 0,
   "error" : {
      "valid_signature" : "WARNING: This key is not certified with a trusted signature!\nPrimary key fingerprint: 66B2 B78E D1B7 7641 4861  D592 B4B3 DD37 3C35 01A0\n"
   },
   "extension" : "tar.gz",
   "extractable" : 1,
   "extracts_nicely" : 1,
   "file__build" : 0,
   "file_blib" : 0,
   "file_build" : 0,
   "file_changelog" : "Changes",
   "file_makefile" : 0,
   "file_makefile_pl" : "Makefile.PL",
   "file_manifest" : "MANIFEST",
   "file_meta_yml" : "META.yml",
   "file_pm_to_blib" : 0,
   "file_readme" : "README",
   "file_signature" : "SIGNATURE",
   "files_array" : [
      "README",
      "Changes",
      "Makefile.PL",
      "META.yml",
      "SIGNATURE",
      "MANIFEST",
      "lib/LWP/Authen/Wsse.pm"
   ],
   "files_hash" : {
      "Changes" : {
         "mtime" : 1135613170,
         "size" : 403
      },
      "MANIFEST" : {
         "mtime" : 1135614062,
         "size" : 335
      },
      "META.yml" : {
         "mtime" : 1135614095,
         "size" : 329
      },
      "Makefile.PL" : {
         "mtime" : 1135613874,
         "size" : 272,
         "used" : [
            "inc::Module::Install",
            "strict"
         ]
      },
      "README" : {
         "mtime" : 1135613901,
         "size" : 670
      },
      "SIGNATURE" : {
         "mtime" : 1135614102,
         "size" : 1716
      },
      "inc/Module/Install.pm" : {
         "mtime" : 1135614094,
         "no_index" : 1,
         "size" : 5228
      },
      "inc/Module/Install/Base.pm" : {
         "mtime" : 1135614095,
         "no_index" : 1,
         "size" : 1033
      },
      "inc/Module/Install/Can.pm" : {
         "mtime" : 1135614095,
         "no_index" : 1,
         "size" : 1695
      },
      "inc/Module/Install/Fetch.pm" : {
         "mtime" : 1135614095,
         "no_index" : 1,
         "size" : 2455
      },
      "inc/Module/Install/Makefile.pm" : {
         "mtime" : 1135614095,
         "no_index" : 1,
         "size" : 4069
      },
      "inc/Module/Install/Metadata.pm" : {
         "mtime" : 1135614095,
         "no_index" : 1,
         "size" : 7198
      },
      "inc/Module/Install/Win32.pm" : {
         "mtime" : 1135614095,
         "no_index" : 1,
         "size" : 1946
      },
      "inc/Module/Install/WriteAll.pm" : {
         "mtime" : 1135614095,
         "no_index" : 1,
         "size" : 854
      },
      "lib/LWP/Authen/Wsse.pm" : {
         "license" : "Perl_5",
         "module" : "LWP::Authen::Wsse",
         "mtime" : 1135614093,
         "size" : 4057,
         "used" : [
            "5.004",
            "Digest::SHA1",
            "English",
            "MIME::Base64",
            "constant",
            "strict",
            "warnings"
         ]
      },
      "t/1-basic.t" : {
         "mtime" : 1135614053,
         "no_index" : 1,
         "required" : [
            "LWP::Authen::Wsse"
         ],
         "size" : 109,
         "used" : [
            "Test",
            "strict"
         ]
      }
   },
   "got_prereq_from" : "META.yml",
   "kwalitee" : {
      "buildtool_not_executable" : 1,
      "consistent_version" : 1,
      "easily_repackageable_by_debian" : 1,
      "easily_repackageable_by_fedora" : 1,
      "extractable" : 1,
      "extracts_nicely" : 1,
      "fits_fedora_license" : 1,
      "has_abstract_in_pod" : 1,
      "has_buildtool" : 1,
      "has_changelog" : 1,
      "has_human_readable_license" : 1,
      "has_known_license_in_source_file" : 1,
      "has_license_in_source_file" : 1,
      "has_manifest" : 1,
      "has_meta_yml" : 1,
      "has_proper_version" : 1,
      "has_readme" : 1,
      "has_separate_license_file" : 0,
      "has_tests" : 1,
      "has_tests_in_t_dir" : 1,
      "has_version" : 1,
      "kwalitee" : "97.56",
      "manifest_matches_dist" : 1,
      "metayml_conforms_to_known_spec" : 1,
      "metayml_declares_perl_version" : 1,
      "metayml_has_license" : 1,
      "metayml_has_provides" : 0,
      "metayml_is_parsable" : 1,
      "no_abstract_stub_in_pod" : 1,
      "no_broken_auto_install" : 1,
      "no_broken_module_install" : 0,
      "no_dot_dirs" : 1,
      "no_dot_underscore_files" : 1,
      "no_generated_files" : 1,
      "no_invalid_versions" : 1,
      "no_local_dirs" : 1,
      "no_mymeta_files" : 1,
      "no_pax_headers" : 1,
      "no_pod_errors" : 1,
      "no_stdin_for_prompting" : 1,
      "no_symlinks" : 1,
      "package_version_matches_dist_version" : 1,
      "portable_filenames" : 1,
      "proper_libs" : 1,
      "use_strict" : 1,
      "use_warnings" : 1,
      "valid_signature" : 1
   },
   "latest_mtime" : 1135614102,
   "license" : "perl defined in META.yml",
   "license_file" : "lib/LWP/Authen/Wsse.pm",
   "license_from_yaml" : "perl",
   "license_in_pod" : 1,
   "license_type" : "Perl_5",
   "licenses" : {
      "Perl_5" : [
         "lib/LWP/Authen/Wsse.pm"
      ]
   },
   "manifest_matches_dist" : 1,
   "meta_yml" : {
      "abstract" : "Library for enabling X-WSSE authentication in LWP",
      "author" : "Audrey Tang <audrey@audrey.org>",
      "distribution_type" : "module",
      "generated_by" : "Module::Install version 0.50",
      "license" : "perl",
      "meta-spec" : {},
      "name" : "LWP-Authen-Wsse",
      "no_index" : {
         "directory" : [
            "inc",
            "t"
         ]
      },
      "requires" : {
         "Digest::SHA1" : "0",
         "LWP" : "0",
         "MIME::Base64" : "0",
         "perl" : "5.004"
      },
      "version" : "0.05"
   },
   "metayml_is_parsable" : 1,
   "module_install" : {
      "broken" : 1,
      "version" : "0.50"
   },
   "modules" : [
      {
         "file" : "lib/LWP/Authen/Wsse.pm",
         "in_basedir" : 0,
         "in_lib" : 1,
         "module" : "LWP::Authen::Wsse"
      }
   ],
   "no_index" : "^inc/;^t/",
   "no_pax_headers" : 1,
   "package" : "LWP-Authen-Wsse-0.05.tar.gz",
   "prereq" : [
      {
         "is_prereq" : 1,
         "requires" : "perl",
         "type" : "runtime_requires",
         "version" : "5.004"
      },
      {
         "is_prereq" : 1,
         "requires" : "MIME::Base64",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "Digest::SHA1",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "LWP",
         "type" : "runtime_requires",
         "version" : "0"
      }
   ],
   "released_epoch" : 1135614195,
   "size_packed" : 11412,
   "size_unpacked" : 32369,
   "uses" : {
      "used_in_code" : {
         "5.004" : 1,
         "Digest::SHA1" : 1,
         "English" : 1,
         "MIME::Base64" : 1,
         "constant" : 1,
         "strict" : 1,
         "warnings" : 1
      },
      "used_in_config" : {
         "inc::Module::Install" : 1,
         "strict" : 1
      },
      "used_in_tests" : {
         "Test" : 1,
         "strict" : 1
      }
   },
   "valid_signature" : 0,
   "version" : "0.05",
   "versions" : {
      "lib/LWP/Authen/Wsse.pm" : {
         "LWP::Authen::Wsse" : "0.05"
      }
   },
   "vname" : "LWP-Authen-Wsse-0.05"
}