Kwalitee Issues


Take a look at the META.yml Spec at (for version 1.4) or (for version 2), and change your META.yml accordingly.

Error: Expected a list structure (author) [Validation: 1.3];License '<undef>' is invalid (license) [Validation: 1.3];Missing mandatory field, 'abstract' (abstract) [Validation: 1.3];Missing mandatory field, 'author' (author) [Validation: 1.3];Missing mandatory field, 'license' (license) [Validation: 1.3];value is an undefined string (abstract) [Validation: 1.3]


Remove the POD errors. You can check for POD errors automatically by including Test::Pod to your test suite.

Error: LaBrea-Tarpit-1.36/DShield/ -- Around line 481: You forgot a '=back' before '=head1' LaBrea-Tarpit-1.36/ -- Around line 411: You can't have =items (as at line 740) unless the first thing after the =over is an =item


Split the distribution, or fix the version numbers to make them consistent (use the highest version number to avoid version downgrade).

Error: 0.01,0.06,0.08,1.05,1.16,1.36


Add a META.json to the distribution. Your buildtool should be able to autogenerate it.


If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.


Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.


Move your *.pm files in a directory named 'lib'. The directory structure should look like 'lib/Your/' for a module named 'Your::Module'. If you need to provide additional files, e.g. for testing, that should not be considered for Kwalitee, then you should look at the 'provides' map in META.yml to limit the files scanned; or use the 'no_index' map to exclude parts of the distribution.

Error:,, DShield/, Get/, Report/, Util/


Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: LaBrea::NetIO, LaBrea::Tarpit, LaBrea::Tarpit::DShield, LaBrea::Tarpit::Get, LaBrea::Tarpit::Report, LaBrea::Tarpit::Util


This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.


Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.


Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).


Name Abstract Version View
LaBrea::NetIO 0.01 metacpan
LaBrea::Tarpit Utilities and web displays for Tom Liston's LaBrea scanner/worm disruptor 1.36 metacpan
LaBrea::Tarpit::DShield 0.08 metacpan
LaBrea::Tarpit::Get 1.05 metacpan
LaBrea::Tarpit::Report tarpit log analysis and report 1.16 metacpan
LaBrea::Tarpit::Util 0.06 metacpan

Other Files

Changes metacpan
DShield/MANIFEST metacpan
DShield/Makefile.PL metacpan
Get/MANIFEST metacpan
Get/Makefile.PL metacpan
MANIFEST metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan
Report/MANIFEST metacpan
Report/Makefile.PL metacpan
Util/MANIFEST metacpan
Util/Makefile.PL metacpan