Kwalitee Issues

use_strict

Add 'use strict' (or its equivalents) to all modules, or convince us that your favorite module is well-known enough and people can easily see the modules are strictly written.

Error: Language::Expr::Parser

use_warnings

Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: Language::Expr::Parser

build_prereq_matches_use

List all modules used in the test suite in META.yml build_requires

Error:

  • Language::Expr::Compiler::JS
  • Language::Expr::Compiler::Perl
  • Pod::Coverage::TrustPod
  • Test::Pod
  • Test::Pod::Coverage

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

Modules

Name Abstract Version View
Language::Expr Simple minilanguage for use in expression 0.29 metacpan
Language::Expr::Compiler::Base Base class for Expr compilers 0.29 metacpan
Language::Expr::Compiler::js Compile Language::Expr expression to JavaScript 0.29 metacpan
Language::Expr::Compiler::perl Compile Language::Expr expression to Perl 0.29 metacpan
Language::Expr::CompilerRole Role for Language::Expr::Compiler::* 0.29 metacpan
Language::Expr::EvaluatorRole Specification for Language::Expr interpreter/compiler 0.29 metacpan
Language::Expr::Interpreter::Base Base class for Language::Expr interpreters 0.29 metacpan
Language::Expr::Interpreter::default A default interpreter for Language::Expr 0.29 metacpan
Language::Expr::Interpreter::dummy Dummy interpreter for Language::Expr (used for testing) 0.29 metacpan
Language::Expr::Interpreter::var_enumer Enumerate variables mentioned in Language::Expr expression 0.29 metacpan
Language::Expr::InterpreterRole Role for Language::Expr::Interpreter::* 0.29 metacpan
Language::Expr::JS Evaluate Expr JavaScript code 0.29 metacpan
Language::Expr::Parser Parse Language::Expr expression 0.29 metacpan

Other Files

Changes metacpan
MANIFEST metacpan
META.json metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan
dist.ini metacpan